summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-22 11:14:31 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-22 11:14:31 +0000
commit9af1b293fb82f11ce6f093843da449d00bb7d8c9 (patch)
treea6fe724c93332f03901109e05aed8435242994d3 /media-video/subtitleeditor
parentUpdate ebuild to EAPI 5. Specify LICENSE more precisely. (diff)
downloadgentoo-2-9af1b293fb82f11ce6f093843da449d00bb7d8c9.tar.gz
gentoo-2-9af1b293fb82f11ce6f093843da449d00bb7d8c9.tar.bz2
gentoo-2-9af1b293fb82f11ce6f093843da449d00bb7d8c9.zip
Fix compat with latest gstreamermm, also fixing bug #501862 by Mark Purtill, drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog13
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch30
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch16
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.41.0-r1.ebuild (renamed from media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild)47
4 files changed, 76 insertions, 30 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index 850eff729c8c..a3e850bd8ad4 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/subtitleeditor
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.24 2013/12/08 19:17:56 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.25 2014/02/22 11:14:31 pacho Exp $
+
+*subtitleeditor-0.41.0-r1 (22 Feb 2014)
+
+ 22 Feb 2014; Pacho Ramos <pacho@gentoo.org>
+ +files/subtitleeditor-0.41.0-keyframe-generation.patch,
+ +files/subtitleeditor-0.41.0-textoverlay.patch,
+ +subtitleeditor-0.41.0-r1.ebuild, -subtitleeditor-0.40.0.ebuild:
+ Fix compat with latest gstreamermm, also fixing bug #501862 by Mark Purtill,
+ drop old
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> subtitleeditor-0.41.0.ebuild:
x86 stable, bug #478252
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch
new file mode 100644
index 000000000000..b347d4ce4261
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-keyframe-generation.patch
@@ -0,0 +1,30 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Prevent crash when generating keyframes with gstreamermm 0.10.11
+--- a/plugins/actions/keyframesmanagement/keyframesgenerator.cc
++++ b/plugins/actions/keyframesmanagement/keyframesgenerator.cc
+@@ -87,12 +87,20 @@
+ if(structure_name.find("video") == Glib::ustring::npos)
+ return Glib::RefPtr<Gst::Element>(NULL);
+
+- Glib::RefPtr<Gst::Bin> videobin = Glib::RefPtr<Gst::Bin>::cast_dynamic(
+- Gst::Parse::create_bin(
+- "ffmpegcolorspace ! fakesink name=vsink", true));
++ // ffmpegcolorspace
++ Glib::RefPtr<Gst::Element> conv = Gst::ElementFactory::create_element("ffmpegcolorspace", "conv");
++ // fakesink
++ Glib::RefPtr<Gst::FakeSink> vsink = Gst::FakeSink::create("vsink");
++ // videobin
++ Glib::RefPtr<Gst::Bin> videobin = Gst::Bin::create("videobin");
+
+- Glib::RefPtr<Gst::FakeSink> vsink = Glib::RefPtr<Gst::FakeSink>::cast_dynamic(
+- videobin->get_element("vsink"));
++ // Add and link
++ videobin->add(conv)->add(vsink);
++ conv->link_pads("src", vsink, "sink");
++
++ // Add sink pad to bin element
++ Glib::RefPtr<Gst::Pad> pad = conv->get_static_pad("sink");
++ videobin->add_pad(Gst::GhostPad::create(pad, "sink"));
+
+ vsink->set_sync(false);
+ vsink->property_silent() = true;
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch
new file mode 100644
index 000000000000..7a8552c7a71f
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.41.0-textoverlay.patch
@@ -0,0 +1,16 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Get textoverlay working with gstreamermm 0.10.11
+--- a/src/vp/gstplayer.cc
++++ b/src/vp/gstplayer.cc
+@@ -656,7 +656,10 @@
+ "Please check your GStreamer installation."), "ffmpegcolorspace"));
+ }
+ // textoverlay
+- textoverlay = Gst::ElementFactory::create_element("textoverlay", "overlay");
++ // Workaround to prevent getting a NULL pointer from the
++ // cast_dynamic(textoverlay) call under gstreamermm 0.10.11
++ textoverlay = Gst::TextOverlay::create("overlay");
++
+ if(!textoverlay)
+ {
+ throw std::runtime_error(
diff --git a/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.41.0-r1.ebuild
index 35718ccd972b..18aeb7391529 100644
--- a/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild
+++ b/media-video/subtitleeditor/subtitleeditor-0.41.0-r1.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild,v 1.5 2012/05/04 00:50:42 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.41.0-r1.ebuild,v 1.1 2014/02/22 11:14:31 pacho Exp $
-EAPI="4"
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
-inherit eutils versionator flag-o-matic
+inherit gnome2 versionator flag-o-matic
-DESCRIPTION="GTK+2 subtitle editing tool."
+DESCRIPTION="GTK+2 subtitle editing tool"
HOMEPAGE="http://home.gna.org/subtitleeditor/"
SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug nls opengl"
RDEPEND="
@@ -21,7 +23,7 @@ RDEPEND="
>=dev-cpp/glibmm-2.16.3:2
>=dev-cpp/libxmlpp-2.20:2.6
>=app-text/enchant-1.4
- >=dev-cpp/gstreamermm-0.10.4
+ >=dev-cpp/gstreamermm-0.10.6
>=media-libs/gst-plugins-good-0.10:0.10
>=media-plugins/gst-plugins-meta-0.10-r2:0.10
>=media-plugins/gst-plugins-pango-0.10:0.10
@@ -30,16 +32,19 @@ RDEPEND="
"
# gst-plugins-pango needed for text overlay
# gst-plugins-xvideo needed for video output
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+ virtual/pkgconfig
+"
src_prepare() {
- # bug #413843, https://gna.org/bugs/index.php?19709
- epatch "${FILESDIR}/${P}-glib-2.31.patch"
+ # Get textoverlay working with gstreamermm 0.10.11
+ epatch "${FILESDIR}/${P}-textoverlay.patch"
+
+ # Prevent crash when generating keyframes with gstreamermm 0.10.11
+ epatch "${FILESDIR}/${P}-keyframe-generation.patch"
+
+ gnome2_src_prepare
}
src_configure() {
@@ -48,22 +53,8 @@ src_configure() {
# Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
use debug && append-flags -DDEBUG
- econf \
+ gnome2_src_configure \
--disable-debug \
$(use_enable nls) \
$(use_enable opengl gl)
}
-
-src_install() {
- default
-
- # plugins are loaded without the help of libtool files
- find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
-}
-
-pkg_postinst() {
- ewarn
- ewarn "If ${PN} doesn't play some video format, please check your"
- ewarn "USE flags on media-plugins/gst-plugins-meta"
- ewarn
-}