summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-11 13:09:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-11 13:09:13 +0000
commit9bcb83d41bd59cb71473c2d2eadf6ff6607422b9 (patch)
tree37f918775313e2424383cc57078917719b503227 /media-video/subtitleeditor
parentfix vboxvideo kernel panic with 2.6.33, backporting trunk patch (diff)
downloadgentoo-2-9bcb83d41bd59cb71473c2d2eadf6ff6607422b9.tar.gz
gentoo-2-9bcb83d41bd59cb71473c2d2eadf6ff6607422b9.tar.bz2
gentoo-2-9bcb83d41bd59cb71473c2d2eadf6ff6607422b9.zip
Add patch from upstream to fix building with OpenGL enabled. Thanks to Nikoli in bug #308937.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog7
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch11
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild5
3 files changed, 21 insertions, 2 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index be2e85dba80c..92b86db4f395 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.5 2010/03/10 20:50:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.6 2010/03/11 13:09:12 flameeyes Exp $
+
+ 11 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ subtitleeditor-0.36.0.ebuild, +files/subtitleeditor-0.36.0-r681.patch:
+ Add patch from upstream to fix building with OpenGL enabled. Thanks to
+ Nikoli in bug #308937.
*subtitleeditor-0.36.0 (10 Mar 2010)
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch b/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch
new file mode 100644
index 000000000000..8b3db12769b0
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.36.0-r681.patch
@@ -0,0 +1,11 @@
+--- src/we/waveformrenderergl.cc (revisione 680)
++++ src/we/waveformrenderergl.cc (revisione 681)
+@@ -722,7 +722,7 @@
+ int text_width = get_text_width("0:00:00");
+
+ float margin = text_width + text_width * 0.5;
+- while(get_pos_by_time(sec_1) < marker)
++ while(get_pos_by_time(sec_1) < margin)
+ {
+ // for a sufficiently long duration sec_* will overflow before
+ // the loop terminates. check the largest of them.
diff --git a/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild
index 5cceabc113d0..63040f6d898f 100644
--- a/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild
+++ b/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild,v 1.1 2010/03/10 20:50:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.36.0.ebuild,v 1.2 2010/03/11 13:09:12 flameeyes Exp $
EAPI="2"
@@ -38,6 +38,9 @@ DEPEND="${RDEPEND}
src_prepare() {
# Fix intltoolize broken file, see upstream #577133
sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+
+ # bug #308937
+ epatch "${FILESDIR}"/${P}-r681.patch
}
src_configure() {