summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2006-05-05 08:26:52 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2006-05-05 08:26:52 +0000
commit772e5dbd13cfa56151460139173a035ec3a4aa30 (patch)
treea0c688b8d9e2712677265d452b199fbf7d88b661 /media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
parenteven more new plugins in 0.10.3 release (diff)
downloadgentoo-2-772e5dbd13cfa56151460139173a035ec3a4aa30.tar.gz
gentoo-2-772e5dbd13cfa56151460139173a035ec3a4aa30.tar.bz2
gentoo-2-772e5dbd13cfa56151460139173a035ec3a4aa30.zip
added gcc3.4 patch for 0.6.4.2 and new ebuild for 0.6.5 see ChangeLog for details
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild')
-rw-r--r--media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild b/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
new file mode 100644
index 000000000000..693bc243fb9b
--- /dev/null
+++ b/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitler-yuv/subtitler-yuv-0.6.5.ebuild,v 1.1 2006/05/05 08:26:52 lordvan Exp $
+
+inherit eutils
+
+DESCRIPTION="for mjpegtools for adding subtitles, pictures, and effects embedded in the picture"
+HOMEPAGE="http://home.zonnet.nl/panteltje/subtitles/"
+#SRC_URI="http://home.zonnet.nl/panteltje/subtitles/${P}.tgz"
+# using ibibio mirror as the webpage itself seems to be offline at the moment
+SRC_URI="http://www.ibiblio.org/pub/linux/apps/video/subtitler-yuv-0.6.5.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ # fix missing '\'
+ #cd ${S}; epatch ${FILESDIR}/${P}.patch
+ #cd ${S}; epatch ${FILESDIR}/gcc-3.4.patch
+}
+
+src_compile() {
+ emake CFLAGS="$CFLAGS" || die "emake failed"
+}
+
+src_install() {
+ dobin subtitler-yuv
+ dodoc CHANGES HOWTO_USE_THIS LICENSE README README.COLOR.PROCESSOR README.PPML
+ insinto /usr/share/${PN}
+ doins demo-yuv.ppml rose.ppm sun.ppm mp-arial-iso-8859-1.zip
+}