summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2007-01-08 12:58:01 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2007-01-08 12:58:01 +0000
commiteab145087a8e75308231842b8709aa383ce1dd69 (patch)
tree103d6c7c3e405102aac7d463e904aab65f2b688c /media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild
parentRemove old versions (diff)
downloadgentoo-2-eab145087a8e75308231842b8709aa383ce1dd69.tar.gz
gentoo-2-eab145087a8e75308231842b8709aa383ce1dd69.tar.bz2
gentoo-2-eab145087a8e75308231842b8709aa383ce1dd69.zip
Preparing for 2.6.19 and fixing the linux-mod-stuff, bugs #158609, #159520.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild')
-rw-r--r--media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild b/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild
index 0bcaee2a5f90..c686084a486c 100644
--- a/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild
+++ b/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild,v 1.1 2006/12/30 11:26:02 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/usb-pwc-re/usb-pwc-re-20061023.042702-r1.ebuild,v 1.2 2007/01/08 12:58:01 phosphan Exp $
-inherit linux-mod
+inherit linux-mod eutils
DESCRIPTION="Free Philips USB Webcam driver for Linux that supports VGA resolution, newer kernels and replaces the old pwcx module."
HOMEPAGE="http://www.saillard.org/pwc/"
@@ -20,13 +20,21 @@ RDEPEND=""
# linux-mod variables
BUILD_TARGETS="all"
+BUILD_PARAMS="KSRC=${KERNEL_DIR}"
MODULE_NAMES="pwc(media/video:)"
-CONFIG_CHECK="USB !USB_PWC"
+CONFIG_CHECK="USB VIDEO_V4L1_COMPAT !USB_PWC"
ERROR_USB="${P} requires Host-side USB support (CONFIG_USB)."
ERROR_USB_PWC="${P} requires the in-kernel version of the PWC driver to be disabled (CONFIG_USB_PWC)."
+ERROR_VIDEO_V4L1_COMPAT="{$P} requires support for the Video For Linux API 1 compatibility layer (CONFIG_VIDEO_V4L1_COMPAT)."
S=${WORKDIR}/pwc-v4l2-${MY_PV}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.h.patch
+}
+
pkg_setup() {
linux-mod_pkg_setup