summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-09 21:29:01 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-09 21:29:01 +0000
commit35538db89b934ab6f997ada966ed4ef490739893 (patch)
tree46c6c15677fb642606f2666b59171452981c33a5 /media-video/xine-ui
parentPatched for hppa. Added hppa to keywords. (diff)
downloadgentoo-2-35538db89b934ab6f997ada966ed4ef490739893.tar.gz
gentoo-2-35538db89b934ab6f997ada966ed4ef490739893.tar.bz2
gentoo-2-35538db89b934ab6f997ada966ed4ef490739893.zip
Version bump.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.191
-rw-r--r--media-video/xine-ui/xine-ui-0.9.19.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index fa68fb8b4168..2877fbcda3aa 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.26 2003/02/12 07:42:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.27 2003/03/09 21:29:01 agenkin Exp $
+
+*xine-ui-0.9.19 (09 Mar 2003)
+
+ 09 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ New version.
*xine-ui-0.9.18 (30 Jan 2003)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.19 b/media-video/xine-ui/files/digest-xine-ui-0.9.19
new file mode 100644
index 000000000000..6129d7c28e5f
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.19
@@ -0,0 +1 @@
+MD5 6d502c8743659097ad0cf04cd21b70b1 xine-ui-0.9.19.tar.gz 2478090
diff --git a/media-video/xine-ui/xine-ui-0.9.19.ebuild b/media-video/xine-ui/xine-ui-0.9.19.ebuild
new file mode 100644
index 000000000000..b589a80459b6
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.19.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.19.ebuild,v 1.1 2003/03/09 21:29:01 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_alpha2
+ >=net-ftp/curl-7.10.2
+ app-misc/lirc
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}