summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-07-29 18:00:27 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-07-29 18:00:27 +0000
commit00c551de515894140e1924ed79f3f349c1c1539f (patch)
treeeafd62e8dba78200ac1a6427b5bd5064287fd067 /media-video
parentMake sure that all of the autotool toolchain is called as we patch configure.... (diff)
downloadgentoo-2-00c551de515894140e1924ed79f3f349c1c1539f.tar.gz
gentoo-2-00c551de515894140e1924ed79f3f349c1c1539f.tar.bz2
gentoo-2-00c551de515894140e1924ed79f3f349c1c1539f.zip
Patch against gcc4 trouble, see bug #100587
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/alevt/ChangeLog6
-rw-r--r--media-video/alevt/Manifest3
-rw-r--r--media-video/alevt/alevt-1.6.1-r1.ebuild3
-rw-r--r--media-video/alevt/files/alevt-1.6.1-gcc4.patch25
4 files changed, 34 insertions, 3 deletions
diff --git a/media-video/alevt/ChangeLog b/media-video/alevt/ChangeLog
index 67faae567858..5899645eea76 100644
--- a/media-video/alevt/ChangeLog
+++ b/media-video/alevt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/alevt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/ChangeLog,v 1.15 2005/07/27 08:22:19 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/ChangeLog,v 1.16 2005/07/29 18:00:27 phosphan Exp $
+
+ 29 Jul 2005; Patrick Kursawe <phosphan@gentoo.org>
+ +files/alevt-1.6.1-gcc4.patch, alevt-1.6.1-r1.ebuild:
+ Patch against gcc4 trouble, see bug #100587
*alevt-1.6.1-r1 (27 Jul 2005)
diff --git a/media-video/alevt/Manifest b/media-video/alevt/Manifest
index ed69976310ba..c80185e9c139 100644
--- a/media-video/alevt/Manifest
+++ b/media-video/alevt/Manifest
@@ -1,4 +1,4 @@
-MD5 212b1b197c42f332bbb0497eb4f6ead3 alevt-1.6.1-r1.ebuild 1140
+MD5 c23a18be8a95d821c5c2b33f322d1225 alevt-1.6.1-r1.ebuild 1176
MD5 efb04d47b0c9e0a1c96e9462aad5ea18 alevt-1.6.1.ebuild 1057
MD5 05cc8edacedcc7e918ad06583c58fbac alevt-1.6.0-r3.ebuild 955
MD5 890dedb8d5b90aba08177922300d42e6 ChangeLog 2502
@@ -9,4 +9,5 @@ MD5 4b33a59a4f04a8a1edaf6d18f71e7101 files/digest-alevt-1.6.1 63
MD5 9b2908a22bc1aeee2713dd6447f077e4 files/alevt-1.6.0-gentoo.diff 1430
MD5 55d9505c13b404139c9f9b2111482ca3 files/digest-alevt-1.6.0-r3 63
MD5 009c3ba83c0f16b20b2066f15fbe295e files/digest-alevt-1.6.1-r1 122
+MD5 1386e3fc0925198ef09da46956f42d0d files/alevt-1.6.1-gcc4.patch 658
MD5 8c88e060926481334f381229aa9c85c5 files/alevt-1.6.1-gentoo.diff 734
diff --git a/media-video/alevt/alevt-1.6.1-r1.ebuild b/media-video/alevt/alevt-1.6.1-r1.ebuild
index dbf9eed6bdc7..1a02329cc18b 100644
--- a/media-video/alevt/alevt-1.6.1-r1.ebuild
+++ b/media-video/alevt/alevt-1.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.1-r1.ebuild,v 1.1 2005/07/27 08:22:19 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.1-r1.ebuild,v 1.2 2005/07/29 18:00:27 phosphan Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_unpack() {
cd ${S}
sed -i -e "s:^OPT=.*:OPT = ${CFLAGS} -s:" Makefile
epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc4.patch
epatch ${DISTDIR}/${PN}-dvb.patch
}
diff --git a/media-video/alevt/files/alevt-1.6.1-gcc4.patch b/media-video/alevt/files/alevt-1.6.1-gcc4.patch
new file mode 100644
index 000000000000..868ba36f2f50
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.1-gcc4.patch
@@ -0,0 +1,25 @@
+diff -ur alevt-1.6.1/xio.c alevt-1.6.1-gcc4/xio.c
+--- alevt-1.6.1/xio.c 2002-08-20 05:09:38.000000000 +0200
++++ alevt-1.6.1-gcc4/xio.c 2005-07-28 15:08:53.281978632 +0200
+@@ -31,11 +31,12 @@
+
+ static struct dl_head dpys[1]; /* list of all displays */
+
++static void xio_timer();
++static void handle_event();
+
+ static int
+ timer_init(int argc, char **argv)
+ {
+- static void xio_timer();
+ int p[2], timer_pid, i;
+
+ if (pipe(p) == -1)
+@@ -160,7 +161,6 @@
+ xio_open_dpy(char *dpy, int argc, char **argv)
+ {
+ XClassHint classhint[1];
+- static void handle_event(); //forward ref
+ struct xio *xio;
+
+ if (local_init(argc, argv) == -1)