summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-04 00:19:07 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-04 00:19:07 +0000
commit0fb832859f381ecca9af390faeda29194b2e90ec (patch)
tree9fbca05c6c8b59aa6cfec420128a1ce028a5547e /media-video
parentversion bump (diff)
downloadgentoo-2-0fb832859f381ecca9af390faeda29194b2e90ec.tar.gz
gentoo-2-0fb832859f381ecca9af390faeda29194b2e90ec.tar.bz2
gentoo-2-0fb832859f381ecca9af390faeda29194b2e90ec.zip
Fix build failure with >=glib-2.31 (bug #413843, thanks to Piotr Mitas and Andre Reinke).
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleeditor/ChangeLog7
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.40.0-glib-2.31.patch15
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild7
3 files changed, 27 insertions, 2 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index 341dbf1b51a2..c7b712c17853 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.17 2012/04/29 16:04:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.18 2012/05/04 00:19:07 tetromino Exp $
+
+ 04 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ subtitleeditor-0.40.0.ebuild, +files/subtitleeditor-0.40.0-glib-2.31.patch:
+ Fix build failure with >=glib-2.31 (bug #413843, thanks to Piotr Mitas and
+ Andre Reinke).
29 Apr 2012; Markus Meier <maekke@gentoo.org> subtitleeditor-0.40.0.ebuild:
x86 stable, bug #410611
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.40.0-glib-2.31.patch b/media-video/subtitleeditor/files/subtitleeditor-0.40.0-glib-2.31.patch
new file mode 100644
index 000000000000..7ac0bd365159
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.40.0-glib-2.31.patch
@@ -0,0 +1,15 @@
+From: Andre Reinke <andre.reinke@googlemail.com>
+
+https://gna.org/bugs/index.php?19709
+
+--- a/plugins/actions/findandreplace/findandreplace.cc
++++ b/plugins/actions/findandreplace/findandreplace.cc
+@@ -26,7 +26,7 @@
+ #include <gui/dialogutility.h>
+ #include <gtkmm_utility.h>
+ #include <widget_config_utility.h>
+-#include <glib/gregex.h>
++#include <glib.h>
+
+ /*
+ * FIXME:
diff --git a/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild
index 17acbe8be4eb..c04d9822fa4b 100644
--- a/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild
+++ b/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild,v 1.3 2012/04/29 16:04:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.40.0.ebuild,v 1.4 2012/05/04 00:19:07 tetromino Exp $
EAPI="4"
@@ -37,6 +37,11 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO"
+src_prepare() {
+ # bug #413843, https://gna.org/bugs/index.php?19709
+ epatch "${FILESDIR}/${P}-glib-2.31.patch"
+}
+
src_configure() {
export GST_REGISTRY="${T}/home/registry.cache.xml"