summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-03-10 18:47:43 +0000
committerSteve Dibb <beandog@gentoo.org>2009-03-10 18:47:43 +0000
commit415e2496a38a4648d4e31d0f04dd53c9f959310d (patch)
tree58c0be393827d53bfa5c539e2cebd294d101cc57 /media-video
parentVersion bump (diff)
downloadgentoo-2-415e2496a38a4648d4e31d0f04dd53c9f959310d.tar.gz
gentoo-2-415e2496a38a4648d4e31d0f04dd53c9f959310d.tar.bz2
gentoo-2-415e2496a38a4648d4e31d0f04dd53c9f959310d.zip
Drop aac use flag, split to faac / faad use flags - ffmpeg has native AAC encoding / decoding which should be used by default; drop unused vhook use flag on live ebuild
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog10
-rw-r--r--media-video/ffmpeg/ffmpeg-0.5-r1.ebuild (renamed from media-video/ffmpeg/ffmpeg-0.5.ebuild)16
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild18
-rw-r--r--media-video/ffmpeg/metadata.xml2
4 files changed, 28 insertions, 18 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index edb4cfcfe68a..3e077eafd83b 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.276 2009/03/10 07:30:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.277 2009/03/10 18:47:43 beandog Exp $
+
+*ffmpeg-0.5-r1 (10 Mar 2009)
+
+ 10 Mar 2009; Steve Dibb <beandog@gentoo.org> metadata.xml,
+ -ffmpeg-0.5.ebuild, +ffmpeg-0.5-r1.ebuild, ffmpeg-9999.ebuild:
+ Drop aac use flag, split to faac / faad use flags - ffmpeg has native AAC
+ encoding / decoding which should be used by default; drop unused vhook use
+ flag on live ebuild
*ffmpeg-0.5 (10 Mar 2009)
diff --git a/media-video/ffmpeg/ffmpeg-0.5.ebuild b/media-video/ffmpeg/ffmpeg-0.5-r1.ebuild
index 1edb179becdd..fa5f16e59216 100644
--- a/media-video/ffmpeg/ffmpeg-0.5.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.5.ebuild,v 1.1 2009/03/10 07:30:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.5-r1.ebuild,v 1.1 2009/03/10 18:47:43 beandog Exp $
EAPI=1
@@ -14,22 +14,22 @@ SRC_URI="http://ffmpeg.org/releases/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="+3dnow +3dnowext aac alsa altivec amr custom-cflags debug dirac doc ieee1394
- +encode gsm ipv6 +mmx +mmxext vorbis test theora threads x264 xvid
- network zlib sdl X mp3 oss schroedinger +hardcoded-tables bindist
+IUSE="+3dnow +3dnowext alsa altivec amr custom-cflags debug dirac doc ieee1394
+ +encode -faac -faad gsm ipv6 +mmx +mmxext vorbis test theora threads x264
+ xvid network zlib sdl X mp3 oss schroedinger +hardcoded-tables bindist
v4l v4l2 speex +ssse3 vhook jpeg2k"
RDEPEND="vhook? ( >=media-libs/imlib2-1.4.0 >=media-libs/freetype-2 )
sdl? ( >=media-libs/libsdl-1.2.10 )
alsa? ( media-libs/alsa-lib )
encode? (
- aac? ( media-libs/faac )
+ faac? ( media-libs/faac )
mp3? ( media-sound/lame )
vorbis? ( media-libs/libvorbis media-libs/libogg )
theora? ( media-libs/libtheora media-libs/libogg )
x264? ( >=media-libs/x264-0.0.20081006 )
xvid? ( >=media-libs/xvid-1.1.0 ) )
- aac? ( >=media-libs/faad2-2.6.1 )
+ faad? ( >=media-libs/faad2-2.6.1 )
zlib? ( sys-libs/zlib )
ieee1394? ( media-libs/libdc1394
sys-libs/libraw1394 )
@@ -68,7 +68,7 @@ src_compile() {
# enabled by default
if use encode
then
- use aac && myconf="${myconf} --enable-libfaac"
+ use faac && myconf="${myconf} --enable-libfaac"
use mp3 && myconf="${myconf} --enable-libmp3lame"
use vorbis && myconf="${myconf} --enable-libvorbis"
use theora && myconf="${myconf} --enable-libtheora"
@@ -94,7 +94,7 @@ src_compile() {
use threads && myconf="${myconf} --enable-pthreads"
# Decoders
- use aac && myconf="${myconf} --enable-libfaad"
+ use faad && myconf="${myconf} --enable-libfaad"
use dirac && myconf="${myconf} --enable-libdirac"
use schroedinger && myconf="${myconf} --enable-libschroedinger"
use speex && myconf="${myconf} --enable-libspeex"
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 154d520c509d..c88c6c7f6179 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.10 2009/03/05 19:20:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.11 2009/03/10 18:47:43 beandog Exp $
EAPI=1
@@ -15,21 +15,21 @@ HOMEPAGE="http://ffmpeg.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="+3dnow +3dnowext aac alsa altivec amr custom-cflags debug dirac doc
- ieee1394 +encode gsm ipv6 +mmx +mmxext vorbis test theora threads
- x264 xvid network zlib sdl X mp3 oss schroedinger +hardcoded-tables
- bindist v4l v4l2 speex +ssse3 vhook jpeg2k"
+IUSE="+3dnow +3dnowext alsa altivec amr custom-cflags debug dirac doc
+ ieee1394 +encode -faac -faad gsm ipv6 +mmx +mmxext vorbis test theora
+ threads x264 xvid network zlib sdl X mp3 oss schroedinger
+ +hardcoded-tables bindist v4l v4l2 speex +ssse3 jpeg2k"
RDEPEND="sdl? ( >=media-libs/libsdl-1.2.10 )
alsa? ( media-libs/alsa-lib )
encode? (
- aac? ( media-libs/faac )
+ faac? ( media-libs/faac )
mp3? ( media-sound/lame )
vorbis? ( media-libs/libvorbis media-libs/libogg )
theora? ( media-libs/libtheora media-libs/libogg )
x264? ( >=media-libs/x264-0.0.20081006 )
xvid? ( >=media-libs/xvid-1.1.0 ) )
- aac? ( >=media-libs/faad2-2.6.1 )
+ faad? ( >=media-libs/faad2-2.6.1 )
zlib? ( sys-libs/zlib )
ieee1394? ( media-libs/libdc1394
sys-libs/libraw1394 )
@@ -68,7 +68,7 @@ src_compile() {
# enabled by default
if use encode
then
- use aac && myconf="${myconf} --enable-libfaac"
+ use faac && myconf="${myconf} --enable-libfaac"
use mp3 && myconf="${myconf} --enable-libmp3lame"
use vorbis && myconf="${myconf} --enable-libvorbis"
use theora && myconf="${myconf} --enable-libtheora"
@@ -94,7 +94,7 @@ src_compile() {
use threads && myconf="${myconf} --enable-pthreads"
# Decoders
- use aac && myconf="${myconf} --enable-libfaad"
+ use faad && myconf="${myconf} --enable-libfaad"
use dirac && myconf="${myconf} --enable-libdirac"
use schroedinger && myconf="${myconf} --enable-libschroedinger"
use speex && myconf="${myconf} --enable-libspeex"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 19aea3f21c35..153e3f9f2754 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -13,6 +13,8 @@
</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
+ <flag name="faac">Use external faac library for AAC encoding (instead of internal libavcodec support)</flag>
+ <flag name="faad">Use external faad library for AAC decoding (instead of internal libavcodec support)</flag>
<flag name="gsm">Enables support for the gsm lossy speech compression codec via libgsm.</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="mmxext">Enables mmx2 support</flag>