summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-16 17:58:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-16 17:58:30 +0000
commit4ab7b61a071230b0db481ec244ff7fe7303dc8aa (patch)
tree61f556571315ba034b927baaaffbcba76c89a4bd /media-video
parentVersion bump, security bug #355127. (diff)
downloadgentoo-2-4ab7b61a071230b0db481ec244ff7fe7303dc8aa.tar.gz
gentoo-2-4ab7b61a071230b0db481ec244ff7fe7303dc8aa.tar.bz2
gentoo-2-4ab7b61a071230b0db481ec244ff7fe7303dc8aa.zip
Add bluray useflag
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog6
-rw-r--r--media-video/vlc/metadata.xml1
-rw-r--r--media-video/vlc/vlc-9999.ebuild6
3 files changed, 10 insertions, 3 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 3ec563515670..952c9c466b86 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.669 2011/02/16 17:14:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.670 2011/02/16 17:58:30 aballier Exp $
+
+ 16 Feb 2011; Alexis Ballier <aballier@gentoo.org> vlc-9999.ebuild,
+ metadata.xml:
+ Add bluray useflag
16 Feb 2011; Alexis Ballier <aballier@gentoo.org> vlc-9999.ebuild,
metadata.xml:
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
index 155953f5d855..bff764ae351f 100644
--- a/media-video/vlc/metadata.xml
+++ b/media-video/vlc/metadata.xml
@@ -9,6 +9,7 @@
<use>
<flag name="atmo">Enables support for AtmoLight (homebrew Ambient Lighting Technology)</flag>
<flag name="bda">Enables Win32 DirectShow BDA support.</flag>
+ <flag name="bluray">Enables libbluray for Blu-ray disc support.</flag>
<flag name="dc1394">Enables IIDC cameras support.</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
<flag name="dshow">Enables Win32 DirectShow support.</flag>
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index cd9ce2cd7126..f203642c8916 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.110 2011/02/16 17:14:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.111 2011/02/16 17:58:30 aballier Exp $
EAPI="4"
@@ -45,7 +45,7 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="a52 aac aalib alsa altivec atmo avahi bda bidi cdda cddb dbus dc1394
+IUSE="a52 aac aalib alsa altivec atmo avahi bda bidi bluray cdda cddb dbus dc1394
debug dirac directfb dshow dts dvb dvd elibc_glibc +encode fbcon fluidsynth +ffmpeg flac fontconfig
+gcrypt gme gnome gnutls growl httpd ieee1394 jack kate kde libass libcaca
libnotify libproxy libtiger libv4l2 linsys lirc live lua matroska mmx
@@ -64,6 +64,7 @@ RDEPEND="
alsa? ( >=media-libs/alsa-lib-1.0.23 )
avahi? ( >=net-dns/avahi-0.6[dbus] )
bidi? ( >=dev-libs/fribidi-0.10.4 )
+ bluray? ( media-libs/libbluray )
cddb? ( >=media-libs/libcddb-1.2.0 )
dbus? ( >=sys-apps/dbus-1.0.2 )
dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 )
@@ -192,6 +193,7 @@ src_configure() {
$(use_enable avahi bonjour) \
$(use_enable bda) \
$(use_enable bidi fribidi) \
+ $(use_enable bluray) \
$(use_enable cdda vcd) \
$(use_enable cddb libcddb) \
$(use_enable dbus) $(use_enable dbus dbus-control) \