summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-01 21:20:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-01 21:20:16 +0000
commit5ddfbd54e36162d6589aff8de9a17fcc3b71fec0 (patch)
treec92ff074c39ad3663bc94a4c07d8c0cb96484b91 /media-video
parentadd a patch to allow building against latest ffmpeg (diff)
downloadgentoo-2-5ddfbd54e36162d6589aff8de9a17fcc3b71fec0.tar.gz
gentoo-2-5ddfbd54e36162d6589aff8de9a17fcc3b71fec0.tar.bz2
gentoo-2-5ddfbd54e36162d6589aff8de9a17fcc3b71fec0.zip
bump a new snapshot with a gcc 4.3 fix by Martin Väth <vaeth@mathematik.uni-wuerzburg.de> (bug #215431) and a fix to build with latest ffmpeg by me
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cinelerra-cvs/ChangeLog11
-rw-r--r--media-video/cinelerra-cvs/cinelerra-cvs-20080401.ebuild110
-rw-r--r--media-video/cinelerra-cvs/files/cinelerra-cvs-ffmpegheaders.patch121
-rw-r--r--media-video/cinelerra-cvs/files/cinelerra-cvs-gcc-4.3.patch18
4 files changed, 259 insertions, 1 deletions
diff --git a/media-video/cinelerra-cvs/ChangeLog b/media-video/cinelerra-cvs/ChangeLog
index 22a56e17fbbe..eb0d1eb719e4 100644
--- a/media-video/cinelerra-cvs/ChangeLog
+++ b/media-video/cinelerra-cvs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/cinelerra-cvs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.41 2008/03/20 21:21:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.42 2008/04/01 21:20:15 aballier Exp $
+
+*cinelerra-cvs-20080401 (01 Apr 2008)
+
+ 01 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/cinelerra-cvs-gcc-4.3.patch,
+ +files/cinelerra-cvs-ffmpegheaders.patch, +cinelerra-cvs-20080401.ebuild:
+ bump a new snapshot with a gcc 4.3 fix by Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de> (bug #215431) and a fix to build with
+ latest ffmpeg by me
20 Mar 2008; Alexis Ballier <aballier@gentoo.org>
-files/cinelerra-cvs-20080115-swscaler.patch,
diff --git a/media-video/cinelerra-cvs/cinelerra-cvs-20080401.ebuild b/media-video/cinelerra-cvs/cinelerra-cvs-20080401.ebuild
new file mode 100644
index 000000000000..c56f0ace4264
--- /dev/null
+++ b/media-video/cinelerra-cvs/cinelerra-cvs-20080401.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/cinelerra-cvs-20080401.ebuild,v 1.1 2008/04/01 21:20:15 aballier Exp $
+
+WANT_AUTOMAKE=1.9
+WANT_AUTOCONF=2.5
+
+inherit toolchain-funcs eutils flag-o-matic autotools
+
+#filter-flags "-fPIC -fforce-addr"
+
+DESCRIPTION="Cinelerra - Professional Video Editor - Unofficial CVS-version"
+HOMEPAGE="http://cvs.cinelerra.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="3dnow alsa esd mmx oss static truetype ieee1394 css altivec opengl"
+RDEPEND="media-libs/libpng
+ >=media-libs/libdv-1.0.0
+ media-libs/faad2
+ media-libs/faac
+ media-libs/a52dec
+ media-libs/libsndfile
+ media-libs/tiff
+ media-video/ffmpeg
+ media-sound/lame
+ >=sci-libs/fftw-3.0.1
+ >=media-libs/x264-svn-20060302
+ ieee1394? ( media-libs/libiec61883 >=sys-libs/libraw1394-1.2.0 \
+ >=sys-libs/libavc1394-0.5.0 )
+ media-video/mjpegtools
+ alsa? ( media-libs/alsa-lib )
+ esd? ( >=media-sound/esound-0.2.34 )
+ truetype? ( >=media-libs/freetype-2.1.10 )
+ opengl? ( virtual/opengl )
+ >=media-libs/openexr-1.2.2
+ >=media-libs/libvorbis-1.1.0
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_alpha4-r1
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libXvMC
+ x11-libs/libXft"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if [[ "$(gcc-major-version)" -lt "4" ]]; then
+ eerror "You need to have gcc 4 or better"
+ eerror "Please follow : http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ eerror "And have a look at bug #128659"
+ die "You must use gcc 4 or better."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-swscaler.patch"
+ epatch "${FILESDIR}/cinelerra-compilewarnings.diff"
+ epatch "${FILESDIR}/${PN}-defaultx264tocqp.patch"
+ epatch "${FILESDIR}/${PN}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${PN}-ffmpegheaders.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ `use_enable static` \
+ `use_enable alsa` \
+ `use_enable esd` \
+ `use_enable oss` \
+ `use_enable mmx` \
+ `use_enable 3dnow` \
+ --with-plugindir=/usr/$(get_libdir)/cinelerra \
+ `use_enable truetype freetype2` \
+ `use_enable ieee1394 firewire` \
+ `use_enable css` \
+ `use_enable opengl` \
+ `use_enable altivec` \
+ --with-external-ffmpeg \
+ --with-buildinfo=cust/"Gentoo - SVN r1055" \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dohtml -a png,html,texi,sdw -r doc/*
+ # workaround
+ rm -fR "${D}/usr/include"
+ mv "${D}/usr/bin/mpeg3cat" "${D}/usr/bin/mpeg3cat.hv"
+ mv "${D}/usr/bin/mpeg3dump" "${D}/usr/bin/mpeg3dump.hv"
+ mv "${D}/usr/bin/mpeg3toc" "${D}/usr/bin/mpeg3toc.hv"
+ ln -s /usr/bin/mpeg2enc "${D}/usr/$(get_libdir)/cinelerra/mpeg2enc.plugin"
+}
+
+pkg_postinst () {
+ elog "Please note that this is unofficial and somewhat experimental code."
+ elog "See cvs.cinelerra.org for a list of changes to the official cinelerra"
+ elog "release."
+}
diff --git a/media-video/cinelerra-cvs/files/cinelerra-cvs-ffmpegheaders.patch b/media-video/cinelerra-cvs/files/cinelerra-cvs-ffmpegheaders.patch
new file mode 100644
index 000000000000..5cc57f887284
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/cinelerra-cvs-ffmpegheaders.patch
@@ -0,0 +1,121 @@
+Index: cinelerra-cvs/cinelerra/ffmpeg.h
+===================================================================
+--- cinelerra-cvs.orig/cinelerra/ffmpeg.h
++++ cinelerra-cvs/cinelerra/ffmpeg.h
+@@ -1,11 +1,20 @@
+ #ifndef FFMPEG_H
+ #define FFMPEG_H
+
++#include "config.h"
+ extern "C" {
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include <avcodec.h>
++#endif
+ #ifdef HAVE_SWSCALER
++#if HAVE_LIBSWSCALE_SWSCALE_H
++#include <libswscale/swscale.h>
++#else
+ #include <swscale.h>
+ #endif
++#endif
+ };
+
+ #include "asset.h"
+Index: cinelerra-cvs/cinelerra/fileac3.h
+===================================================================
+--- cinelerra-cvs.orig/cinelerra/fileac3.h
++++ cinelerra-cvs/cinelerra/fileac3.h
+@@ -1,8 +1,13 @@
+ #ifndef FILEAC3_H
+ #define FILEAC3_H
+
++#include "config.h"
+ extern "C" {
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include <avcodec.h>
++#endif
+ };
+
+ #include "filebase.h"
+Index: cinelerra-cvs/configure.in
+===================================================================
+--- cinelerra-cvs.orig/configure.in
++++ cinelerra-cvs/configure.in
+@@ -370,6 +370,10 @@ if test "x$with_external_ffmpeg" = "xyes
+ else
+ PKG_CHECK_MODULES([FFMPEG], [libavcodec libpostproc])
+ fi
++ AC_CHECK_HEADERS(ffmpeg/avcodec.h libavcodec/avcodec.h)
++ AC_CHECK_HEADERS(ffmpeg/avformat.h libavformat/avformat.h)
++ AC_CHECK_HEADERS(ffmpeg/avutil.h libavutil/avutil.h)
++ AC_CHECK_HEADERS([ffmpeg/swscale.h libswscale/swscale.h])
+
+ else
+ FFMPEG_FOLDER=ffmpeg
+Index: cinelerra-cvs/quicktime/mpeg4.c
+===================================================================
+--- cinelerra-cvs.orig/quicktime/mpeg4.c
++++ cinelerra-cvs/quicktime/mpeg4.c
+@@ -7,7 +7,12 @@
+
+
+
++#include "config.h"
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include "avcodec.h"
++#endif
+ #include "colormodels.h"
+ #include "funcprotos.h"
+ #include "qtffmpeg.h"
+Index: cinelerra-cvs/quicktime/qtffmpeg.h
+===================================================================
+--- cinelerra-cvs.orig/quicktime/qtffmpeg.h
++++ cinelerra-cvs/quicktime/qtffmpeg.h
+@@ -16,8 +16,12 @@
+ // Heroine Virtual.
+
+
+-
++#include "config.h"
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include "avcodec.h"
++#endif
+ #include "qtprivate.h"
+
+
+Index: cinelerra-cvs/quicktime/qth264.c
+===================================================================
+--- cinelerra-cvs.orig/quicktime/qth264.c
++++ cinelerra-cvs/quicktime/qth264.c
+@@ -1,4 +1,9 @@
++#include "config.h"
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include "avcodec.h"
++#endif
+ #include "colormodels.h"
+ #include "funcprotos.h"
+ #include <pthread.h>
+Index: cinelerra-cvs/quicktime/wma.c
+===================================================================
+--- cinelerra-cvs.orig/quicktime/wma.c
++++ cinelerra-cvs/quicktime/wma.c
+@@ -1,4 +1,9 @@
++#include "config.h"
++#if HAVE_LIBAVCODEC_AVCODEC_H
++#include <libavcodec/avcodec.h>
++#else
+ #include "avcodec.h"
++#endif
+ #include "funcprotos.h"
+ #include "quicktime.h"
+ #include <string.h>
diff --git a/media-video/cinelerra-cvs/files/cinelerra-cvs-gcc-4.3.patch b/media-video/cinelerra-cvs/files/cinelerra-cvs-gcc-4.3.patch
new file mode 100644
index 000000000000..e244a2deafaf
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/cinelerra-cvs-gcc-4.3.patch
@@ -0,0 +1,18 @@
+--- plugins/threshold/threshold.C
++++ plugins/threshold/threshold.C
+@@ -461,13 +461,13 @@
+ }
+
+ template<>
+-static inline float scale_to_range(int v)
++inline float scale_to_range(int v)
+ {
+ return (float) v / 0xff;
+ }
+
+ template<>
+-static inline uint16_t scale_to_range(int v)
++inline uint16_t scale_to_range(int v)
+ {
+ return v << 8 | v;
+ }