summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-07-01 10:35:32 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-07-01 10:35:32 +0000
commit603b869a474894971bd00cefc316da8b6ad861e7 (patch)
tree725970cba8930d98adc7d42ecb21444758192c01 /media-video
parentVersion bump using cmake instead unsupported autoconf script (#183323). (diff)
downloadgentoo-2-603b869a474894971bd00cefc316da8b6ad861e7.tar.gz
gentoo-2-603b869a474894971bd00cefc316da8b6ad861e7.tar.bz2
gentoo-2-603b869a474894971bd00cefc316da8b6ad861e7.zip
Version bump.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/griffith/ChangeLog7
-rw-r--r--media-video/griffith/files/digest-griffith-0.9.36
-rw-r--r--media-video/griffith/griffith-0.9.3.ebuild65
3 files changed, 77 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 3e49ea127417..1053aa91d4a2 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.10 2007/07/01 03:07:39 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.11 2007/07/01 10:35:32 nelchael Exp $
+
+*griffith-0.9.3 (01 Jul 2007)
+
+ 01 Jul 2007; Krzysiek Pawlik <nelchael@gentoo.org> +griffith-0.9.3.ebuild:
+ Version bump.
01 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
+files/digest-griffith-0.9.2, Manifest:
diff --git a/media-video/griffith/files/digest-griffith-0.9.3 b/media-video/griffith/files/digest-griffith-0.9.3
new file mode 100644
index 000000000000..90848c36488e
--- /dev/null
+++ b/media-video/griffith/files/digest-griffith-0.9.3
@@ -0,0 +1,6 @@
+MD5 a698339ec336fae3e92d71337001a0b7 griffith-0.9.3.tar.gz 794593
+RMD160 e47c45ea95045001dbc68a4d0834bf7fbb0156c6 griffith-0.9.3.tar.gz 794593
+SHA256 c6779072cdb7cded5b77cd22febb07b55cdc8b7289ba5d52679f4418fcb160a1 griffith-0.9.3.tar.gz 794593
+MD5 3a0cb7fc9e555efb0c6be558dfbdd944 griffith-extra-artwork-0.9.3.tar.gz 122675
+RMD160 6669058afbe4936e08d2f25372671b251af26a12 griffith-extra-artwork-0.9.3.tar.gz 122675
+SHA256 448485ab88320038831ae311c77acdb4202a1a62fcc9a9a7e3f778a403ae18dc griffith-extra-artwork-0.9.3.tar.gz 122675
diff --git a/media-video/griffith/griffith-0.9.3.ebuild b/media-video/griffith/griffith-0.9.3.ebuild
new file mode 100644
index 000000000000..f00e237c24d4
--- /dev/null
+++ b/media-video/griffith/griffith-0.9.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.3.ebuild,v 1.1 2007/07/01 10:35:32 nelchael Exp $
+
+inherit python
+
+ARTWORK_PV="${PV}"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.vasconunes.net/"
+SRC_URI="http://download.berlios.de/griffith/${P/_/-}.tar.gz
+ http://download.berlios.de/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc spell"
+
+RDEPEND="dev-python/imaging
+ >=dev-python/pygtk-2.6.1
+ >=dev-python/pysqlite-2.0
+ >=dev-python/sqlalchemy-0.3
+ >=dev-python/reportlab-1.19
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/docbook2x-man/docbook2man.pl/' \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/*/Makefile || die "sed failed"
+ sed -i \
+ -e 's/latin1/iso-8859-1/' \
+ docs/en/*.xml || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/share/${PN}/lib
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/share/${PN}/lib
+}