summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-01 23:11:48 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-01 23:11:48 +0000
commit624a62be577113acae4078162d1cb3c7ca9624ad (patch)
treeb5c7e3be10e357ea6334fbf08ed5c61f86d10624 /media-video
parentdev-haskell/dbus: add new, drop old (diff)
downloadgentoo-2-624a62be577113acae4078162d1cb3c7ca9624ad.tar.gz
gentoo-2-624a62be577113acae4078162d1cb3c7ca9624ad.tar.bz2
gentoo-2-624a62be577113acae4078162d1cb3c7ca9624ad.zip
Introduce USE=libav to control the preferred implementation. Add subslot op to force rebuilds on ABI change.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/makemkv/ChangeLog10
-rw-r--r--media-video/makemkv/makemkv-1.8.13-r1.ebuild118
2 files changed, 126 insertions, 2 deletions
diff --git a/media-video/makemkv/ChangeLog b/media-video/makemkv/ChangeLog
index 87fc6b5a6129..592b3de32d34 100644
--- a/media-video/makemkv/ChangeLog
+++ b/media-video/makemkv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/makemkv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.47 2014/10/20 14:39:06 mattm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.48 2015/02/01 23:11:48 mgorny Exp $
+
+*makemkv-1.8.13-r1 (01 Feb 2015)
+
+ 01 Feb 2015; Michał Górny <mgorny@gentoo.org> +makemkv-1.8.13-r1.ebuild:
+ Introduce USE=libav to control the preferred implementation. Add subslot op to
+ force rebuilds on ABI change.
20 Oct 2014; Matthew Marlowe <mattm@gentoo.org>
+files/makemkv-1.8.13-makefile.linux.patch:
diff --git a/media-video/makemkv/makemkv-1.8.13-r1.ebuild b/media-video/makemkv/makemkv-1.8.13-r1.ebuild
new file mode 100644
index 000000000000..34a9daebc9e7
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.8.13-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.13-r1.ebuild,v 1.1 2015/02/01 23:11:48 mgorny Exp $
+
+EAPI=5
+inherit eutils gnome2-utils multilib flag-o-matic
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping Blu-Ray, HD-DVD and DVD discs and copying content to a Matroska container"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav multilib qt4"
+
+QA_PREBUILT="opt/bin/makemkvcon opt/bin/mmdtsdec"
+
+RDEPEND="
+ sys-libs/glibc[multilib?]
+ dev-libs/expat
+ dev-libs/openssl:0
+ sys-libs/zlib
+ qt4? (
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ )
+ !libav? ( >=media-video/ffmpeg-1.0.0:0= )
+ libav? ( >=media-video/libav-0.8.9:0= )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/makemkv-oss-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.linux.patch
+}
+
+src_configure() {
+ replace-flags -O* -Os
+ local args=""
+ use qt4 || args="--disable-gui"
+ if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
+ econf $args
+ fi
+}
+
+src_compile() {
+ emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" || die "Make failed!"
+}
+
+src_install() {
+ # install oss package
+ dolib.so out/libdriveio.so.0
+ dolib.so out/libmakemkv.so.1
+ dolib.so out/libmmbd.so.0
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+ into /opt
+
+ if use qt4; then
+ dobin out/makemkv
+
+ local res
+ for res in 16 22 32 64 128; do
+ newicon -s ${res} makemkvgui/share/icons/${res}x${res}/makemkv.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} MakeMKV ${PN} 'Qt;AudioVideo;Video'
+ fi
+
+ # install bin package
+ pushd "${WORKDIR}"/${MY_PB}/bin >/dev/null
+ if use x86; then
+ dobin i386/{makemkvcon,mmdtsdec}
+ elif use amd64; then
+ dobin amd64/makemkvcon
+ use multilib && dobin i386/mmdtsdec
+ fi
+ popd >/dev/null
+
+ # install license and default profile
+ pushd "${WORKDIR}"/${MY_PB}/src/share >/dev/null
+ insinto /usr/share/MakeMKV
+ doins *.{gz,xml}
+ popd >/dev/null
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "If this is a new install, remember to copy the default profile"
+ elog "to the config directory:"
+ elog "cp /usr/share/MakeMKV/default.mmcp.xml ~/.MakeMKV/"
+}
+
+pkg_postrm() { gnome2_icon_cache_update; }