summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-17 17:12:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-17 17:12:57 +0000
commit744dacd7a27dba282b90542b3adf1fe909dd89ec (patch)
tree68c7f402d88cfd4eef7f31bcd6db1b1d3456ab9e /media-video
parentx86 stable, bug #232515 (diff)
downloadgentoo-2-744dacd7a27dba282b90542b3adf1fe909dd89ec.tar.gz
gentoo-2-744dacd7a27dba282b90542b3adf1fe909dd89ec.tar.bz2
gentoo-2-744dacd7a27dba282b90542b3adf1fe909dd89ec.zip
Add dirac and schroedinger useflags that were automagic, thanks to Hanno Boeck <hanno@gentoo.org> for reporting in bug #234775.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog7
-rw-r--r--media-video/mplayer/metadata.xml2
-rw-r--r--media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild11
3 files changed, 16 insertions, 4 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 34814748e04a..9081344f242e 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.585 2008/08/17 14:50:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.586 2008/08/17 17:12:57 aballier Exp $
+
+ 17 Aug 2008; Alexis Ballier <aballier@gentoo.org> metadata.xml,
+ mplayer-1.0_rc2_p27458.ebuild:
+ Add dirac and schroedinger useflags that were automagic, thanks to Hanno
+ Boeck <hanno@gentoo.org> for reporting in bug #234775.
17 Aug 2008; Alexis Ballier <aballier@gentoo.org>
mplayer-1.0_rc2_p27458.ebuild:
diff --git a/media-video/mplayer/metadata.xml b/media-video/mplayer/metadata.xml
index be8d51c293e6..798f80a4cbfd 100644
--- a/media-video/mplayer/metadata.xml
+++ b/media-video/mplayer/metadata.xml
@@ -15,6 +15,7 @@
<flag name="cpudetection">Enables runtime cpudetection (useful for bindist, compatability on other CPUs)</flag>
<flag name="custom-cflags">Enables custom CFLAGS (UNSUPPORTED)</flag>
<flag name="custom-cpuopts">Fine-tune custom CPU optimizations (UNSUPPORTED)</flag>
+ <flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
<flag name="dxr2">Enable DXR2 video output</flag>
<flag name="dxr3">Enable DXR3/H+ video output</flag>
<flag name="enca">Enables support for charset discovery and conversion</flag>
@@ -29,6 +30,7 @@
<flag name="rar">Enable Unique RAR File Library</flag>
<flag name="real">Adds real video support</flag>
<flag name="rtc">Enables usage of the linux real time clock. The alternative is software emulation of rtc</flag>
+ <flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="srt">Internal SRT/SSA/ASS (SubRip / SubStation Alpha) subtitle support</flag>
<flag name="ssse3">faster floating point optimization for SSSE3 capable chips (Intel Core 2 and later chips)</flag>
<flag name="teletext">Support for TV teletext interface</flag>
diff --git a/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild b/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild
index 7c57082ae556..53482efc4401 100644
--- a/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild
+++ b/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild,v 1.3 2008/08/17 14:50:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc2_p27458.ebuild,v 1.4 2008/08/17 17:12:57 aballier Exp $
EAPI="1"
@@ -11,10 +11,10 @@ MPLAYER_REVISION=27458
IUSE="3dnow 3dnowext +a52 aac -aalib +alsa altivec amrnb amrwb -arts bidi bl
bindist cddb cdio cdparanoia -cpudetection -custom-cflags -custom-cpuopts debug
-dga doc dts dvb directfb +dvd dv dxr2 dxr3 enca encode esd -fbcon ftp -gif ggi
+dga dirac doc dts dvb directfb +dvd dv dxr2 dxr3 enca encode esd -fbcon ftp -gif ggi
-gtk iconv ipv6 jack joystick -jpeg kernel_linux ladspa -libcaca lirc live lzo
+mad -md5sum +mmx mmxext mp2 +mp3 musepack nas nemesi +vorbis opengl
-openal oss -png -pnm pulseaudio -pvr quicktime radio -rar real rtc -samba sdl
+openal oss -png -pnm pulseaudio -pvr quicktime radio -rar real rtc -samba schroedinger sdl
speex srt sse sse2 ssse3 svga teletext tga +theora +truetype unicode v4l v4l2 vidix win32codecs +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
VIDEO_CARDS="s3virge mga tdfx vesa"
@@ -57,6 +57,7 @@ RDEPEND="sys-libs/ncurses
bidi? ( dev-libs/fribidi )
cdio? ( dev-libs/libcdio )
cdparanoia? ( media-sound/cdparanoia )
+ dirac? ( >=media-video/dirac-0.10.0 )
directfb? ( dev-libs/DirectFB )
dga? ( x11-libs/libXxf86dga )
dts? ( media-libs/libdca )
@@ -91,6 +92,7 @@ RDEPEND="sys-libs/ncurses
pnm? ( media-libs/netpbm )
pulseaudio? ( media-sound/pulseaudio )
samba? ( net-fs/samba )
+ schroedinger? ( media-libs/schroedinger )
sdl? ( media-libs/libsdl )
speex? ( >=media-libs/speex-1.1.7 )
srt? ( >=media-libs/freetype-2.1
@@ -324,6 +326,9 @@ src_compile() {
for x in gif jpeg live mad musepack pnm speex tga theora xanim; do
use ${x} || myconf="${myconf} --disable-${x}"
done
+ for x in dirac schroedinger ; do
+ use ${x} || myconf="${myconf} --disable-lib${x}-lavc"
+ done
use amrnb || myconf="${myconf} --disable-libamr_nb"
use amrwb || myconf="${myconf} --disable-libamr_wb"
use dts || myconf="${myconf} --disable-libdca"