summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-24 17:28:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-24 17:28:38 +0000
commit9aea40e582c89b86b3f030cec88d603e2d12185a (patch)
treeaa2a12ad457183a87e409b40c3294c0655096361 /media-video
parentia64/sparc stable wrt #372391 (diff)
downloadgentoo-2-9aea40e582c89b86b3f030cec88d603e2d12185a.tar.gz
gentoo-2-9aea40e582c89b86b3f030cec88d603e2d12185a.tar.bz2
gentoo-2-9aea40e582c89b86b3f030cec88d603e2d12185a.zip
Version bump wrt #376243 by Mike Gilbert
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog8
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 66ed5b6344ec..86d980771ddf 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.122 2011/05/20 20:08:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.123 2011/07/24 17:28:38 ssuominen Exp $
+
+*ffmpegthumbnailer-2.0.7 (24 Jul 2011)
+
+ 24 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +ffmpegthumbnailer-2.0.7.ebuild:
+ Version bump wrt #376243 by Mike Gilbert
20 May 2011; Kacper Kowalik <xarthisius@gentoo.org>
ffmpegthumbnailer-2.0.6.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7.ebuild
new file mode 100644
index 000000000000..0a3d94f72b17
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.7.ebuild,v 1.1 2011/07/24 17:28:38 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk jpeg png"
+
+COMMON_DEPEND="virtual/ffmpeg
+ png? ( >=media-libs/libpng-1.4 )
+ jpeg? ( virtual/jpeg )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( >=dev-libs/glib-2.14:2 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable gtk gio)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} +
+}