summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-01 18:47:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-01 18:47:34 +0000
commit9d69bd1be7e324054519ef49afacc1ca6027bd40 (patch)
tree61a34a051a59b1705382bc3f4b75b8ceb4421d83 /media-video
parentStable on amd64 wrt bug 177617 (diff)
downloadgentoo-2-9d69bd1be7e324054519ef49afacc1ca6027bd40.tar.gz
gentoo-2-9d69bd1be7e324054519ef49afacc1ca6027bd40.tar.bz2
gentoo-2-9d69bd1be7e324054519ef49afacc1ca6027bd40.zip
Fix compilation against newest ffmpeg, bug #180547, also remove long time deprecated max c++ syntax that has been removed in gcc 4.2
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvbcut/ChangeLog8
-rw-r--r--media-video/dvbcut/dvbcut-0.5.4.ebuild4
-rw-r--r--media-video/dvbcut/files/dvbcut-0.5.4-ffmpeg-compat2.patch129
-rw-r--r--media-video/dvbcut/files/dvbcut-0.5.4-gcc42.patch13
4 files changed, 152 insertions, 2 deletions
diff --git a/media-video/dvbcut/ChangeLog b/media-video/dvbcut/ChangeLog
index b7c52e07cf52..c9205704968f 100644
--- a/media-video/dvbcut/ChangeLog
+++ b/media-video/dvbcut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/dvbcut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.5 2007/04/14 23:18:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.6 2007/06/01 18:47:34 aballier Exp $
+
+ 01 Jun 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/dvbcut-0.5.4-ffmpeg-compat2.patch, +files/dvbcut-0.5.4-gcc42.patch,
+ dvbcut-0.5.4.ebuild:
+ Fix compilation against newest ffmpeg, bug #180547, also remove long time
+ deprecated max c++ syntax that has been removed in gcc 4.2
*dvbcut-0.5.4 (14 Apr 2007)
diff --git a/media-video/dvbcut/dvbcut-0.5.4.ebuild b/media-video/dvbcut/dvbcut-0.5.4.ebuild
index 439c160c4c45..f904534a056a 100644
--- a/media-video/dvbcut/dvbcut-0.5.4.ebuild
+++ b/media-video/dvbcut/dvbcut-0.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4.ebuild,v 1.1 2007/04/14 23:18:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4.ebuild,v 1.2 2007/06/01 18:47:34 aballier Exp $
inherit qt3 eutils
@@ -36,6 +36,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-0.5.3-ffmpeg-compat.patch"
+ epatch "${FILESDIR}/${P}-gcc42.patch"
+ epatch "${FILESDIR}/${P}-ffmpeg-compat2.patch"
}
src_compile() {
diff --git a/media-video/dvbcut/files/dvbcut-0.5.4-ffmpeg-compat2.patch b/media-video/dvbcut/files/dvbcut-0.5.4-ffmpeg-compat2.patch
new file mode 100644
index 000000000000..b58228630965
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.5.4-ffmpeg-compat2.patch
@@ -0,0 +1,129 @@
+Index: dvbcut-0.5.4/src/avframe.h
+===================================================================
+--- dvbcut-0.5.4.orig/src/avframe.h
++++ dvbcut-0.5.4/src/avframe.h
+@@ -19,7 +19,9 @@
+ #ifndef _DVBCUT_AVFRAME_H
+ #define _DVBCUT_AVFRAME_H
+
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
+
+ class QImage;
+
+Index: dvbcut-0.5.4/src/lavfmuxer.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/lavfmuxer.cpp
++++ dvbcut-0.5.4/src/lavfmuxer.cpp
+@@ -16,7 +16,9 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+ #include <string.h>
+ #include <utility>
+ #include <list>
+Index: dvbcut-0.5.4/src/lavfmuxer.h
+===================================================================
+--- dvbcut-0.5.4.orig/src/lavfmuxer.h
++++ dvbcut-0.5.4/src/lavfmuxer.h
+@@ -19,7 +19,9 @@
+ #ifndef _DVBCUT_LAVFMUXER_H
+ #define _DVBCUT_LAVFMUXER_H
+
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+ #include "mpgfile.h"
+ #include "muxer.h"
+
+Index: dvbcut-0.5.4/src/main.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/main.cpp
++++ dvbcut-0.5.4/src/main.cpp
+@@ -27,7 +27,9 @@
+ #endif // HAVE_LIB_AO
+
+ #include <qapplication.h>
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+ #include <qimage.h>
+ #include <qsettings.h>
+ #include "dvbcut.h"
+Index: dvbcut-0.5.4/src/mpgfile.h
+===================================================================
+--- dvbcut-0.5.4.orig/src/mpgfile.h
++++ dvbcut-0.5.4/src/mpgfile.h
+@@ -19,7 +19,10 @@
+ #ifndef _DVBCUT_MPGFILE_H
+ #define _DVBCUT_MPGFILE_H
+
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
++
+ #include <string>
+ #include <vector>
+ #include <list>
+Index: dvbcut-0.5.4/src/playaudio.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/playaudio.cpp
++++ dvbcut-0.5.4/src/playaudio.cpp
+@@ -19,7 +19,10 @@
+ #ifdef HAVE_LIB_AO
+ #include <stdio.h>
+ #include <ao/ao.h>
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
++
+ #include "playaudio.h"
+
+ #define MIN_BUFFER_SAMPLES (1536*6)
+Index: dvbcut-0.5.4/src/psfile.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/psfile.cpp
++++ dvbcut-0.5.4/src/psfile.cpp
+@@ -19,7 +19,10 @@
+ #include "psfile.h"
+ #include "streamhandle.h"
+ #include "stream.h"
++
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
+
+ psfile::psfile(const std::string &filename, inbuffer &b, int initial_offset)
+ : mpgfile(filename, b, initial_offset)
+Index: dvbcut-0.5.4/src/streamdata.h
+===================================================================
+--- dvbcut-0.5.4.orig/src/streamdata.h
++++ dvbcut-0.5.4/src/streamdata.h
+@@ -21,7 +21,9 @@
+
+ #include <string>
+ #include <list>
++extern "C" {
+ #include <ffmpeg/avformat.h>
++}
+
+ #include "port.h"
+ #include "tsfile.h"
+Index: dvbcut-0.5.4/src/tsfile.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/tsfile.cpp
++++ dvbcut-0.5.4/src/tsfile.cpp
+@@ -22,7 +22,9 @@
+ #include <list>
+ #include <utility>
+
++extern "C" {
+ #include <ffmpeg/avcodec.h>
++}
+
+ tsfile::tsfile(const std::string &filename, inbuffer &b, int initial_offset)
+ : mpgfile(filename, b, initial_offset)
diff --git a/media-video/dvbcut/files/dvbcut-0.5.4-gcc42.patch b/media-video/dvbcut/files/dvbcut-0.5.4-gcc42.patch
new file mode 100644
index 000000000000..ba61fcdca064
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.5.4-gcc42.patch
@@ -0,0 +1,13 @@
+Index: dvbcut-0.5.4/src/playaudio.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/playaudio.cpp
++++ dvbcut-0.5.4/src/playaudio.cpp
+@@ -38,7 +38,7 @@ void playaudio(const void *data, uint32_
+ const uint8_t *d=(const uint8_t*)data;
+
+ while (len>0) {
+- int16_t samples[MIN_BUFFER_SAMPLES >? avcc->frame_size];
++ int16_t samples[MIN_BUFFER_SAMPLES > avcc->frame_size ? MIN_BUFFER_SAMPLES : avcc->frame_size ];
+ int frame_size;
+
+ int bytesDecoded=avcodec_decode_audio(avcc,samples,&frame_size,(uint8_t*)d,len);