summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-19 19:31:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-19 19:31:52 +0000
commit9f604bf461744e779e0425ab5af85e68f382bd7e (patch)
tree0ee9cbff5a91a522d38837257860b2a19c59aeb3 /media-video
parentStable on ppc. (diff)
downloadgentoo-2-9f604bf461744e779e0425ab5af85e68f382bd7e.tar.gz
gentoo-2-9f604bf461744e779e0425ab5af85e68f382bd7e.tar.bz2
gentoo-2-9f604bf461744e779e0425ab5af85e68f382bd7e.zip
Added patch to build fine without X at all.
(Portage version: 2.0.51.22)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/toxine/ChangeLog6
-rw-r--r--media-video/toxine/files/toxine-0.6.3-nox.patch36
-rw-r--r--media-video/toxine/toxine-0.6.3.ebuild3
3 files changed, 43 insertions, 2 deletions
diff --git a/media-video/toxine/ChangeLog b/media-video/toxine/ChangeLog
index 33ce25b650ac..aae75233155d 100644
--- a/media-video/toxine/ChangeLog
+++ b/media-video/toxine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/toxine
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/toxine/ChangeLog,v 1.1 2005/08/18 22:12:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/toxine/ChangeLog,v 1.2 2005/08/19 19:31:52 flameeyes Exp $
+
+ 19 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/toxine-0.6.3-nox.patch, toxine-0.6.3.ebuild:
+ Added patch to build fine without X at all.
*toxine-0.6.3 (18 Aug 2005)
diff --git a/media-video/toxine/files/toxine-0.6.3-nox.patch b/media-video/toxine/files/toxine-0.6.3-nox.patch
new file mode 100644
index 000000000000..d86db6d4a760
--- /dev/null
+++ b/media-video/toxine/files/toxine-0.6.3-nox.patch
@@ -0,0 +1,36 @@
+diff -ur toxine-0.6.3/configure.ac toxine-0.6.3-nox/configure.ac
+--- toxine-0.6.3/configure.ac 2004-04-16 18:32:30.000000000 +0200
++++ toxine-0.6.3-nox/configure.ac 2005-08-19 21:22:55.000000000 +0200
+@@ -141,6 +141,7 @@
+ if test x"$no_x" != x"yes"; then
+ AC_DEFINE(HAVE_X11,,[Define this if you have X11R6 installed])
+ fi
++AM_CONDITIONAL(HAVE_X11, test x"$no_x" != x"yes")
+
+ dnl
+ dnl XTest Extension
+Only in toxine-0.6.3-nox: configure.ac~
+diff -ur toxine-0.6.3/src/plugins/Makefile.am toxine-0.6.3-nox/src/plugins/Makefile.am
+--- toxine-0.6.3/src/plugins/Makefile.am 2004-04-12 00:29:01.000000000 +0200
++++ toxine-0.6.3-nox/src/plugins/Makefile.am 2005-08-19 21:23:36.000000000 +0200
+@@ -6,6 +6,10 @@
+
+ LIBTOOL = $(SHELL) $(top_builddir)/libtoolplugin-nofpic
+
++if HAVE_X11
++x11_plugin = toxine_vo_plugin_x11.la
++endif
++
+ if HAVE_AA
+ aa_plugin = toxine_vo_plugin_aa.la
+ endif
+@@ -14,7 +18,7 @@
+ caca_plugin = toxine_vo_plugin_caca.la
+ endif
+
+-lib_LTLIBRARIES = $(aa_plugin) $(caca_plugin) toxine_vo_plugin_x11.la \
++lib_LTLIBRARIES = $(aa_plugin) $(caca_plugin) $(x11_plugin) \
+ toxine_vo_plugin_dxr3.la toxine_vo_plugin_none.la
+
+ toxine_vo_plugin_x11_la_SOURCES = vo_x11.c
+Only in toxine-0.6.3-nox/src/plugins: Makefile.am~
diff --git a/media-video/toxine/toxine-0.6.3.ebuild b/media-video/toxine/toxine-0.6.3.ebuild
index ff7c95206909..6ba50ac81253 100644
--- a/media-video/toxine/toxine-0.6.3.ebuild
+++ b/media-video/toxine/toxine-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/toxine/toxine-0.6.3.ebuild,v 1.1 2005/08/18 22:12:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/toxine/toxine-0.6.3.ebuild,v 1.2 2005/08/19 19:31:52 flameeyes Exp $
inherit eutils
@@ -29,6 +29,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-configure.patch
epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-nox.patch
aclocal -I m4 || die "aclocal failed"
autoconf || die "autoconf failed"