summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-14 08:26:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-14 08:26:05 +0000
commitac0d029879184eea3bb5af906bb8643521f2daf0 (patch)
treef014273bcbc4b0e3d080b9fc0edff01f6a39c42c /media-video
parentRevision bump reverts upstream changes for dav calendar wrt bug #415401. (diff)
downloadgentoo-2-ac0d029879184eea3bb5af906bb8643521f2daf0.tar.gz
gentoo-2-ac0d029879184eea3bb5af906bb8643521f2daf0.tar.bz2
gentoo-2-ac0d029879184eea3bb5af906bb8643521f2daf0.zip
use the same use expand for tools like ffmpeg does so we are more inline with each other.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libav/ChangeLog7
-rw-r--r--media-video/libav/libav-0.8.2-r1.ebuild20
-rw-r--r--media-video/libav/libav-0.8.9999.ebuild20
-rw-r--r--media-video/libav/libav-9999.ebuild40
4 files changed, 36 insertions, 51 deletions
diff --git a/media-video/libav/ChangeLog b/media-video/libav/ChangeLog
index 2b3cf81125fa..fe5889035fe2 100644
--- a/media-video/libav/ChangeLog
+++ b/media-video/libav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/libav
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/ChangeLog,v 1.78 2012/05/14 06:49:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/ChangeLog,v 1.79 2012/05/14 08:26:05 scarabeus Exp $
+
+ 14 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libav-0.8.2-r1.ebuild,
+ libav-0.8.9999.ebuild, libav-9999.ebuild:
+ use the same use expand for tools like ffmpeg does so we are more inline with
+ each other.
*libav-0.8.2-r1 (14 May 2012)
diff --git a/media-video/libav/libav-0.8.2-r1.ebuild b/media-video/libav/libav-0.8.2-r1.ebuild
index e6c7f84e1ba5..4bab89a6ec97 100644
--- a/media-video/libav/libav-0.8.2-r1.ebuild
+++ b/media-video/libav/libav-0.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.8.2-r1.ebuild,v 1.1 2012/05/14 06:49:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.8.2-r1.ebuild,v 1.2 2012/05/14 08:26:05 scarabeus Exp $
EAPI=4
@@ -31,7 +31,7 @@ IUSE=" aac aacplus alsa ass amr bindist +bzip2 cdio celt cpudetection
custom-cflags dirac debug doc +encode faac frei0r +gpl gsm
+hardcoded-tables ieee1394 jack jpeg2k libv4l modplug mp3 network
openal openssl oss pic pulseaudio rtmp schroedinger sdl speex ssl
- static-libs test theora threads tools truetype v4l vaapi vdpau vorbis
+ static-libs test theora threads truetype v4l vaapi vdpau vorbis
vpx X x264 xvid +zlib"
# String for CPU features in the useflag[:configure_option] form
@@ -132,8 +132,6 @@ src_prepare() {
fi
}
-TOOLS="aviocat graph2dot ismindex qt-faststart"
-
src_configure() {
local myconf="${EXTRA_LIBAV_CONF}"
local uses i
@@ -144,8 +142,6 @@ src_configure() {
--enable-avfilter
"
- use zlib && TOOLS+=" cws2fws"
-
# enabled by default
uses="debug doc network zlib"
for i in ${uses}; do
@@ -302,11 +298,9 @@ src_compile() {
emake
- if use tools; then
- for i in ${TOOLS}; do
- emake tools/${i}
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && emake tools/${i}
done
- fi
}
src_install() {
@@ -317,11 +311,9 @@ src_install() {
dodoc doc/*.txt
use doc && dodoc doc/*.html
- if use tools; then
- for i in ${TOOLS}; do
- dobin tools/${i}
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && dobin tools/${i}
done
- fi
for i in $(usex sdl avplay "") $(usex network avserver "") avprobe; do
dosym ${i} /usr/bin/${i/av/ff}
diff --git a/media-video/libav/libav-0.8.9999.ebuild b/media-video/libav/libav-0.8.9999.ebuild
index 620d57eb5541..bb970cbd892c 100644
--- a/media-video/libav/libav-0.8.9999.ebuild
+++ b/media-video/libav/libav-0.8.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.8.9999.ebuild,v 1.10 2012/05/14 06:49:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.8.9999.ebuild,v 1.11 2012/05/14 08:26:05 scarabeus Exp $
EAPI=4
@@ -31,7 +31,7 @@ IUSE=" aac aacplus alsa ass amr bindist +bzip2 cdio celt cpudetection
custom-cflags dirac debug doc +encode faac frei0r +gpl gsm
+hardcoded-tables ieee1394 jack jpeg2k libv4l modplug mp3 network
openal openssl oss pic pulseaudio rtmp schroedinger sdl speex ssl
- static-libs test theora threads tools truetype v4l vaapi vdpau vorbis
+ static-libs test theora threads truetype v4l vaapi vdpau vorbis
vpx X x264 xvid +zlib"
# String for CPU features in the useflag[:configure_option] form
@@ -132,8 +132,6 @@ src_prepare() {
fi
}
-TOOLS="aviocat graph2dot ismindex qt-faststart"
-
src_configure() {
local myconf="${EXTRA_LIBAV_CONF}"
local uses i
@@ -144,8 +142,6 @@ src_configure() {
--enable-avfilter
"
- use zlib && TOOLS+=" cws2fws"
-
# enabled by default
uses="debug doc network zlib"
for i in ${uses}; do
@@ -302,11 +298,9 @@ src_compile() {
emake
- if use tools; then
- for i in ${TOOLS}; do
- emake tools/${i}
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && emake tools/${i}
done
- fi
}
src_install() {
@@ -317,11 +311,9 @@ src_install() {
dodoc doc/*.txt
use doc && dodoc doc/*.html
- if use tools; then
- for i in ${TOOLS}; do
- dobin tools/${i}
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && dobin tools/${i}
done
- fi
for i in $(usex sdl avplay "") $(usex network avserver "") avprobe; do
dosym ${i} /usr/bin/${i/av/ff}
diff --git a/media-video/libav/libav-9999.ebuild b/media-video/libav/libav-9999.ebuild
index 98b94aac5643..9b4fcc3d58ea 100644
--- a/media-video/libav/libav-9999.ebuild
+++ b/media-video/libav/libav-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.40 2012/05/14 06:32:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.41 2012/05/14 08:26:05 scarabeus Exp $
EAPI=4
@@ -27,21 +27,24 @@ SLOT="0"
[[ ${PV} == *9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64
~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos
~x64-solaris ~x86-solaris"
-IUSE=" aac aacplus alsa ass amr bindist bluray +bzip2 cdio celt cpudetection
+IUSE="aac aacplus alsa ass amr bindist bluray +bzip2 cdio celt cpudetection
custom-cflags debug doc +encode faac fontconfig frei0r +gpl gsm
- +hardcoded-tables ieee1394 jack jpeg2k libv4l modplug mp3 network
- openal openssl oss pic pulseaudio rtmp schroedinger sdl speex ssl
- static-libs test theora threads tools truetype v4l vaapi vdpau vorbis
- vpx X x264 xvid +zlib"
+ +hardcoded-tables ieee1394 jack jpeg2k libv4l modplug mp3 network openal
+ openssl oss pic pulseaudio rtmp schroedinger sdl speex ssl static-libs test
+ theora threads truetype v4l vaapi vdpau vorbis vpx X x264 xvid +zlib"
# String for CPU features in the useflag[:configure_option] form
# if :configure_option isn't set, it will use 'useflag' as configure option
CPU_FEATURES="3dnow:amd3dnow 3dnowext:amd3dnowext altivec avx mmx mmxext:mmx2 neon ssse3 vis"
-
-for i in ${CPU_FEATURES}; do
+for i in ${CPU_FEATURES} ; do
IUSE+=" ${i%:*}"
done
+FFTOOLS="aviocat cws2fws graph2dot ismindex pktdumper qt-faststart trasher"
+for i in ${FFTOOLS} ; do
+ IUSE+=" +fftools_${i}"
+done
+
RDEPEND="
!media-video/ffmpeg
alsa? ( media-libs/alsa-lib )
@@ -131,8 +134,6 @@ src_prepare() {
fi
}
-TOOLS="aviocat graph2dot ismindex qt-faststart"
-
src_configure() {
local myconf="${EXTRA_LIBAV_CONF}"
local uses i
@@ -143,8 +144,6 @@ src_configure() {
--enable-avfilter
"
- use zlib && TOOLS+=" cws2fws"
-
# enabled by default
uses="debug doc network zlib"
for i in ${uses}; do
@@ -303,26 +302,23 @@ src_compile() {
emake
- if use tools; then
- for i in ${TOOLS}; do
- emake tools/${i}
- done
- fi
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && emake tools/${i}
+ done
}
src_install() {
local i
+
emake DESTDIR="${D}" install install-man
dodoc Changelog README INSTALL
dodoc doc/*.txt
use doc && dodoc doc/*.html
- if use tools; then
- for i in ${TOOLS}; do
- dobin tools/${i}
- done
- fi
+ for i in ${FFTOOLS} ; do
+ use fftools_${i} && dobin tools/${i}
+ done
for i in $(usex sdl avplay "") $(usex network avserver "") avprobe; do
dosym ${i} /usr/bin/${i/av/ff}