summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-03-31 21:11:46 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-03-31 21:11:46 +0000
commitc5114441edcb2b092435d7a8c099878ca042f9fa (patch)
tree4a568d0caf9e6bff26115f9de41c95615d39f274 /media-video
parentIncorporate suggestions from Message-ID: <20080330053631.GB24954@comet.had1.o... (diff)
downloadgentoo-2-c5114441edcb2b092435d7a8c099878ca042f9fa.tar.gz
gentoo-2-c5114441edcb2b092435d7a8c099878ca042f9fa.tar.bz2
gentoo-2-c5114441edcb2b092435d7a8c099878ca042f9fa.zip
Non-maintainer-bump (bug #188626), a lot of fixes and new features,
including HD support. Thanks to Toffanin, Patrick Huber and Roberto Castagnola for contributions. (Portage version: 2.1.4.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/kdenlive/ChangeLog13
-rw-r--r--media-video/kdenlive/kdenlive-0.5.ebuild52
2 files changed, 63 insertions, 2 deletions
diff --git a/media-video/kdenlive/ChangeLog b/media-video/kdenlive/ChangeLog
index 55b6eebd8d57..48b0e92aa4f9 100644
--- a/media-video/kdenlive/ChangeLog
+++ b/media-video/kdenlive/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/kdenlive
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/ChangeLog,v 1.19 2007/12/25 17:24:20 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/ChangeLog,v 1.20 2008/03/31 21:11:46 rbu Exp $
+
+*kdenlive-0.5 (31 Mar 2008)
+
+ 31 Mar 2008; Robert Buchholz <rbu@gentoo.org> +kdenlive-0.5.ebuild:
+ Non-maintainer-bump (bug #188626), a lot of fixes and new features,
+ including HD support. Thanks to Toffanin, Patrick Huber and Roberto
+ Castagnola for contributions.
+
+ This should also fix bug #193641.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing zypher from metadata.xml as per #26909. Assigning to
diff --git a/media-video/kdenlive/kdenlive-0.5.ebuild b/media-video/kdenlive/kdenlive-0.5.ebuild
new file mode 100644
index 000000000000..2bf939dc1e84
--- /dev/null
+++ b/media-video/kdenlive/kdenlive-0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kdenlive/kdenlive-0.5.ebuild,v 1.1 2008/03/31 21:11:46 rbu Exp $
+
+inherit eutils kde
+
+DESCRIPTION="Kdenlive! (pronounced Kay-den-live) is a Non Linear Video Editing Suite for KDE."
+HOMEPAGE="http://kdenlive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kdenlive/${P}-1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="media-video/ffmpeg
+ >=media-libs/mlt-0.2.4-r1
+ >=media-libs/mlt++-20060601"
+
+DEPEND="${RDEPEND}
+ x11-base/xorg-server
+ x11-proto/xextproto"
+
+need-kde 3
+
+pkg_setup() {
+ if ! built_with_use media-libs/mlt sdl || \
+ ! built_with_use media-video/ffmpeg sdl ; then
+ eerror "You need to build both media-libs/mlt with USE='sdl'"
+ die "media-libs/mlt or media-video/ffmpeg without sdl detected"
+ fi
+
+ if ! built_with_use media-video/ffmpeg X ; then
+ eerror "You need to build media-video/ffmpeg with USE='X'"
+ die "media-video/ffmpeg without X detected"
+ fi
+}
+
+src_compile() {
+ rm configure
+ myconf="--enable-pch"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # docbook is not generated, does not build properly
+ # and is installed to the wrong location
+ rm -r "${D}"/usr/share/doc/HTML
+}