summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-25 20:53:16 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-25 20:53:16 +0000
commitc8bf94e5db7e89079e7a7af333365880cc02213c (patch)
treedcfa738eefc741395d72c7271681ea604cdfe2ba /media-video
parentRevision bump, update to EAPI 4 and fix repoman warning (diff)
downloadgentoo-2-c8bf94e5db7e89079e7a7af333365880cc02213c.tar.gz
gentoo-2-c8bf94e5db7e89079e7a7af333365880cc02213c.tar.bz2
gentoo-2-c8bf94e5db7e89079e7a7af333365880cc02213c.zip
Bump to EAPI 4, add explicit RDEPEND, fix .desktop validation.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/kffmpegthumbnailer/ChangeLog11
-rw-r--r--media-video/kffmpegthumbnailer/kffmpegthumbnailer-1.1.0-r1.ebuild31
2 files changed, 39 insertions, 3 deletions
diff --git a/media-video/kffmpegthumbnailer/ChangeLog b/media-video/kffmpegthumbnailer/ChangeLog
index b7cbb437798c..a528b17baee9 100644
--- a/media-video/kffmpegthumbnailer/ChangeLog
+++ b/media-video/kffmpegthumbnailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/kffmpegthumbnailer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kffmpegthumbnailer/ChangeLog,v 1.6 2011/02/02 05:16:09 tampakrap Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kffmpegthumbnailer/ChangeLog,v 1.7 2012/08/25 20:53:16 creffett Exp $
+
+*kffmpegthumbnailer-1.1.0-r1 (25 Aug 2012)
+
+ 25 Aug 2012; Chris Reffett <creffett@gentoo.org>
+ +kffmpegthumbnailer-1.1.0-r1.ebuild:
+ Bump to EAPI 4, add explicit RDEPEND, fix .desktop validation.
02 Feb 2011; Theo Chatzimichos <tampakrap@gentoo.org>
kffmpegthumbnailer-1.1.0.ebuild:
@@ -31,4 +37,3 @@
24 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+kffmpegthumbnailer-1.0.0.ebuild:
Initial commit.
-
diff --git a/media-video/kffmpegthumbnailer/kffmpegthumbnailer-1.1.0-r1.ebuild b/media-video/kffmpegthumbnailer/kffmpegthumbnailer-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..8070b81e825b
--- /dev/null
+++ b/media-video/kffmpegthumbnailer/kffmpegthumbnailer-1.1.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kffmpegthumbnailer/kffmpegthumbnailer-1.1.0-r1.ebuild,v 1.1 2012/08/25 20:53:16 creffett Exp $
+
+EAPI=4
+inherit kde4-base
+
+DESCRIPTION="A thumbnailer for KDE based on ffmpegthumbnailer"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
+SRC_URI="http://ffmpegthumbnailer.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=media-video/ffmpegthumbnailer-2
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( Changelog README )
+
+src_prepare() {
+ sed -e "s:CacheThumbnail:X-CacheThumbnail:" \
+ -e "s:IgnoreMaximumSize:X-IgnoreMaximumSize:" \
+ -e "s:ThumbnailerVersion:X-ThumbnailerVersion:" \
+ -e "/Encoding=UTF-8/d" \
+ -i kffmpegthumbnailer.desktop || die "fixing .desktop file failed"
+ kde4-base_src_prepare
+}