summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-10-23 21:14:06 +0000
committerHanno Böck <hanno@gentoo.org>2008-10-23 21:14:06 +0000
commite22f57d3ff7914124534598c29e958b98780bb0e (patch)
tree2eeecccbb438f27b2ddb4f0d1cea89ecc9bb2b6b /media-video
parentSparc stable, Bug #243270, which see. (diff)
downloadgentoo-2-e22f57d3ff7914124534598c29e958b98780bb0e.tar.gz
gentoo-2-e22f57d3ff7914124534598c29e958b98780bb0e.tar.bz2
gentoo-2-e22f57d3ff7914124534598c29e958b98780bb0e.zip
ffmpeg2theora bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc9-00179-g2447a26 x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg2theora/ChangeLog7
-rw-r--r--media-video/ffmpeg2theora/ffmpeg2theora-0.22.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-video/ffmpeg2theora/ChangeLog b/media-video/ffmpeg2theora/ChangeLog
index 1d1f68ecf309..cf76412b80a4 100644
--- a/media-video/ffmpeg2theora/ChangeLog
+++ b/media-video/ffmpeg2theora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpeg2theora
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ChangeLog,v 1.26 2008/10/15 17:43:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ChangeLog,v 1.27 2008/10/23 21:14:06 hanno Exp $
+
+*ffmpeg2theora-0.22 (22 Oct 2008)
+
+ 22 Oct 2008; Hanno Boeck <hanno@gentoo.org> +ffmpeg2theora-0.22.ebuild:
+ Version bump.
15 Oct 2008; Alexis Ballier <aballier@gentoo.org>
-ffmpeg2theora-0.18.ebuild, -ffmpeg2theora-0.19.ebuild,
diff --git a/media-video/ffmpeg2theora/ffmpeg2theora-0.22.ebuild b/media-video/ffmpeg2theora/ffmpeg2theora-0.22.ebuild
new file mode 100644
index 000000000000..7a7ba0d3ea53
--- /dev/null
+++ b/media-video/ffmpeg2theora/ffmpeg2theora-0.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ffmpeg2theora-0.22.ebuild,v 1.1 2008/10/23 21:14:06 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="A simple converter to create Ogg Theora files."
+HOMEPAGE="http://www.v2v.cc/~j/ffmpeg2theora/index.html"
+SRC_URI="http://www.v2v.cc/~j/ffmpeg2theora/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-video/ffmpeg-0.4.9_p20070616-r20
+ >=media-libs/libvorbis-1.1
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_beta1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/scons"
+
+pkg_setup() {
+ local fail="Re-emerge media-libs/libtheora with USE encode."
+
+ if ! built_with_use media-libs/libtheora encode; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+ if ! built_with_use --missing true media-video/ffmpeg vhook; then
+ eerror "${PN} requires ffmpeg to be built with the vhook useflag."
+ die "Please reinstall media-video/ffmpeg with the vhook useflag enabled"
+ fi
+}
+
+src_compile() {
+ scons APPEND_CFLAGS="${CFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}" || die "scons failed"
+}
+
+src_install() {
+ scons destdir="${D}" prefix=/usr install || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO || die
+# newdoc kino_export/README README.kino_export
+# exeinto /usr/share/kino/scripts/exports
+# doexe kino_export/ffmpeg2theora.sh
+}