summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-09 20:07:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-09 20:07:27 +0000
commitec5d3439c58c30c983616fc29b553422ac43ce65 (patch)
tree53966a85b74eadfc6658fe5d28e6283038197e44 /media-video
parentPinpoint virtual/x11 version to less than 7. (diff)
downloadgentoo-2-ec5d3439c58c30c983616fc29b553422ac43ce65.tar.gz
gentoo-2-ec5d3439c58c30c983616fc29b553422ac43ce65.tar.bz2
gentoo-2-ec5d3439c58c30c983616fc29b553422ac43ce65.zip
Almost rewrite the ebuild so that it works.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mvc/ChangeLog7
-rw-r--r--media-video/mvc/files/digest-mvc-0.8.72
-rw-r--r--media-video/mvc/mvc-0.8.7.ebuild34
3 files changed, 28 insertions, 15 deletions
diff --git a/media-video/mvc/ChangeLog b/media-video/mvc/ChangeLog
index 64b0637386ba..5fcd3825f682 100644
--- a/media-video/mvc/ChangeLog
+++ b/media-video/mvc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/mvc
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mvc/ChangeLog,v 1.2 2005/07/28 10:44:32 dholm Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mvc/ChangeLog,v 1.3 2006/07/09 20:07:27 flameeyes Exp $
+
+ 09 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> mvc-0.8.7.ebuild:
+ Almost rewrite the ebuild so that it works.
28 Jul 2005; David Holm <dholm@gentoo.org> mvc-0.8.7.ebuild:
Added to ~ppc.
diff --git a/media-video/mvc/files/digest-mvc-0.8.7 b/media-video/mvc/files/digest-mvc-0.8.7
index bffc9ae547a2..90e09b0abf74 100644
--- a/media-video/mvc/files/digest-mvc-0.8.7
+++ b/media-video/mvc/files/digest-mvc-0.8.7
@@ -1 +1,3 @@
MD5 3e36e81ec30f2bd9be94f5933b7ae8b6 mvc-0.8.7.tar.gz 20640
+RMD160 d445ae0c76eb88f1db63512b3b6070cf5d6d43d8 mvc-0.8.7.tar.gz 20640
+SHA256 52a806375b52bf7450e42c64b2ee1b085f5fa8370720471573e0bb561e0d5c49 mvc-0.8.7.tar.gz 20640
diff --git a/media-video/mvc/mvc-0.8.7.ebuild b/media-video/mvc/mvc-0.8.7.ebuild
index 14fe5fd5ecef..6697abad2586 100644
--- a/media-video/mvc/mvc-0.8.7.ebuild
+++ b/media-video/mvc/mvc-0.8.7.ebuild
@@ -1,30 +1,38 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mvc/mvc-0.8.7.ebuild,v 1.2 2005/07/28 10:44:32 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mvc/mvc-0.8.7.ebuild,v 1.3 2006/07/09 20:07:27 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Motion Video Capture, text mode v4l video capture program with motion detection feature"
HOMEPAGE="http://modesto.sourceforge.net/piave/index.html"
-MY_P="${P}"
-SRC_URI="http://www.turbolinux.com.cn/~merlin/mvc/${MY_P}.tar.gz"
+SRC_URI="http://www.turbolinux.com.cn/~merlin/mvc/${P}.tar.gz"
-IUSE="nls"
+IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~ppc ~x86"
-DEPEND="virtual/x11"
+RDEPEND="media-libs/jpeg
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e "s:prefix=/usr:prefix=${D}/usr:" Makefile || die "Could not fix install path"
+doecho() {
+ echo "$@"
+ exec "$@"
}
src_compile() {
- emake || die
+ doecho $(tc-getCC) \
+ ${CFLAGS} -DHAVE_JPEG -DHAVE_PNG $(pkg-config --cflags libpng) \
+ ${LDFLAGS} -o mvc \
+ mvc.c \
+ -ljpeg $(pkg-config --libs libpng)
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog README TODO
+ dobin mvc
+ doman mvc.1
+ dodoc ChangeLog README TODO NEWS
}