summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-03 21:14:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-03 21:14:37 +0000
commit919ef00012a14dd0eab671239f02699466d509de (patch)
treee572f3b9670e220ffe1f27785600e4a35dc82ff0 /net-analyzer/argus-clients
parentppc stable wrt bug #502362 (diff)
downloadgentoo-2-919ef00012a14dd0eab671239f02699466d509de.tar.gz
gentoo-2-919ef00012a14dd0eab671239f02699466d509de.tar.bz2
gentoo-2-919ef00012a14dd0eab671239f02699466d509de.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/argus-clients')
-rw-r--r--net-analyzer/argus-clients/ChangeLog7
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.7.26.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index 119a146bc5ee..0ff2ad466977 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.61 2014/03/05 17:08:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.62 2014/05/03 21:14:37 jer Exp $
+
+*argus-clients-3.0.7.26 (03 May 2014)
+
+ 03 May 2014; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.7.26.ebuild:
+ Version bump.
*argus-clients-3.0.7.21 (05 Mar 2014)
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.7.26.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.7.26.ebuild
new file mode 100644
index 000000000000..2570705970ad
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.7.26.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.7.26.ebuild,v 1.1 2014/05/03 21:14:37 jer Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+MY_CDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+
+RDEPEND="
+ ${MY_CDEPEND}
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.7.18-sasl.patch \
+ "${FILESDIR}"/${PN}-3.0.7.21-curses-readline.patch
+
+ sed -i -e 's| ar | $(AR) |g' common/Makefile.in || die
+ tc-export AR RANLIB
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ # racurses uses both libncurses and libtinfo, if present
+ emake \
+ CCOPT="${CFLAGS} ${LDFLAGS}" \
+ RANLIB=$(tc-getRANLIB) \
+ CURSESLIB="$( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}