summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-30 19:35:20 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-30 19:35:20 +0000
commitf6e3fa1df847af6d7abd417041746aabcf38a335 (patch)
tree351680c566600fb7fb7c84a255112cb8891eb3de /net-analyzer/argus-clients
parentVersion bump. (diff)
downloadgentoo-2-f6e3fa1df847af6d7abd417041746aabcf38a335.tar.gz
gentoo-2-f6e3fa1df847af6d7abd417041746aabcf38a335.tar.bz2
gentoo-2-f6e3fa1df847af6d7abd417041746aabcf38a335.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus-clients')
-rw-r--r--net-analyzer/argus-clients/ChangeLog7
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.5.19.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index 7bd6c1e2e324..bb16efaf845f 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.26 2011/08/01 22:44:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.27 2011/08/30 19:35:20 jer Exp $
+
+*argus-clients-3.0.5.19 (30 Aug 2011)
+
+ 30 Aug 2011; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.5.19.ebuild:
+ Version bump.
*argus-clients-3.0.5.18 (01 Aug 2011)
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.5.19.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.5.19.ebuild
new file mode 100644
index 000000000000..fd39ad633f4b
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.5.19.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.5.19.ebuild,v 1.1 2011/08/30 19:35:20 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug geoip mysql tcpd"
+
+#sasl? ( >=dev-libs/cyrus-sasl-1.5.24 )
+MY_CDEPEND="
+ net-libs/libpcap
+ net-analyzer/rrdtool[perl]
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sys-libs/ncurses
+"
+
+# >=net-analyzer/argus-2.0.6[sasl?]"
+RDEPEND="
+ ${MY_CDEPEND}
+ >=net-analyzer/argus-3.0.2
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ # $(use_with sasl) \
+ econf \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra* || die "Failed to install ra*"
+ dodoc ChangeLog CREDITS README doc/{CHANGES,FAQ,HOW-TO} || die
+ doman man/man{1,5}/*
+}