summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-21 12:45:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-21 12:45:05 +0000
commit9fcb23de2641cfc416622ad5e74c47626e9e8108 (patch)
tree112cb62bdb4a1e698540be4c0c01a81d77795bc7 /net-analyzer/argus/argus-2.0.6.ebuild
parentdosemu: only rdep on xf86dgaproto (diff)
downloadgentoo-2-9fcb23de2641cfc416622ad5e74c47626e9e8108.tar.gz
gentoo-2-9fcb23de2641cfc416622ad5e74c47626e9e8108.tar.bz2
gentoo-2-9fcb23de2641cfc416622ad5e74c47626e9e8108.zip
Die when dolib or newsbin fail since the make process always return success.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-analyzer/argus/argus-2.0.6.ebuild')
-rw-r--r--net-analyzer/argus/argus-2.0.6.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-analyzer/argus/argus-2.0.6.ebuild b/net-analyzer/argus/argus-2.0.6.ebuild
index 80061869c549..66a0717b56dc 100644
--- a/net-analyzer/argus/argus-2.0.6.ebuild
+++ b/net-analyzer/argus/argus-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.6.ebuild,v 1.4 2008/01/16 18:57:38 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.6.ebuild,v 1.5 2008/11/21 12:45:05 flameeyes Exp $
inherit eutils
@@ -34,9 +34,13 @@ src_install () {
#do not install man/man1/tcpdump.1, file collision
doman man/man5/* man/man8/*
- dolib lib/argus_common.a lib/argus_parse.a
+ dolib lib/argus_common.a lib/argus_parse.a || die "dolib failed"
- [[ ${CHOST} == *-darwin* ]] && newsbin bin/argus_bpf argus || newsbin bin/argus_linux argus
+ if [[ ${CHOST} == *-darwin* ]]; then
+ newsbin bin/argus_bpf argus || die "newsbin failed"
+ else
+ newsbin bin/argus_linux argus || die "newsbin failed"
+ fi
insinto /etc/argus
doins support/Config/argus.conf