summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-08-27 02:19:17 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2013-08-27 02:19:17 +0000
commit185965f8eaa5d8be3b812e7465b4f9b7bf7fc369 (patch)
tree6b29746c784aa48390c3b429eb06d6587f68e3e9 /net-analyzer/cacti-spine
parentdolphin-9999.ebuild: Adds check for merge type to prevent unnecessary checkin... (diff)
downloadgentoo-2-185965f8eaa5d8be3b812e7465b4f9b7bf7fc369.tar.gz
gentoo-2-185965f8eaa5d8be3b812e7465b4f9b7bf7fc369.tar.bz2
gentoo-2-185965f8eaa5d8be3b812e7465b4f9b7bf7fc369.zip
Copy cacti-spine from my overlay.
Bump cacti-spine to the 0.8.8b release (Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/ChangeLog8
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild65
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch12
3 files changed, 84 insertions, 1 deletions
diff --git a/net-analyzer/cacti-spine/ChangeLog b/net-analyzer/cacti-spine/ChangeLog
index 7ffc2bda4cb2..fc04d4920f5e 100644
--- a/net-analyzer/cacti-spine/ChangeLog
+++ b/net-analyzer/cacti-spine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti-spine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.37 2013/04/27 15:09:23 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/ChangeLog,v 1.38 2013/08/27 02:19:17 jmbsvicetto Exp $
+
+*cacti-spine-0.8.8b (27 Aug 2013)
+
+ 27 Aug 2013; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +cacti-spine-0.8.8b.ebuild, +files/cacti-spine-0.8.8b-fix-ac-macro.patch:
+ Copy cacti-spine from my overlay. Bump cacti-spine to the 0.8.8b release
*cacti-spine-0.8.8a (27 Apr 2013)
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild
new file mode 100644
index 000000000000..1a3ada7bdffb
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-spine/cacti-spine-0.8.8b.ebuild,v 1.1 2013/08/27 02:19:17 jmbsvicetto Exp $
+
+EAPI="4"
+inherit autotools eutils
+
+UPSTREAM_PATCHES=""
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="net-analyzer/net-snmp
+ dev-libs/openssl
+ virtual/mysql"
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
+
+if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES}; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/spine/patches/${PV}/${i}.patch"
+ done
+fi
+
+src_prepare() {
+ # Patch configure.ac to replace AM_CONFIG_HEADER with AC_CONFIG_HEADERS
+ epatch "${FILESDIR}/${P}-fix-ac-macro.patch"
+
+ if [[ -n ${UPSTREAM_PATCHES} ]]; then
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -N" epatch "${DISTDIR}"/${i}.patch
+ done
+ fi
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine || die
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,} || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ elog "Please see the cacti's site for installation instructions:"
+ elog
+ elog "http://cacti.net/spine_install.php"
+ echo
+ ewarn "/etc/spine.conf should be readable by webserver, thus after you"
+ ewarn "decide on webserver do not forget to run the following command:"
+ ewarn
+ ewarn " # chown root:<wwwgroup> /etc/spine.conf"
+ echo
+}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch
new file mode 100644
index 000000000000..81fb6dbbd0cd
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8b-fix-ac-macro.patch
@@ -0,0 +1,12 @@
+diff -ur cacti-spine-0.8.8b-orig/configure.ac cacti-spine-0.8.8b/configure.ac
+--- cacti-spine-0.8.8b-orig/configure.ac 2013-08-27 01:45:32.400120526 +0000
++++ cacti-spine-0.8.8b/configure.ac 2013-08-27 01:45:42.350084943 +0000
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8b)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,