summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-02-10 14:46:53 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-02-10 14:46:53 +0000
commit6a35925ea161a67abaaae5558680a7c0aebdfaaf (patch)
tree5924d4c72d4b32e4b452f295c245f45022012998 /net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild
parentadd ~alpha (diff)
downloadgentoo-2-6a35925ea161a67abaaae5558680a7c0aebdfaaf.tar.gz
gentoo-2-6a35925ea161a67abaaae5558680a7c0aebdfaaf.tar.bz2
gentoo-2-6a35925ea161a67abaaae5558680a7c0aebdfaaf.zip
adding a couple of hogwashes to portage
Diffstat (limited to 'net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild')
-rw-r--r--net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild b/net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild
new file mode 100644
index 000000000000..235beadeb699
--- /dev/null
+++ b/net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hogwash/hogwash-0.4.0_pre1.ebuild,v 1.1 2003/02/10 14:46:53 sethbc Exp $
+
+TGZFILE=hogwash-0.4-pre1.tgz
+S=${WORKDIR}/devel-0.4
+DESCRIPTION="An invisible, layer2 network packet scrubber based on snort"
+HOMEPAGE="http://hogwash.sourceforge.net"
+SRC_URI="mirror://sourceforge/hogwash/${TGZFILE}
+ http://hogwash.sourceforge.net/rules.2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND=">=net-libs/libpcap-0.6.1
+ >=net-libs/libnet-1.0.2a"
+
+src_unpack() {
+
+ unpack ${TGZFILE}
+}
+
+src_compile() {
+ cp setup setup.old
+ head -n 67 setup.old > setup
+ ./setup || die
+}
+
+src_install () {
+
+ dosbin hogwash
+ dodoc COPYRIGHT README ${FILESDIR}/Documentation.txt
+ dodir /var/log/snort
+ dodir /var/log/hogwash
+
+ insinto /etc/hogwash ; doins stock.rules ${DISTDIR}/rules.2
+ exeinto /etc/init.d ; newexe ${FILESDIR}/hogwash.rc6 hogwash
+}