summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-29 02:34:02 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-29 02:34:02 +0000
commitb775f5336d6c500579627c09392a5262d7a28f2b (patch)
treefaa6bdfcd35a63c5ffca7eb97c60e11dadfe2d4a /net-analyzer/honeyd
parentVersion bumped (development version). (diff)
downloadgentoo-2-b775f5336d6c500579627c09392a5262d7a28f2b.tar.gz
gentoo-2-b775f5336d6c500579627c09392a5262d7a28f2b.tar.bz2
gentoo-2-b775f5336d6c500579627c09392a5262d7a28f2b.zip
Added patch so honeyd will build with gcc-4.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-analyzer/honeyd')
-rw-r--r--net-analyzer/honeyd/ChangeLog6
-rw-r--r--net-analyzer/honeyd/Manifest15
-rw-r--r--net-analyzer/honeyd/files/honeyd-1.0-gcc4.diff23
-rw-r--r--net-analyzer/honeyd/honeyd-1.0.ebuild13
4 files changed, 39 insertions, 18 deletions
diff --git a/net-analyzer/honeyd/ChangeLog b/net-analyzer/honeyd/ChangeLog
index 93abc80bc8ed..1101d5f43163 100644
--- a/net-analyzer/honeyd/ChangeLog
+++ b/net-analyzer/honeyd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/honeyd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/ChangeLog,v 1.17 2005/02/25 12:58:03 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/ChangeLog,v 1.18 2005/05/29 02:34:02 ka0ttic Exp $
+
+ 29 May 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/honeyd-1.0-gcc4.diff, honeyd-1.0.ebuild:
+ Added patch so honeyd will build with gcc-4.
25 Feb 2005; Aaron Walker <ka0ttic@gentoo.org> honeyd-1.0.ebuild:
Marked stable on x86.
diff --git a/net-analyzer/honeyd/Manifest b/net-analyzer/honeyd/Manifest
index 8b8f7ab2502b..68290d6e8fd4 100644
--- a/net-analyzer/honeyd/Manifest
+++ b/net-analyzer/honeyd/Manifest
@@ -1,18 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f14a4d480a0e027ac820f59f90c529a0 honeyd-0.8.ebuild 1954
-MD5 0db0c60bfcfc41139150fd8b05e6c481 ChangeLog 2688
+MD5 bb7e29bb55179d53974b8d7af8dced77 ChangeLog 2835
MD5 fef2fd2afe9a195bdc62e5628a5fd501 metadata.xml 259
-MD5 186b41de635d2185288bd6ae8c72ce81 honeyd-1.0.ebuild 1779
+MD5 1cd123901a3279a87c57544b019a0a6f honeyd-1.0.ebuild 1871
+MD5 0f51773734c0ac0e902fc0eea15f9647 files/honeyd-1.0-gcc4.diff 674
MD5 05aa030ef5d390514cee9da3fa910690 files/honeyd.confd 429
MD5 1f9cce4545bcf9f1e0b47486617da5a0 files/honeyd.initd 1459
MD5 96be4ce17e233507825dbc39127ee9f3 files/digest-honeyd-0.8 129
MD5 857b8d8953a80aae5035664b1bc984a7 files/digest-honeyd-1.0 129
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCHyFnEZCkKN40op4RAmd0AJ474FetaURPIpKjI1W+FgXI0bOlfQCgs8a1
-X76T0ZE2mbgwUN3QqCAa/fs=
-=Z3pD
------END PGP SIGNATURE-----
diff --git a/net-analyzer/honeyd/files/honeyd-1.0-gcc4.diff b/net-analyzer/honeyd/files/honeyd-1.0-gcc4.diff
new file mode 100644
index 000000000000..5d38ee980070
--- /dev/null
+++ b/net-analyzer/honeyd/files/honeyd-1.0-gcc4.diff
@@ -0,0 +1,23 @@
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN honeyd-1.0.orig/dhcpclient.c honeyd-1.0/dhcpclient.c
+--- honeyd-1.0.orig/dhcpclient.c 2005-05-28 22:22:21.000000000 -0400
++++ honeyd-1.0/dhcpclient.c 2005-05-28 22:25:10.000000000 -0400
+@@ -472,7 +472,8 @@
+
+ memset(buf, 0, sizeof(buf));
+
+- eth = (struct eth_hdr *)p = buf;
++ p = buf;
++ eth = (struct eth_hdr *)p;
+ eth_pack_hdr(eth, ETH_ADDR_BROADCAST, req->ea, ETH_TYPE_IP);
+
+ restlen -= ETH_HDR_LEN;
+@@ -524,7 +525,8 @@
+
+ memset(buf, 0, sizeof(buf));
+
+- eth = (struct eth_hdr *)p = buf;
++ p = buf;
++ eth = (struct eth_hdr *)p;
+ eth_pack_hdr(eth, req->server_ea, req->ea, ETH_TYPE_IP);
+
+ restlen -= ETH_HDR_LEN;
diff --git a/net-analyzer/honeyd/honeyd-1.0.ebuild b/net-analyzer/honeyd/honeyd-1.0.ebuild
index 72d3e012f2bb..70b03966fb9a 100644
--- a/net-analyzer/honeyd/honeyd-1.0.ebuild
+++ b/net-analyzer/honeyd/honeyd-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-1.0.ebuild,v 1.3 2005/02/25 12:58:03 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-1.0.ebuild,v 1.4 2005/05/29 02:34:02 ka0ttic Exp $
+
+inherit eutils
DESCRIPTION="Honeyd is a small daemon that creates virtual hosts on a network"
HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
@@ -20,6 +22,7 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i "s:^CFLAGS = -O2:CFLAGS = ${CFLAGS}:g" Makefile.in || die "sed failed"
+ epatch ${FILESDIR}/${P}-gcc4.diff
}
src_compile() {
@@ -29,7 +32,7 @@ src_compile() {
src_install() {
dodoc README TODO
- dosbin honeyd
+ dosbin honeyd || die "dosbin failed"
einstall || die "make install failed"
@@ -39,8 +42,8 @@ src_install() {
insinto /etc
newins config.sample honeyd.conf || die "failed to install honeyd.conf"
- newinitd ${FILESDIR}/${PN}.initd ${PN}
- newconfd ${FILESDIR}/${PN}.confd ${PN}
+ newinitd ${FILESDIR}/${PN}.initd ${PN} || die
+ newconfd ${FILESDIR}/${PN}.confd ${PN} || die
# This adds all the services and example configurations collected
# by Lance Spitzer
@@ -57,6 +60,6 @@ src_install() {
# Install all the example scripts
cp -R scripts ${D}/usr/share/honeyd/
find ${D}/usr/share/honeyd/scripts \
- -type f -name "*.sh" -o -name "*.pl" | xargs chmod +x
+ -type f -name '*.sh' -o -name '*.pl' -exec chmod +x {} \;
}