summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-09 19:58:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-09 19:58:26 +0000
commit41945c36877e0698e4bca68b0383a750c76ad7df (patch)
tree055dc56863376d7dc9dcfa46f7f04c0effebdf00 /net-analyzer/httping/httping-1.0.10.ebuild
parentNew atlas3.6.0-shared-libs.1.patch fixes insecure RUNPATH issues. This closes... (diff)
downloadgentoo-2-41945c36877e0698e4bca68b0383a750c76ad7df.tar.gz
gentoo-2-41945c36877e0698e4bca68b0383a750c76ad7df.tar.bz2
gentoo-2-41945c36877e0698e4bca68b0383a750c76ad7df.zip
1.0.10 version bump, marking 1.0.8 x86 stable.
(Portage version: 2.0.53)
Diffstat (limited to 'net-analyzer/httping/httping-1.0.10.ebuild')
-rw-r--r--net-analyzer/httping/httping-1.0.10.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/httping/httping-1.0.10.ebuild b/net-analyzer/httping/httping-1.0.10.ebuild
new file mode 100644
index 000000000000..bab1bb288bd1
--- /dev/null
+++ b/net-analyzer/httping/httping-1.0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.0.10.ebuild,v 1.1 2006/01/09 19:58:25 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~hppa ~amd64 ~mips"
+IUSE="ssl"
+
+DEPEND=">=sys-libs/ncurses-5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s|^\(CFLAGS=\)-O2\(.*\)$|\1${CFLAGS} \2|g" Makefile* || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ local makefile
+ use ssl || makefile="-f Makefile.nossl"
+ export CC="$(tc-getCC)"
+ emake ${makefile} || die "make failed"
+}
+
+src_install() {
+ dobin httping || die
+ dodoc readme.txt license.txt
+}