summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-15 15:32:32 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-15 15:32:32 +0000
commit8fb4c39bc14804b3dbb3f7bdd50e7cfce95ee06a (patch)
tree81d2acaa3bc7937fa6334a4a1dab41485db8c868 /net-analyzer/hydra
parentDo not add -g to CFLAGS by Agostino Sarubbo (bug #386089). (diff)
downloadgentoo-2-8fb4c39bc14804b3dbb3f7bdd50e7cfce95ee06a.tar.gz
gentoo-2-8fb4c39bc14804b3dbb3f7bdd50e7cfce95ee06a.tar.bz2
gentoo-2-8fb4c39bc14804b3dbb3f7bdd50e7cfce95ee06a.zip
Version bump.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/ChangeLog9
-rw-r--r--net-analyzer/hydra/hydra-7.2.ebuild99
2 files changed, 106 insertions, 2 deletions
diff --git a/net-analyzer/hydra/ChangeLog b/net-analyzer/hydra/ChangeLog
index 437fbe0252cf..83a21c4dadde 100644
--- a/net-analyzer/hydra/ChangeLog
+++ b/net-analyzer/hydra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/hydra
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.65 2011/12/19 13:04:42 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/ChangeLog,v 1.66 2012/02/15 15:32:31 jer Exp $
+
+*hydra-7.2 (15 Feb 2012)
+
+ 15 Feb 2012; Jeroen Roovers <jer@gentoo.org> +hydra-7.2.ebuild:
+ Version bump.
19 Dec 2011; Jeroen Roovers <jer@gentoo.org> hydra-7.0.ebuild,
hydra-7.1.ebuild:
diff --git a/net-analyzer/hydra/hydra-7.2.ebuild b/net-analyzer/hydra/hydra-7.2.ebuild
new file mode 100644
index 000000000000..3401bf7c8e82
--- /dev/null
+++ b/net-analyzer/hydra/hydra-7.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hydra/hydra-7.2.ebuild,v 1.1 2012/02/15 15:32:32 jer Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="http://www.thc.org/thc-hydra/"
+SRC_URI="http://freeworld.thc.org/releases/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="firebird gtk idn mysql ncp oracle pcre postgres ssl subversion"
+
+RDEPEND="
+ dev-libs/openssl
+ firebird? ( dev-db/firebird )
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ idn? ( net-dns/libidn )
+ mysql? ( virtual/mysql )
+ ncp? ( net-fs/ncpfs )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql-base )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+ subversion? ( dev-vcs/subversion )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:-O2:$(CPPFLAGS) $(CFLAGS):g' \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s:-::' \
+ -e '/^OPTS/{s|=|+=|;s| -O3||}' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die "sed failed"
+}
+
+src_configure() {
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ export OPTS="${CFLAGS}"
+ ./configure \
+ --prefix=/usr \
+ $(use gtk && echo --disable-xhydra) \
+ || die "configure failed"
+
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=-lcrypto:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ Makefile || die "pruning vars"
+
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DLIBOPENSSLNEW -DLIBSSH:' \
+ -e '/^XLIBS=/s:$: -lssl -lssh:' \
+ Makefile || die "adding ssl"
+ fi
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf || die "econf failed"
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake
+ if use gtk ; then
+ cd hydra-gtk && \
+ emake
+ fi
+}
+
+src_install() {
+ dobin hydra pw-inspector
+ if use gtk ; then
+ dobin hydra-gtk/src/xhydra
+ fi
+ dodoc CHANGES README
+}