summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-04 22:20:03 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-04 22:20:03 +0000
commit8e2de6c54d512cb14bde28d5f2874bcffa341ba8 (patch)
tree293330e87d8b0a3462cd252ff2bd6b1533fece4c /net-analyzer/labrea/labrea-2.5.ebuild
parent~ppc, ~sparc on behalf of fmccor (Manifest recommit) (diff)
downloadgentoo-2-8e2de6c54d512cb14bde28d5f2874bcffa341ba8.tar.gz
gentoo-2-8e2de6c54d512cb14bde28d5f2874bcffa341ba8.tar.bz2
gentoo-2-8e2de6c54d512cb14bde28d5f2874bcffa341ba8.zip
initial ebuild, closes #45777
Diffstat (limited to 'net-analyzer/labrea/labrea-2.5.ebuild')
-rw-r--r--net-analyzer/labrea/labrea-2.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/labrea/labrea-2.5.ebuild b/net-analyzer/labrea/labrea-2.5.ebuild
new file mode 100644
index 000000000000..e0c5cd79c147
--- /dev/null
+++ b/net-analyzer/labrea/labrea-2.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/labrea/labrea-2.5.ebuild,v 1.1 2004/07/04 22:20:03 eldad Exp $
+
+DESCRIPTION="'Sticky' Honeypot and IDS"
+HOMEPAGE="http://labrea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-stable-1.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-libs/libpcap
+ >=dev-libs/libdnet-1.7"
+
+MY_P="${P}-stable-1"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog INSTALL README TODO NEWS
+}
+
+pkg_postinst() {
+
+ ewarn CAUTION:
+ ewarn Before using this package READ the INSTALL and README!
+ ewarn as the author states that it can cause serious problems on your network.
+
+}