summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-03 14:33:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-03 14:33:26 +0000
commitadd4a21d0df30a4162d066ddbc0551ff4a05887b (patch)
tree57a9fc0bbfbdbeb65511a17d92b0ef2a7ce67e47 /net-analyzer/libnasl/libnasl-2.2.9.ebuild
parent2.2.9 version bump for bug 169466. Thanks to Jared Breland <nitro322 at gmail... (diff)
downloadgentoo-2-add4a21d0df30a4162d066ddbc0551ff4a05887b.tar.gz
gentoo-2-add4a21d0df30a4162d066ddbc0551ff4a05887b.tar.bz2
gentoo-2-add4a21d0df30a4162d066ddbc0551ff4a05887b.zip
2.2.9 version bump for bug 169466. Thanks to Jared Breland <nitro322 at gmail dot com>.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-analyzer/libnasl/libnasl-2.2.9.ebuild')
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/libnasl-2.2.9.ebuild b/net-analyzer/libnasl/libnasl-2.2.9.ebuild
new file mode 100644
index 000000000000..c6f69efc4140
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-2.2.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9.ebuild,v 1.1 2007/04/03 14:33:26 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=net-analyzer/nessus-libraries-${PV}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf || die "configuration failed"
+ # emake fails for >= -j2. bug #16471.
+ emake -C nasl cflags
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed libnasl"
+}