summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-11 08:50:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-11 08:50:11 +0000
commit5ed0fd7252365f4ecdd4c2f35c9f1180852eef42 (patch)
tree1146d1dd483cf9e3895b14f27de18c46a9b0d570 /net-analyzer/linkchecker/files
parentStable for x86, wrt bug #493894 (diff)
downloadgentoo-2-5ed0fd7252365f4ecdd4c2f35c9f1180852eef42.tar.gz
gentoo-2-5ed0fd7252365f4ecdd4c2f35c9f1180852eef42.tar.bz2
gentoo-2-5ed0fd7252365f4ecdd4c2f35c9f1180852eef42.zip
net-analyzer/linkchecker: Add live ebuild; backport upstream fix and drop bad patch to fix help issue, #488360; drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-analyzer/linkchecker/files')
-rw-r--r--net-analyzer/linkchecker/files/8.0-missing-files.patch13
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-8.4-help.patch36
2 files changed, 36 insertions, 13 deletions
diff --git a/net-analyzer/linkchecker/files/8.0-missing-files.patch b/net-analyzer/linkchecker/files/8.0-missing-files.patch
deleted file mode 100644
index 165783ccb671..000000000000
--- a/net-analyzer/linkchecker/files/8.0-missing-files.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 38b4c15..716203d 100755
---- a/setup.py
-+++ b/setup.py
-@@ -375,7 +375,7 @@ myemail = "calvin@users.sourceforge.net"
- data_files = [
- ('share/linkchecker',
- ['config/linkcheckerrc', 'config/ca-certificates.crt',
-- 'doc/html/lccollection.qhc', 'doc/html/lcdoc.qch']),
-+ 'doc/html/lccollection.qhcp', 'doc/html/lcdoc.qhp']),
- ('share/linkchecker/examples',
- ['cgi-bin/lconline/leer.html.en',
- 'cgi-bin/lconline/leer.html.de',
diff --git a/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch b/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch
new file mode 100644
index 000000000000..32360b6ea89e
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch
@@ -0,0 +1,36 @@
+From a7c1cdd6f69a1b91a95361359e49494b4ed88701 Mon Sep 17 00:00:00 2001
+From: Bastian Kleineidam <bastian.kleineidam@web.de>
+Date: Tue, 10 Dec 2013 20:56:26 +0100
+Subject: [PATCH] Check for help files.
+
+---
+ linkcheck/configuration/__init__.py | 6 ++++--
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/linkcheck/configuration/__init__.py b/linkcheck/configuration/__init__.py
+index 3b72499..f40f285 100644
+--- a/linkcheck/configuration/__init__.py
++++ b/linkcheck/configuration/__init__.py
+@@ -96,7 +96,8 @@ def get_share_file (devel_dir, filename):
+ @param filename: filename to search for
+ @ptype filename: string
+ @return: the found filename or None
+- @rtype: string or None
++ @rtype: string
++ @raises: ValueError if not found
+ """
+ paths = [
+ # when developing
+@@ -112,7 +113,8 @@ def get_share_file (devel_dir, filename):
+ if os.path.isfile(fullpath):
+ return fullpath
+ # not found
+- return None
++ msg = "%s not found in %s; check your installation" % (filename, paths)
++ raise ValueError(msg)
+
+
+ # dynamic options
+--
+1.8.5.1
+