summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2010-06-03 18:41:51 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2010-06-03 18:41:51 +0000
commitfaaf24a5dc431396931bb51e1e2bfdee327d8933 (patch)
tree9d5029a622b29b8cf79c961d505af85e1bf98528 /net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild
parentFixed license (GPL-2 --> GPL-3) (diff)
downloadgentoo-2-faaf24a5dc431396931bb51e1e2bfdee327d8933.tar.gz
gentoo-2-faaf24a5dc431396931bb51e1e2bfdee327d8933.tar.bz2
gentoo-2-faaf24a5dc431396931bb51e1e2bfdee327d8933.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild')
-rw-r--r--net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild b/net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild
new file mode 100644
index 000000000000..b487829f3517
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ndoutils/ndoutils-1.4_beta9.ebuild,v 1.1 2010/06/03 18:41:51 dertobi123 Exp $
+
+inherit eutils
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql
+ virtual/mysql"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nagios-core-3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/nagios \
+ --enable-mysql \
+ --disable-pgsql || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ emake install-config DESTDIR="${D}" || die "emake install-config failed"
+
+ dodoc README REQUIREMENTS TODO UPGRADING Changelog "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+ newinitd "${FILESDIR}"/ndo2db.init-nagios3 ndo2db
+}
+
+pkg_postinst() {
+ elog "To include NDO in your Nagios setup you'll need to activate the NDO broker module"
+ elog "in /etc/nagios/nagios.cfg:"
+ elog "\tbroker_module=/usr/bin/ndomod-3x.o config_file=/etc/nagios/ndomod.cfg"
+}