summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-09-29 06:50:43 +0000
committerPeter Volkov <pva@gentoo.org>2007-09-29 06:50:43 +0000
commit210bc23467aefb5830fdfb39a2162d7bc95ae5c5 (patch)
treea0b62b5e46887992cd44d4fdfb65f8c4b2e395da /net-analyzer/netselect/netselect-0.3-r2.ebuild
parentHandle fpe in ri contrib package. Closes #193683 (diff)
downloadgentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.tar.gz
gentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.tar.bz2
gentoo-2-210bc23467aefb5830fdfb39a2162d7bc95ae5c5.zip
Use tc-getCC compiler, fixes bug #193793, reported by Chris Slycord <cslycord AT gmail.com>
(Portage version: 2.1.3.10)
Diffstat (limited to 'net-analyzer/netselect/netselect-0.3-r2.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-0.3-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-0.3-r2.ebuild b/net-analyzer/netselect/netselect-0.3-r2.ebuild
new file mode 100644
index 000000000000..fded24afdc36
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r2.ebuild,v 1.1 2007/09/29 06:50:43 pva Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://alumnit.ca/~apenwarr/netselect/index.html"
+SRC_URI="http://alumnit.ca/~apenwarr/netselect/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-bsd.patch"
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+
+ sed -i \
+ -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e "s:LDFLAGS =.*:LDFLAGS = -g ${LDFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ Makefile \
+ || die "sed Makefile failed"
+
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install () {
+ dobin netselect || die "dobin failed"
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ dodoc ChangeLog HISTORY README*
+}