summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-09-10 16:36:05 +0000
committerMichael Weber <xmw@gentoo.org>2011-09-10 16:36:05 +0000
commit96314de9f7f9446e6f5c14247b6ae20cf7062912 (patch)
tree1d5100db9a840898aa232417cd49e15b341d8ce1 /net-analyzer/netsniff-ng
parentAdd dconf to fix problems like bug #375101, use app-admin/system-config-print... (diff)
downloadgentoo-2-96314de9f7f9446e6f5c14247b6ae20cf7062912.tar.gz
gentoo-2-96314de9f7f9446e6f5c14247b6ae20cf7062912.tar.bz2
gentoo-2-96314de9f7f9446e6f5c14247b6ae20cf7062912.zip
Initial import, thanks to epinephrine for the report (bug 299549)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/netsniff-ng')
-rw-r--r--net-analyzer/netsniff-ng/ChangeLog10
-rw-r--r--net-analyzer/netsniff-ng/metadata.xml10
-rw-r--r--net-analyzer/netsniff-ng/netsniff-ng-0.5.5.0.ebuild35
3 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/netsniff-ng/ChangeLog b/net-analyzer/netsniff-ng/ChangeLog
new file mode 100644
index 000000000000..80ef934f06bd
--- /dev/null
+++ b/net-analyzer/netsniff-ng/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/netsniff-ng
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netsniff-ng/ChangeLog,v 1.1 2011/09/10 16:36:05 xmw Exp $
+
+*netsniff-ng-0.5.5.0 (10 Sep 2011)
+
+ 10 Sep 2011; Michael Weber <xmw@gentoo.org> +netsniff-ng-0.5.5.0.ebuild,
+ +metadata.xml:
+ Initial import, thanks to epinephrine for the report (bug 299549)
+
diff --git a/net-analyzer/netsniff-ng/metadata.xml b/net-analyzer/netsniff-ng/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/net-analyzer/netsniff-ng/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/net-analyzer/netsniff-ng/netsniff-ng-0.5.5.0.ebuild b/net-analyzer/netsniff-ng/netsniff-ng-0.5.5.0.ebuild
new file mode 100644
index 000000000000..aed92ce10333
--- /dev/null
+++ b/net-analyzer/netsniff-ng/netsniff-ng-0.5.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netsniff-ng/netsniff-ng-0.5.5.0.ebuild,v 1.1 2011/09/10 16:36:05 xmw Exp $
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="high performance network sniffer for packet inspection"
+HOMEPAGE="http://netsniff-ng.org/"
+SRC_URI="http://www.${PN}.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${PN}/src
+
+src_prepare() {
+ sed \
+ -e "/CC_NORM/,+1s/gcc/$(tc-getCC)/" \
+ -e "/LD_NORM/,+1s/gcc/$(tc-getCC)/" \
+ -i definitions.mk || die
+ echo "CFLAGS = ${CFLAGS} -std=gnu99" >> definitions.mk || die
+ echo "LIBS += ${LDFLAGS}" >> definitions.mk || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ../{AUTHORS,CHANGELOG,CODING,CREDITS,HACKING,README,TODO} || die
+}