summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-10-01 10:45:46 +0000
committerAnant Narayanan <anant@gentoo.org>2007-10-01 10:45:46 +0000
commite75570e65d79b8f96e2a76a8c5580d8322fd4b3c (patch)
tree2a86aaeaa095782f75ee50b4f7984bc5afd4e321 /net-analyzer/ns
parent* bump, sub flag, cosmetics (diff)
downloadgentoo-2-e75570e65d79b8f96e2a76a8c5580d8322fd4b3c.tar.gz
gentoo-2-e75570e65d79b8f96e2a76a8c5580d8322fd4b3c.tar.bz2
gentoo-2-e75570e65d79b8f96e2a76a8c5580d8322fd4b3c.zip
Bump to 2.31
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-analyzer/ns')
-rw-r--r--net-analyzer/ns/ChangeLog7
-rw-r--r--net-analyzer/ns/files/digest-ns-2.313
-rw-r--r--net-analyzer/ns/ns-2.31.ebuild129
3 files changed, 138 insertions, 1 deletions
diff --git a/net-analyzer/ns/ChangeLog b/net-analyzer/ns/ChangeLog
index fcf102c165f8..14ac420142ec 100644
--- a/net-analyzer/ns/ChangeLog
+++ b/net-analyzer/ns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ns
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.25 2007/07/26 13:34:36 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.26 2007/10/01 10:45:45 anant Exp $
+
+*ns-2.31 (01 Oct 2007)
+
+ 01 Oct 2007; Anant Narayanan <anant@gentoo.org> +ns-2.31.ebuild:
+ Bump to 2.31
26 Jul 2007; Anant Narayanan <anant@gentoo.org> metadata.xml:
Add myself to metadata.
diff --git a/net-analyzer/ns/files/digest-ns-2.31 b/net-analyzer/ns/files/digest-ns-2.31
new file mode 100644
index 000000000000..76b157560c00
--- /dev/null
+++ b/net-analyzer/ns/files/digest-ns-2.31
@@ -0,0 +1,3 @@
+MD5 32c7bc31d115d31f491d9179d21a8df5 ns-src-2.31.tar.gz 56719360
+RMD160 ca8b17b241b25127859c89c79110f839982ca4b0 ns-src-2.31.tar.gz 56719360
+SHA256 7cea6e80591be6331e8a158ab8a0d689d9e6f3ff4d9c11739af9bb5be5eaa166 ns-src-2.31.tar.gz 56719360
diff --git a/net-analyzer/ns/ns-2.31.ebuild b/net-analyzer/ns/ns-2.31.ebuild
new file mode 100644
index 000000000000..08e0d99b68ca
--- /dev/null
+++ b/net-analyzer/ns/ns-2.31.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.31.ebuild,v 1.1 2007/10/01 10:45:45 anant Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Network Simulator"
+HOMEPAGE="http://www.isi.edu/nsnam/ns/"
+SRC_URI="http://downloads.sourceforge.net/nsnam/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE="doc debug"
+
+RDEPEND=">=dev-lang/tcl-8.4.5
+ >=dev-lang/tk-8.4.5
+ >=dev-tcltk/otcl-1.11
+ >=dev-tcltk/tclcl-1.17
+ virtual/libpcap
+ debug? ( =dev-lang/perl-5*
+ >=sci-visualization/xgraph-12.1
+ >=dev-libs/dmalloc-4.8.2
+ >=dev-tcltk/tcl-debug-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/tetex
+ virtual/ghostscript
+ dev-tex/latex2html )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed '/$(CC)/s!-g!$(CFLAGS)!g' ${S}/indep-utils/model-gen/Makefile
+}
+
+src_compile() {
+ local myconf
+ local mytclver=""
+ local i
+
+ tc-export CC CXX
+
+ # correctness is more important than speed
+ replace-flags -Os -O2
+ replace-flags -O3 -O2
+
+ use debug \
+ && myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" \
+ || myconf="${myconf} --with-tcldebug=no"
+ myconf="${myconf} $(use_with debug dmalloc)"
+
+ for i in 8.4 ; do
+ einfo "Testing TCL ${i}"
+ has_version "=dev-lang/tcl-${i}*" && mytclver=${i}
+ [ "${#mytclver}" -gt 2 ] && break
+ done
+ einfo "Using TCL ${mytclver}"
+ myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
+
+ econf \
+ ${myconf} \
+ --mandir=/usr/share/man \
+ --enable-stl \
+ --enable-release || die "./configure failed"
+ emake CCOPT="${CFLAGS}" || die
+
+ cd ${S}/indep-utils/dosdbell
+ emake DFLAGS="${CFLAGS}" || die
+ cd ${S}/indep-utils/dosreduce
+ ${CC} ${CFLAGS} dosreduce.c -o dosreduce
+ cd ${S}/indep-utils/propagation
+ ${CXX} ${CXXFLAGS} threshold.cc -o threshold
+ cd ${S}/indep-utils/model-gen
+ emake CFLAGS="${CFLAGS}" || die
+
+ if useq doc; then
+ einfo "Generating extra docs"
+ cd ${S}/doc
+ yes '' | emake all
+ fi
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1 /usr/share/doc/${PF} /usr/share/ns
+ make DESTDIR="${D}" MANDEST=/usr/share/man install \
+ || die "make install failed"
+ dobin nse
+
+ dodoc BASE-VERSION COPYRIGHTS FILES HOWTO-CONTRIBUTE README VERSION
+ dohtml CHANGES.html TODO.html
+
+ cd "${S}"
+ insinto /usr/share/ns
+ doins -r tcl
+
+ cd "${S}/indep-utils/dosdbell"
+ dobin dosdbell dosdbellasim
+ newdoc README README.dosdbell
+ cd "${S}/indep-utils/dosreduce"
+ dobin dosreduce
+ newdoc README README.dosreduce
+ cd "${S}/indep-utils/cmu-scen-gen"
+ dobin cbrgen.tcl
+ newdoc README README.cbrgen
+ cd "${S}/indep-utils/propagation"
+ dobin threshold
+ cd "${S}/indep-utils/model-gen"
+ dobin http_connect http_active
+
+ if use doc; then
+ cd ${S}/doc
+ docinto doc
+ dodoc everything.dvi everything.ps.gz everything.html everything.pdf
+ docinto model-gen
+ cd ${S}/indep-utils/model-gen
+ dodoc *
+ fi
+}
+
+src_test() {
+ einfo "Warning, these tests will take upwards of 45 minutes."
+ einfo "Additionally, as shipped, a number of tests may fail."
+ einfo "We log to 'validate.run', which you should compare against"
+ einfo "the shipped 'validate.out' to evaluate success."
+ einfo "At the time of assembling this ebuild, these test suites failed:"
+ einfo "srm smac-multihop hier-routing algo-routing mcast vc"
+ einfo "session mixmode webcache mcache plm wireless-tdma"
+ ./validate 2>&1 | tee ${S}/validate.run
+}