summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-02-16 22:17:29 +0000
committerAlin Năstac <mrness@gentoo.org>2009-02-16 22:17:29 +0000
commit67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd (patch)
tree6a8dacd7c5bd33bdac96f07a74570eddd7c8fdfa /net-analyzer/ntop
parentwhitespace (diff)
downloadgentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.tar.gz
gentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.tar.bz2
gentoo-2-67a6a23ee2a4b5b0c710523529615ed1dbf2a2fd.zip
Version bump. Install /var/lib/ntop with the right owner (#254868).
(Portage version: 2.1.6.4/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog11
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch97
-rw-r--r--net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch47
-rw-r--r--net-analyzer/ntop/ntop-3.3.9.ebuild119
4 files changed, 272 insertions, 2 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index a9e8738b49c4..6b63894b5a33 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ntop
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.66 2008/10/05 13:08:44 mrness Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.67 2009/02/16 22:17:28 mrness Exp $
+
+*ntop-3.3.9 (16 Feb 2009)
+
+ 16 Feb 2009; Alin Năstac <mrness@gentoo.org>
+ +files/ntop-3.3.9-external-geoip.patch, +files/ntop-3.3.9-gentoo.patch,
+ +ntop-3.3.9.ebuild:
+ Version bump. Install /var/lib/ntop with the right owner (#254868).
*ntop-3.3.8 (05 Oct 2008)
diff --git a/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch b/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch
new file mode 100644
index 000000000000..99efd615c171
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.9-external-geoip.patch
@@ -0,0 +1,97 @@
+diff -Nru ntop-3.3.9.orig/configure.in ntop-3.3.9/configure.in
+--- ntop-3.3.9.orig/configure.in 2009-02-16 19:43:57.000000000 +0000
++++ ntop-3.3.9/configure.in 2009-02-16 19:47:10.000000000 +0000
+@@ -1882,20 +1882,6 @@
+ fi
+
+ dnl> GeoIP (http://www.maxmind.com/)
+-if test -f "GeoIP.tar.gz"; then
+- echo "GeoIP already present on this machine"
+-else
+- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
+- tar xvfz GeoIP.tar.gz
+- GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+- cd $GEO_DIR; ./configure; make; cd ..
+- # OSX Fix
+- GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+- if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
+- fi
+-fi
+-
+ if test -f "GeoLiteCity.dat"; then
+ echo "GeoLiteCity.dat already present"
+ else
+@@ -1911,10 +1897,7 @@
+ fi
+
+
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-GEO_IP="$GEO_DIR/libGeoIP/"
+-CFLAGS="$CFLAGS -I$GEO_IP"
+-LDFLAGS="$LDFLAGS -L$GEO_IP.libs/ -lGeoIP"
++LDFLAGS="$LDFLAGS -lGeoIP"
+
+ dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
+
+@@ -2079,7 +2062,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+
+ AC_CONFIG_FILES([Makefile])
+
+diff -Nru ntop-3.3.9.orig/initialize.c ntop-3.3.9/initialize.c
+--- ntop-3.3.9.orig/initialize.c 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/initialize.c 2009-02-16 22:04:34.000000000 +0000
+@@ -467,16 +467,15 @@
+ #endif
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i], CONST_PATH_SEP, GEO_IP_FILE);
++ myGlobals.dbPath, CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+
+@@ -485,16 +484,15 @@
+
+ /* *************************** */
+
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i], CONST_PATH_SEP, GEO_IP_ASN_FILE);
++ myGlobals.dbPath, CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+
+diff -Nru ntop-3.3.9.orig/Makefile.am ntop-3.3.9/Makefile.am
+--- ntop-3.3.9.orig/Makefile.am 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/Makefile.am 2009-02-16 19:47:25.000000000 +0000
+@@ -270,8 +270,6 @@
+
+ install: install-recursive
+
+- cd @GEO_DIR@; make install
+-
+ @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
+
+ @echo ""
diff --git a/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch b/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch
new file mode 100644
index 000000000000..fb0268fed30a
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-3.3.9-gentoo.patch
@@ -0,0 +1,47 @@
+diff -Nru ntop-3.3.9.orig/configure.in ntop-3.3.9/configure.in
+--- ntop-3.3.9.orig/configure.in 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/configure.in 2009-02-15 18:19:26.000000000 +0000
+@@ -57,6 +57,7 @@
+ dnl>
+ umask 002
+ AM_CONFIG_HEADER(config.h)
++AM_MAINTAINER_MODE
+
+ HAS_ERROR=
+ HAS_WARNING=
+@@ -504,11 +504,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+diff -Nru ntop-3.3.9.orig/globals-core.c ntop-3.3.9/globals-core.c
+--- ntop-3.3.9.orig/globals-core.c 2008-12-03 22:00:22.000000000 +0000
++++ ntop-3.3.9/globals-core.c 2009-02-15 18:18:55.000000000 +0000
+@@ -424,7 +424,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500 /* raw IP */;
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+diff -Nru ntop-3.3.9.orig/report.c ntop-3.3.9/report.c
+--- ntop-3.3.9.orig/report.c 2008-12-09 11:41:47.000000000 +0000
++++ ntop-3.3.9/report.c 2009-02-15 18:18:55.000000000 +0000
+@@ -2301,7 +2301,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+
diff --git a/net-analyzer/ntop/ntop-3.3.9.ebuild b/net-analyzer/ntop/ntop-3.3.9.ebuild
new file mode 100644
index 000000000000..e82a9412890d
--- /dev/null
+++ b/net-analyzer/ntop/ntop-3.3.9.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.3.9.ebuild,v 1.1 2009/02/16 22:17:28 mrness Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="tool that shows network usage like top"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+SRC_URI="mirror://sourceforge/ntop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 nls ssl tcpd"
+#snmp support is disabled
+
+#snmp? ( net-analyzer/net-snmp )
+COMMON_DEPEND="sys-apps/gawk
+ dev-lang/perl
+ sys-libs/gdbm
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ sys-libs/zlib
+ dev-libs/geoip"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.4
+ net-misc/wget" # needed for downloading GeoIP data
+
+# Needed by xmldumpPlugin - couldn't get it to work
+# dev-libs/gdome2
+# >=dev-libs/glib-2"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz"
+
+pkg_setup() {
+ # snmp doesn't compile in this release, disabled for now
+ #if use snmp ; then
+ # ewarn "snmp plugin is under development and upstream does not recommend"
+ # ewarn "it for usage in production environment."
+ # if ! use ipv6 ; then
+ # echo
+ # eerror "snmp plugin has compilation problems without ipv6 support."
+ # eerror "For additional information see bug #121497."
+ # die "snmp without ipv6 is broken"
+ # else
+ # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ # echo
+ # eerror "You have both ipv6 and snmp enabled."
+ # eerror "This require ipv6 support in net-analyzer/net-snmp."
+ # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
+ # die "net-analyzer/net-snmp was build without ipv6."
+ # fi
+ # fi
+ #fi
+
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-external-geoip.patch
+ cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_compile() {
+ # force disable xmldumpPlugin
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls i18n) \
+ $(use_with ssl) $(use_enable ssl sslwatchdog) \
+ $(use_with tcpd tcpwrapper) \
+ --with-rrd-home=/usr/lib \
+ --disable-snmp \
+ || die "configure problem"
+ # $(use_enable snmp)
+ emake || die "compile problem"
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop &&
+ mv "${D}"/etc/ntop/Geo*.dat "${D}"/var/lib/ntop ||
+ die "failed to prepare /var/lib/ntop dir"
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+}
+
+pkg_postinst() {
+ elog "You need to set a password first by running"
+ elog "ntop --set-admin-password"
+}