summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-14 18:21:49 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-14 18:21:49 +0000
commitfcfc9bb8ea0931e6380124e7464802dba7f2fca0 (patch)
tree4586158d3653383c93b5776e3f938ea681065aeb /net-analyzer/pmacct/pmacct-0.14.1.ebuild
parentSpelling. (diff)
downloadgentoo-2-fcfc9bb8ea0931e6380124e7464802dba7f2fca0.tar.gz
gentoo-2-fcfc9bb8ea0931e6380124e7464802dba7f2fca0.tar.bz2
gentoo-2-fcfc9bb8ea0931e6380124e7464802dba7f2fca0.zip
Export AR and RANLIB for cross-compiling (bug #443122 by Denis M.).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/pmacct/pmacct-0.14.1.ebuild')
-rw-r--r--net-analyzer/pmacct/pmacct-0.14.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/pmacct/pmacct-0.14.1.ebuild b/net-analyzer/pmacct/pmacct-0.14.1.ebuild
index ad5675400d35..f874aa1b2fb6 100644
--- a/net-analyzer/pmacct/pmacct-0.14.1.ebuild
+++ b/net-analyzer/pmacct/pmacct-0.14.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.14.1.ebuild,v 1.2 2012/11/03 20:19:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.14.1.ebuild,v 1.3 2012/11/14 18:21:49 jer Exp $
EAPI=4
inherit eutils toolchain-funcs
@@ -26,10 +26,13 @@ DOCS=(
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.12.0-gentoo.patch
+ sed -i \
+ -e '/[[:space:]]ar /s|ar |$(AR) |g' \
+ $(find . -name Makefile.in) || die
}
src_configure() {
- tc-export CC
+ tc-export CC AR RANLIB
econf \
$(use_enable 64bit) \
$(use_enable debug) \