summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-01 11:50:27 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-01 11:50:27 +0000
commit3ce588b0844e9eee37e06150195cbdb26344f009 (patch)
tree3e043583cc1a7fbfd519c93bbfb3159a0db2cfec /net-analyzer/pmacct
parentStable for HPPA (bug #499802). (diff)
downloadgentoo-2-3ce588b0844e9eee37e06150195cbdb26344f009.tar.gz
gentoo-2-3ce588b0844e9eee37e06150195cbdb26344f009.tar.bz2
gentoo-2-3ce588b0844e9eee37e06150195cbdb26344f009.zip
Add dev-libs/geoip dependency (bug #499924 by Michael Rowell).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog8
-rw-r--r--net-analyzer/pmacct/pmacct-0.14.2.ebuild67
-rw-r--r--net-analyzer/pmacct/pmacct-0.14.3.ebuild5
3 files changed, 9 insertions, 71 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 56762ad70e97..ae8d0629f7b1 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/pmacct
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.90 2013/05/09 03:03:11 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.91 2014/02/01 11:50:27 jer Exp $
+
+ 01 Feb 2014; Jeroen Roovers <jer@gentoo.org> -pmacct-0.14.2.ebuild,
+ pmacct-0.14.3.ebuild:
+ Add dev-libs/geoip dependency (bug #499924 by Michael Rowell).
*pmacct-0.14.3 (09 May 2013)
diff --git a/net-analyzer/pmacct/pmacct-0.14.2.ebuild b/net-analyzer/pmacct/pmacct-0.14.2.ebuild
deleted file mode 100644
index dd6be981f4ff..000000000000
--- a/net-analyzer/pmacct/pmacct-0.14.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.14.2.ebuild,v 1.3 2013/02/03 19:32:38 ago Exp $
-
-EAPI=4
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A network tool to gather IP traffic information"
-HOMEPAGE="http://www.pmacct.net/"
-SRC_URI="http://www.pmacct.net/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="64bit debug geoip ipv6 mongodb mysql postgres sqlite threads ulog"
-
-DEPEND="
- net-libs/libpcap
- mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- sqlite? ( =dev-db/sqlite-3* )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=(
- CONFIG-KEYS ChangeLog FAQS KNOWN-BUGS QUICKSTART README TODO TOOLS UPGRADE
- docs/INTERNALS docs/PLUGINS docs/SIGNALS
-)
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.12.0-gentoo.patch
- sed -i \
- -e '/[[:space:]]ar /s|ar |$(AR) |g' \
- $(find . -name Makefile.in) || die
-}
-
-src_configure() {
- tc-export CC AR RANLIB
-
- econf \
- $(use_enable 64bit) \
- $(use_enable debug) \
- $(use_enable geoip) \
- $(use_enable ipv6) \
- $(use_enable mongodb) \
- $(use_enable mysql) \
- $(use_enable postgres pgsql) \
- $(use_enable sqlite sqlite3) \
- $(use_enable threads) \
- $(use_enable ulog)
-}
-
-src_install() {
- default
-
- for dirname in examples sql; do
- docinto ${dirname}
- dodoc ${dirname}/*
- done
-
- newinitd "${FILESDIR}"/pmacctd-init.d pmacctd
- newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd
-
- insinto /etc/pmacctd
- newins examples/pmacctd-imt.conf.example pmacctd.conf
-}
diff --git a/net-analyzer/pmacct/pmacct-0.14.3.ebuild b/net-analyzer/pmacct/pmacct-0.14.3.ebuild
index e463d3f664c6..e6e1dfeb3382 100644
--- a/net-analyzer/pmacct/pmacct-0.14.3.ebuild
+++ b/net-analyzer/pmacct/pmacct-0.14.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.14.3.ebuild,v 1.1 2013/05/09 03:03:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.14.3.ebuild,v 1.2 2014/02/01 11:50:27 jer Exp $
EAPI=5
inherit eutils toolchain-funcs
@@ -16,6 +16,7 @@ IUSE="64bit debug geoip ipv6 mongodb mysql postgres sqlite threads ulog"
DEPEND="
net-libs/libpcap
+ geoip? ( dev-libs/geoip )
mongodb? ( dev-libs/mongo-c-driver )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql-base )