summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-02-25 00:27:37 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-02-25 00:27:37 +0000
commit45cfc281d358a7b8d3a32e8c8b16371f470492ef (patch)
treef4ccc20696584126b623a65023f0e1bd8c5ba29e /net-analyzer/sarg/sarg-1.4.1-r2.ebuild
parentMaking 3.2.5 stable on x86. Adding info to metada.xml. Making all versions no... (diff)
downloadgentoo-2-45cfc281d358a7b8d3a32e8c8b16371f470492ef.tar.gz
gentoo-2-45cfc281d358a7b8d3a32e8c8b16371f470492ef.tar.bz2
gentoo-2-45cfc281d358a7b8d3a32e8c8b16371f470492ef.zip
Added patch to fix segfault under 2.6 kernels
Diffstat (limited to 'net-analyzer/sarg/sarg-1.4.1-r2.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-1.4.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-1.4.1-r2.ebuild b/net-analyzer/sarg/sarg-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..f0d0876c7cb3
--- /dev/null
+++ b/net-analyzer/sarg/sarg-1.4.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Sarg (Squid Analysis Report Generator) is a tool that allows you to view where your users are going to on the Internet."
+HOMEPAGE="http://web.onda.com.br/orso/sarg.html"
+SRC_URI="http://web.onda.com.br/orso/${P}.tar.gz http://web.onda.com.br/orso/patches/sarg-1.4.1-index.sort.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=""
+RDEPEND=">=net-www/squid-2.5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/sarg-1.4.1-index.sort.patch
+ epatch ${FILESDIR}/sarg-1.4.1-2.6.fix.patch
+}
+
+src_compile() {
+ rm -rf config.cache
+ ./configure \
+ --enable-bindir=/usr/bin \
+ --enable-mandir=/usr/man/man1 \
+ --enable-sysconfdir=/etc/sarg || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/sarg /usr/bin /usr/man/man1
+ make \
+ BINDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/man/man1 \
+ SYSCONFDIR=${D}/etc/sarg \
+ install || die
+}