summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-04-01 11:48:37 +0000
committerJeroen Roovers <jer@gentoo.org>2014-04-01 11:48:37 +0000
commiteac6368d993cddd520db46dcd642f92b348dc896 (patch)
tree37d9a487010e0213ff2f5d2835634ef8e97abb61 /net-analyzer/sarg
parentx86 stable, bug #504250 (diff)
downloadgentoo-2-eac6368d993cddd520db46dcd642f92b348dc896.tar.gz
gentoo-2-eac6368d993cddd520db46dcd642f92b348dc896.tar.bz2
gentoo-2-eac6368d993cddd520db46dcd642f92b348dc896.zip
Version bump (bug #506334 by Nikoli).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/ChangeLog10
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.8-long-long-int.patch31
-rw-r--r--net-analyzer/sarg/sarg-2.3.8.ebuild65
3 files changed, 104 insertions, 2 deletions
diff --git a/net-analyzer/sarg/ChangeLog b/net-analyzer/sarg/ChangeLog
index 3ea2e47eb344..6b7cf4dd7d39 100644
--- a/net-analyzer/sarg/ChangeLog
+++ b/net-analyzer/sarg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/sarg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.79 2013/02/16 12:47:02 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.80 2014/04/01 11:48:36 jer Exp $
+
+*sarg-2.3.8 (01 Apr 2014)
+
+ 01 Apr 2014; Jeroen Roovers <jer@gentoo.org> +sarg-2.3.8.ebuild,
+ +files/sarg-2.3.8-long-long-int.patch:
+ Version bump (bug #506334 by Nikoli).
16 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #96436
diff --git a/net-analyzer/sarg/files/sarg-2.3.8-long-long-int.patch b/net-analyzer/sarg/files/sarg-2.3.8-long-long-int.patch
new file mode 100644
index 000000000000..85b3ec907b55
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.8-long-long-int.patch
@@ -0,0 +1,31 @@
+log.c:128: nbytes is defined as a long long int
+
+
+--- a/log.c
++++ b/log.c
+@@ -1503,14 +1503,14 @@
+ }
+ }
+
+- if (fprintf(ufile->file, "%s\t%s\t%s\t%s\t%"PRIi64"\t%s\t%ld\t%s\n",dia,hora,ip,url,nbytes,code,elap_time,smartfilter)<=0) {
++ if (fprintf(ufile->file, "%s\t%s\t%s\t%s\t%lld\t%s\t%ld\t%s\n",dia,hora,ip,url,nbytes,code,elap_time,smartfilter)<=0) {
+ debuga(_("Write error in the log file of user %s\n"),user);
+ exit(EXIT_FAILURE);
+ }
+ records_kept++;
+
+ if(fp_log && ilf!=ILF_Sarg)
+- fprintf(fp_log, "%s\t%s\t%s\t%s\t%s\t%"PRIi64"\t%s\t%ld\t%s\n",dia,hora,user,ip,url,nbytes,code,elap_time,smartfilter);
++ fprintf(fp_log, "%s\t%s\t%s\t%s\t%s\t%lld\t%s\t%ld\t%s\n",dia,hora,user,ip,url,nbytes,code,elap_time,smartfilter);
+
+ totregsg++;
+
+@@ -1561,7 +1561,7 @@
+ printf("FUNC=\t%s\n",fun);
+ printf("URL=\t%s\n",url);
+ printf("CODE=\t%s\n",code);
+- printf("LEN=\t%"PRIi64"\n",nbytes);
++ printf("LEN=\t%lld\n",nbytes);
+ }
+ }
+ if (!from_stdin) {
diff --git a/net-analyzer/sarg/sarg-2.3.8.ebuild b/net-analyzer/sarg/sarg-2.3.8.ebuild
new file mode 100644
index 000000000000..790349ba12c1
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.3.8.ebuild,v 1.1 2014/04/01 11:48:36 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/sarg.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gd ldap pcre"
+
+DEPEND="
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-long-long-int.patch
+
+ sed -i configure.in -e '/LDFLAGS=/s:LDFLAGS:LIBS:g' || die
+
+ sed \
+ -e 's:/usr/local/squid/var/logs/access.log:/var/log/squid/access.log:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -e 's:/var/www/html/squid-reports:/var/www/localhost/htdocs/squid-reports:' \
+ -e 's:/usr/local/sarg/exclude_codes:/etc/sarg/exclude_codes:' \
+ -i sarg.conf || die
+
+ sed -e 's:"/var/www/html/squid-reports":"/var/www/localhost/htdocs/squid-reports":' \
+ -i log.c || die #43132
+
+ sed -e 's:/usr/local/sarg/passwd:/etc/sarg/passwd:' \
+ -i htaccess || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/squid/etc/passwd:/etc/squid/passwd:' \
+ -i user_limit_block || die
+
+ sed -e 's:/usr/local/squid/etc/block.txt:/etc/squid/etc/block.txt:' \
+ -i sarg-php/sarg-block-it.php || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -i sarg.1 sarg-php/sarg-squidguard-block.php || die
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gd) \
+ $(use_with ldap) \
+ $(use_with pcre) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}