summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-16 10:42:34 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-16 10:42:34 +0000
commit9f3bdbcea9ce48ba2fa5602c77797fb32e2ce695 (patch)
tree61a67e7ae2857689473d1dd15d36d82f0f62a0b5 /net-analyzer/snortsam/snortsam-2.50-r1.ebuild
parentCleanup (diff)
downloadgentoo-2-9f3bdbcea9ce48ba2fa5602c77797fb32e2ce695.tar.gz
gentoo-2-9f3bdbcea9ce48ba2fa5602c77797fb32e2ce695.tar.bz2
gentoo-2-9f3bdbcea9ce48ba2fa5602c77797fb32e2ce695.zip
Fixed position of functions.sh, bug 234521, thank Olivier Huber for report. Respect LDFLAGS. Clean old.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.50-r1.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.50-r1.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.50-r1.ebuild b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
index 88d92c4dfda2..c0e113f33d24 100644
--- a/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
+++ b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.50-r1.ebuild,v 1.10 2007/11/06 17:21:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.50-r1.ebuild,v 1.11 2008/09/16 10:42:34 pva Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P="${PN}-src-${PV}"
DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
IUSE=""
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
@@ -23,17 +23,20 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-2.29-no-ugly----lines.diff
# bug 155955, ciscoacl segfaults with gcc-4.1.1
epatch "${DISTDIR}"/${PN}-2.50-ciscoacl.diff.bz2
+ sed -i -e "s:sbin/functions.sh:etc/init.d/functions.sh:" \
+ -e "s: -O2 : ${CFLAGS} :" \
+ -e "s:gcc :$(tc-getCC) :" \
+ -e "s:\( -o ../snortsam\): ${LDFLAGS}\1:" makesnortsam.sh || die "sed failed"
+ find "${S}" -depth -type d -name CVS -exec rm -rf \{\} \;
}
src_compile() {
- sed -i "s: -O2 : ${CFLAGS} :" makesnortsam.sh || die "sed failed"
sh makesnortsam.sh || die "makesnortsam.sh failed"
}
src_install() {
- find "${S}" -type d -name CVS -exec rm -rf {} \;
- find "${S}" -type f -name "*.asc" -exec rm -f {} \;
dobin snortsam || die "dobin failed"
+ find "${S}" -depth -type f -name "*.asc" -exec rm -f {} \;
dodoc docs/* conf/*
}
@@ -43,5 +46,4 @@ pkg_postinst() {
elog "Read the INSTALL file to configure snort for snortsam, and configure"
elog "snortsam for your particular firewall."
elog
-
}