summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-12-09 16:03:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-12-09 16:03:26 +0000
commita5796bc49e0a6d44daf0b294e66458692e92ba77 (patch)
tree06381acf2c278db1e172dcf8facacb288893a93d /net-analyzer/snortsam/snortsam-2.50-r1.ebuild
parentFix bug 23852 (diff)
downloadgentoo-2-a5796bc49e0a6d44daf0b294e66458692e92ba77.tar.gz
gentoo-2-a5796bc49e0a6d44daf0b294e66458692e92ba77.tar.bz2
gentoo-2-a5796bc49e0a6d44daf0b294e66458692e92ba77.zip
Remove old ebuilds, add patch from bug 155955 to allow ciscoacl plugin to work with gcc-4.1.1. Thanks to Paul Kehrer <paul at victoly dot com>.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/snortsam/snortsam-2.50-r1.ebuild')
-rw-r--r--net-analyzer/snortsam/snortsam-2.50-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/snortsam/snortsam-2.50-r1.ebuild b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
new file mode 100644
index 000000000000..95f485207898
--- /dev/null
+++ b/net-analyzer/snortsam/snortsam-2.50-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snortsam/snortsam-2.50-r1.ebuild,v 1.1 2006/12/09 16:03:26 vanquirius Exp $
+
+inherit eutils
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Snort plugin that allows automated blocking of IP addresses on several firewalls"
+HOMEPAGE="http://www.snortsam.net/"
+SRC_URI="http://www.snortsam.net/files/snortsam/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-2.50-ciscoacl.diff.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.29-no-ugly----lines.diff
+ # bug 155955, ciscoacl segfaults with gcc-4.1.1
+ epatch "${DISTDIR}"/${PN}-2.50-ciscoacl.diff.bz2
+}
+
+src_compile() {
+ sed -i "s: -O2 : ${CFLAGS} :" makesnortsam.sh || die "sed failed"
+ sh makesnortsam.sh || die "makesnortsam.sh failed"
+}
+
+src_install() {
+ find "${S}" -type d -name CVS -exec rm -rf {} \;
+ find "${S}" -type f -name "*.asc" -exec rm -f {} \;
+ dobin snortsam || die "dobin failed"
+ dodoc docs/* conf/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use snortsam with snort, you'll have to compile snort with USE=snortsam."
+ einfo "Read the INSTALL file to configure snort for snortsam, and configure"
+ einfo "snortsam for your particular firewall."
+ einfo
+
+}