summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-12-14 14:52:14 +0000
committerPeter Volkov <pva@gentoo.org>2006-12-14 14:52:14 +0000
commit2482e2fb21eb842c85532b0397b4d60a571cdbd5 (patch)
treed0ea0c41ed885f97dfe9c1cf9328fbd5079040f1 /net-analyzer/sussen
parentVersion bump. This version includes the NEO code. (diff)
downloadgentoo-2-2482e2fb21eb842c85532b0397b4d60a571cdbd5.tar.gz
gentoo-2-2482e2fb21eb842c85532b0397b4d60a571cdbd5.tar.bz2
gentoo-2-2482e2fb21eb842c85532b0397b4d60a571cdbd5.zip
Version bump. Thank upstream dev Loren Bandiera for report.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/sussen')
-rw-r--r--net-analyzer/sussen/ChangeLog9
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.333
-rw-r--r--net-analyzer/sussen/files/sussen-0.33-configopts-mono-1.1.13-fix.patch23
-rw-r--r--net-analyzer/sussen/files/sussen-0.33-ignore-unsupported-test.patch12
-rw-r--r--net-analyzer/sussen/sussen-0.33.ebuild102
5 files changed, 148 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index d1e81c356565..2492b079fc03 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.39 2006/12/03 15:20:38 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.40 2006/12/14 14:52:13 pva Exp $
+
+*sussen-0.33 (14 Dec 2006)
+
+ 14 Dec 2006; Peter Volkov <pva@gentoo.org>
+ +files/sussen-0.33-configopts-mono-1.1.13-fix.patch,
+ +files/sussen-0.33-ignore-unsupported-test.patch, +sussen-0.33.ebuild:
+ Version bump. Thank upstream dev Loren Bandiera for report.
03 Dec 2006; Peter Volkov <pva@gentoo.org> sussen-0.29.ebuild,
sussen-0.30.ebuild:
diff --git a/net-analyzer/sussen/files/digest-sussen-0.33 b/net-analyzer/sussen/files/digest-sussen-0.33
new file mode 100644
index 000000000000..310719fc688e
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.33
@@ -0,0 +1,3 @@
+MD5 d13bc12c2e78f5507ca8c670a9443afb sussen-0.33.tar.gz 928318
+RMD160 0a56d8cb79322f001186949117f2d585b56dbad7 sussen-0.33.tar.gz 928318
+SHA256 982c1b1ef0008698e6f8c635886e0102b97dac51f1dce2f49fdf1d7db36503f5 sussen-0.33.tar.gz 928318
diff --git a/net-analyzer/sussen/files/sussen-0.33-configopts-mono-1.1.13-fix.patch b/net-analyzer/sussen/files/sussen-0.33-configopts-mono-1.1.13-fix.patch
new file mode 100644
index 000000000000..8d772fb3b295
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.33-configopts-mono-1.1.13-fix.patch
@@ -0,0 +1,23 @@
+diff -Naur sussen-0.33.orig/agent/Main.cs sussen-0.33/agent/Main.cs
+--- sussen-0.33.orig/agent/Main.cs 2006-11-10 18:05:58.000000000 +0300
++++ sussen-0.33/agent/Main.cs 2006-12-14 14:47:43.000000000 +0300
+@@ -302,9 +302,16 @@
+ Config config = new Config ("windows");
+ #endif
+
+-
+- config.XmlDirectory = ConfigurationManager.AppSettings.Get("sussenXmlDirectory");
+- config.DownloadDirectory = ConfigurationManager.AppSettings.Get("sussenDownloadDirectory");
++ try {
++ config.XmlDirectory = ConfigurationManager.AppSettings.Get("sussenXmlDirectory");
++ config.DownloadDirectory = ConfigurationManager.AppSettings.Get("sussenDownloadDirectory");
++ } catch {
++#if MONO_BUILD
++ // Mono 1.1.13.x doesn't like the above two lines. Use old method if it fails.
++ config.XmlDirectory = ConfigurationSettings.AppSettings.Get ("sussenXmlDirectory");
++ config.DownloadDirectory = ConfigurationSettings.AppSettings.Get ("sussenDownloadDirectory");
++#endif
++ }
+
+ Repository.Initialize (config.XmlDirectory);
+ config.DefinitionsFile = Repository.GetResource (definitionFile);
diff --git a/net-analyzer/sussen/files/sussen-0.33-ignore-unsupported-test.patch b/net-analyzer/sussen/files/sussen-0.33-ignore-unsupported-test.patch
new file mode 100644
index 000000000000..b4a800534270
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.33-ignore-unsupported-test.patch
@@ -0,0 +1,12 @@
+diff -Naur sussen-0.33.orig/oval/Sussen.Oval/DataCollector.cs sussen-0.33/oval/Sussen.Oval/DataCollector.cs
+--- sussen-0.33.orig/oval/Sussen.Oval/DataCollector.cs 2006-12-03 01:00:37.000000000 +0300
++++ sussen-0.33/oval/Sussen.Oval/DataCollector.cs 2006-12-11 19:04:44.000000000 +0300
+@@ -106,6 +106,8 @@
+ Log.Debug(e);
+ docs.SystemCharacteristics.WrongPlatform.Add(testElement.ID, testElement.ID);
+ docs.SystemCharacteristics.WriteCollectedObject(oe.ID, oe.Version, Flags.NotApplicable);
++ } catch (Exception ie) {
++ // do nothing for now
+ }
+ }
+
diff --git a/net-analyzer/sussen/sussen-0.33.ebuild b/net-analyzer/sussen/sussen-0.33.ebuild
new file mode 100644
index 000000000000..17afc0299507
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.33.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.33.ebuild,v 1.1 2006/12/14 14:52:13 pva Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.8"
+inherit eutils gnome2 mono autotools
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+# web interface now optional, but does not work.
+#IUSE="doc gnome web"
+IUSE="doc gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="dev-lang/mono
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ ewarn "dbus support has been removed from sussen until mono binding"
+ ewarn "issue will be resolved: http://www.j5live.com/?p=221"
+ #ebeep 5
+
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+# src_unpack, pkg_postinst, pkg_postrm are exported in gnome2.eclass. But since
+# we have gnome2 support depends on USE let's call gnome2.eclass internal
+# functions only when USE="gnome".
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-ignore-unsupported-test.patch
+ epatch "${FILESDIR}"/${P}-configopts-mono-1.1.13-fix.patch
+ use gnome && gnome2_omf_fix
+}
+
+src_compile () {
+ # Put all asp pages in /usr/share/$PF dir instead of /usr/share/sussen
+ sed -i -e \
+ "s:wwwdir = \$(datadir)/doc/sussen/www/asp:wwwdir = \$(datadir)/doc/${PF}/www/asp:" \
+ www/asp/Makefile.in || die "sed failed."
+
+ # $(use_enable web yes)
+ econf ${myconf} \
+ --enable-web=no \
+ $(use_enable gnome) || die "./configure failed."
+
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ # Workaround bug in mono.
+ mkdir "${D}"/usr/share/sussen/xml/schema
+ mv "${D}"/usr/share/sussen/xml/*.xsd "${D}"/usr/share/sussen/xml/schema
+
+ dodoc ${DOCS}
+
+ if use gnome ; then
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it with the --tray-icon command line option."
+ echo
+ ewarn "sussen-editor is still work in progress... But 'new', 'save' and"
+ ewarn "'save as' operations are now implemented. Also it is possible to"
+ ewarn "execute definitions."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each user that run sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}