summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-01-31 07:34:53 +0000
committerPeter Volkov <pva@gentoo.org>2007-01-31 07:34:53 +0000
commit97d44a77d9c343097de9c1561478ab1a5efd7461 (patch)
treee344c7a84a9ce468100548cae6ca10044dc1a18f /net-analyzer/sussen
parentfix typo of gtkhtml (diff)
downloadgentoo-2-97d44a77d9c343097de9c1561478ab1a5efd7461.tar.gz
gentoo-2-97d44a77d9c343097de9c1561478ab1a5efd7461.tar.bz2
gentoo-2-97d44a77d9c343097de9c1561478ab1a5efd7461.zip
Version bump. Thank upstream dev Loren Bandiera for report and for regression fix.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/sussen')
-rw-r--r--net-analyzer/sussen/ChangeLog11
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.343
-rw-r--r--net-analyzer/sussen/files/sussen-0.34-sussen-out-of-range.patch54
-rw-r--r--net-analyzer/sussen/sussen-0.34.ebuild101
4 files changed, 167 insertions, 2 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index 2492b079fc03..c6821de72102 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/sussen
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.40 2006/12/14 14:52:13 pva Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.41 2007/01/31 07:34:53 pva Exp $
+
+*sussen-0.34 (31 Jan 2007)
+
+ 31 Jan 2007; <pva@gentoo.org>
+ +files/sussen-0.34-sussen-out-of-range.patch, +sussen-0.34.ebuild:
+ Version bump. Thank upstream dev Loren Bandiera for report and for
+ regression fix.
*sussen-0.33 (14 Dec 2006)
diff --git a/net-analyzer/sussen/files/digest-sussen-0.34 b/net-analyzer/sussen/files/digest-sussen-0.34
new file mode 100644
index 000000000000..caad7ac88f6d
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.34
@@ -0,0 +1,3 @@
+MD5 829f30b60dbdb86f80aa21c509e83bd3 sussen-0.34.tar.gz 949671
+RMD160 572527a2e57e68201cb5636cea75728753da42ad sussen-0.34.tar.gz 949671
+SHA256 1294416c51337db2275ec5691d36b9e10da349a95474bed52b5141dbaa133c0c sussen-0.34.tar.gz 949671
diff --git a/net-analyzer/sussen/files/sussen-0.34-sussen-out-of-range.patch b/net-analyzer/sussen/files/sussen-0.34-sussen-out-of-range.patch
new file mode 100644
index 000000000000..8a75e2cc7535
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.34-sussen-out-of-range.patch
@@ -0,0 +1,54 @@
+diff -Naur sussen-0.34.orig/oval/Sussen.Oval/DataCollector.cs sussen-0.34/oval/Sussen.Oval/DataCollector.cs
+--- sussen-0.34.orig/oval/Sussen.Oval/DataCollector.cs 2007-01-24 01:55:23.000000000 +0300
++++ sussen-0.34/oval/Sussen.Oval/DataCollector.cs 2007-01-31 09:36:28.000000000 +0300
+@@ -111,8 +111,15 @@
+
+ } catch (TestException e) {
+ Log.Debug(e);
+- docs.SystemCharacteristics.WrongPlatform.Add(testElement.ID, testElement.ID);
+- docs.SystemCharacteristics.WriteCollectedObject(oe.ID, oe.Version, Flags.NotApplicable);
++ if (!docs.SystemCharacteristics.WrongPlatform.ContainsKey (testElement.ID)) { docs.SystemCharacteristics.WrongPlatform.Add(testElement.ID, testElement.ID);
++ docs.SystemCharacteristics.WriteCollectedObject(oe.ID, oe.Version, Flags.NotApplicable);
++ }
++ } catch (ArgumentOutOfRangeException ex) {
++ Log.Debug (ex);
++ if (!docs.SystemCharacteristics.WrongPlatform.ContainsKey (testElement.ID)) {
++ docs.SystemCharacteristics.WrongPlatform.Add(testElement.ID, testElement.ID);
++ docs.SystemCharacteristics.WriteCollectedObject(oe.ID, oe.Version, Flags.NotApplicable);
++ }
+ }
+
+ Log.Debug("si.Count in complement: {0}", si.Count);
+diff -Naur sussen-0.34.orig/oval/Sussen.Oval/Variable.cs sussen-0.34/oval/Sussen.Oval/Variable.cs
+--- sussen-0.34.orig/oval/Sussen.Oval/Variable.cs 2007-01-24 01:55:23.000000000 +0300
++++ sussen-0.34/oval/Sussen.Oval/Variable.cs 2007-01-31 09:38:33.000000000 +0300
+@@ -385,15 +385,20 @@
+
+ if (oe.Entities.Count == 0) {
+ ObjectElement oe2 = Global.Objects[oe.Set.ObjectReferences[0]];
+- StateElement se2 = Global.States[oe.Set.Filters[0]];
+-
+- Test test = CreateTest(testName);
+- CollectedItem[] results = test.Run(null, oe2);
+-
+- CollectedItem ci = FilterSet(results, se2);
+- foreach (EntityObject ceo in ci.Items)
+- if (ceo.Name == itemField)
+- return ceo.Value;
++ StateElement se2 = Global.States[oe.Set.Filters[0]];
++
++ try {
++ Test test = CreateTest(testName);
++ CollectedItem[] results = test.Run(null, oe2);
++ CollectedItem ci = FilterSet(results, se2);
++ foreach (EntityObject ceo in ci.Items)
++ if (ceo.Name == itemField)
++ return ceo.Value;
++
++ } catch (Exception e) {
++ Log.Debug (e);
++ }
++
+
+ return null;
+ }
diff --git a/net-analyzer/sussen/sussen-0.34.ebuild b/net-analyzer/sussen/sussen-0.34.ebuild
new file mode 100644
index 000000000000..e234b9afc899
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.34.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.34.ebuild,v 1.1 2007/01/31 07:34:53 pva Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.8"
+inherit eutils gnome2 mono autotools
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+# web interface now optional, but does not work.
+#IUSE="doc gnome web"
+IUSE="doc gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="dev-lang/mono
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ ewarn "dbus support has been removed from sussen until mono binding"
+ ewarn "issue will be resolved: http://www.j5live.com/?p=221"
+ ebeep 5
+
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+# src_unpack, pkg_postinst, pkg_postrm are exported in gnome2.eclass. But since
+# we have gnome2 support depends on USE let's call gnome2.eclass internal
+# functions only when USE="gnome".
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-sussen-out-of-range.patch
+ use gnome && gnome2_omf_fix
+}
+
+src_compile () {
+ # Put all asp pages in /usr/share/$PF dir instead of /usr/share/sussen
+ sed -i -e \
+ "s:wwwdir = \$(datadir)/doc/sussen/www/asp:wwwdir = \$(datadir)/doc/${PF}/www/asp:" \
+ www/asp/Makefile.in || die "sed failed."
+
+ # $(use_enable web yes)
+ econf ${myconf} \
+ --enable-web=no \
+ $(use_enable gnome) || die "./configure failed."
+
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ # Workaround bug in mono.
+ mkdir "${D}"/usr/share/sussen/xml/schema
+ mv "${D}"/usr/share/sussen/xml/*.xsd "${D}"/usr/share/sussen/xml/schema
+
+ dodoc ${DOCS}
+
+ if use gnome ; then
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it with the --tray-icon command line option."
+ echo
+ ewarn "sussen-editor is still work in progress... But 'new', 'save' and"
+ ewarn "'save as' operations are now implemented. Also it is possible to"
+ ewarn "execute definitions."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each user that run sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}