summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-11-08 15:29:23 +0000
committerCédric Krier <cedk@gentoo.org>2008-11-08 15:29:23 +0000
commit844a3e48404704934365308b0b10446e8e45e3e8 (patch)
treee408a1d99e8e02b461729cb96a0202d5a1fb8236 /net-analyzer/tptest/tptest-3.1.7.ebuild
parentamd64 stable, bug 245970 (diff)
downloadgentoo-2-844a3e48404704934365308b0b10446e8e45e3e8.tar.gz
gentoo-2-844a3e48404704934365308b0b10446e8e45e3e8.tar.bz2
gentoo-2-844a3e48404704934365308b0b10446e8e45e3e8.zip
Fix C(XX)FLAGS and CC for bug #240866
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-analyzer/tptest/tptest-3.1.7.ebuild')
-rw-r--r--net-analyzer/tptest/tptest-3.1.7.ebuild41
1 files changed, 24 insertions, 17 deletions
diff --git a/net-analyzer/tptest/tptest-3.1.7.ebuild b/net-analyzer/tptest/tptest-3.1.7.ebuild
index c50cf0b2740e..8db0b0c43de5 100644
--- a/net-analyzer/tptest/tptest-3.1.7.ebuild
+++ b/net-analyzer/tptest/tptest-3.1.7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tptest/tptest-3.1.7.ebuild,v 1.2 2007/05/13 17:39:02 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tptest/tptest-3.1.7.ebuild,v 1.3 2008/11/08 15:29:23 cedk Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Internet bandwidth tester"
HOMEPAGE="http://tptest.sourceforge.net/"
@@ -11,32 +13,37 @@ KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE=""
DEPEND=">=sys-apps/sed-4"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A}
- cd ${S}/apps/unix/server
- sed -i "s:^CFLAGS\(.*\):CFLAGS\1 ${CFLAGS} :g" Makefile
+ cd "${S}"/apps/unix/server
+ sed -i \
+ -e "s:^CFLAGS =:CFLAGS+=:" \
+ -e "s:CC =:CC?=:" \
+ Makefile
+
+ cd "${S}"/apps/unix/client
+ sed -i \
+ -e "s:^CFLAGS =:CFLAGS+=:" \
+ -e "s:CC =:CC+=:" \
+ Makefile
- cd ${S}/apps/unix/client
- sed -i "s:^CFLAGS\(.*\):CFLAGS\1 ${CFLAGS} :g" Makefile
- cp -f ${S}/os-dep/unix/* .
- cp -f ${S}/engine/* .
+ cp -f "${S}"/os-dep/unix/* .
+ cp -f "${S}"/engine/* .
}
src_compile() {
- cd ${S}/apps/unix/server
- emake || die
+ cd "${S}"/apps/unix/server
+ emake CC=$(tc-getCC) || die "emake failed"
- cd ${S}/apps/unix/client
- emake || die
+ cd "${S}"/apps/unix/client
+ emake CC=$(tc-getCC) || die "emake failed"
}
src_install() {
- dobin ${S}/apps/unix/client/tptestclient
- dosbin ${S}/apps/unix/server/tptestserver
+ dobin "${S}"/apps/unix/client/tptestclient
+ dosbin "${S}"/apps/unix/server/tptestserver
insinto /etc
- doins ${S}/apps/unix/server/tptest.conf
+ doins "${S}"/apps/unix/server/tptest.conf
}