summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-11-01 04:17:10 +0000
committerJeroen Roovers <jer@gentoo.org>2010-11-01 04:17:10 +0000
commit93e254c149bc33e68a82af09d925ce1b447d5cda (patch)
treecdbca53e552b113e0a70b91ca9afffa6a0938ea6 /net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild
parentrevbump (diff)
downloadgentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.tar.gz
gentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.tar.bz2
gentoo-2-93e254c149bc33e68a82af09d925ce1b447d5cda.zip
Clean up patch (remove LIBTOOL dep and unset CFLAGS in configure.in, extend it (Makefile.am) so we can simply use emake install without trying to install empty/non-existent files, and do not set CFLAGS again (src/Makefile.am). Bug #343333.
(Portage version: 2.1.9.23/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild')
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild b/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild
new file mode 100644
index 000000000000..997579708f85
--- /dev/null
+++ b/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4-r2.ebuild,v 1.1 2010/11/01 04:17:09 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Scans the network for UPNP capable devices"
+HOMEPAGE="http://www.cqure.net/wp/upnpscan/"
+SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}