summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-06-04 20:40:58 +0000
committerJon Hood <squinky86@gentoo.org>2004-06-04 20:40:58 +0000
commit16b8462b5a6cab3392d87559758478bc895aeecd (patch)
tree645666f8b6a7789041a5c5c994831f24f4a32941 /net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild
parentAdded dev-ruby/ruby-amazon:geoip (diff)
downloadgentoo-2-16b8462b5a6cab3392d87559758478bc895aeecd.tar.gz
gentoo-2-16b8462b5a6cab3392d87559758478bc895aeecd.tar.bz2
gentoo-2-16b8462b5a6cab3392d87559758478bc895aeecd.zip
version bump, closes #51707
Diffstat (limited to 'net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild')
-rw-r--r--net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild b/net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild
new file mode 100644
index 000000000000..21f7126d0fcd
--- /dev/null
+++ b/net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xtraceroute/xtraceroute-0.9.1.ebuild,v 1.1 2004/06/04 20:40:58 squinky86 Exp $
+
+DESCRIPTION="neat graphical traceroute displaying route on the globe"
+SRC_URI="http://www.dtek.chalmers.se/~d3august/xt/dl/${P}.tar.gz
+ http://www.dtek.chalmers.se/~d3august/xt/dl/ndg_files.tar.gz"
+HOMEPAGE="http://www.dtek.chalmers.se/~d3august/xt/"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="nls"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ net-analyzer/traceroute
+ <x11-libs/gtkglarea-1.99.0
+ media-libs/gdk-pixbuf
+ net-misc/host"
+
+src_compile() {
+ # specify --from-code to fix bug 25395 (01 Aug 2003 agriffis)
+ XGETTEXT='/usr/bin/xgettext --from-code=ISO-8859-1' \
+ ./configure \
+ `use_enable nls` \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-host=/usr/bin/hostx \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+ # Install documentation.
+ dodoc AUTHORS NEWS README TODO || die "dodoc failed"
+
+ #Install NDG loc database
+ cd ${D}/usr/share/xtraceroute/
+ unpack "ndg_files.tar.gz"
+}