summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2013-01-18 18:51:53 +0000
committerMatthew Marlowe <mattm@gentoo.org>2013-01-18 18:51:53 +0000
commitdd58bc57ef31dc30da5bf37b6436a9e318ad370d (patch)
treeb96c8b2a4218fcaf2d150317e49a32abafbe88e1 /net-analyzer/zabbix
parentinitial import (diff)
downloadgentoo-2-dd58bc57ef31dc30da5bf37b6436a9e318ad370d.tar.gz
gentoo-2-dd58bc57ef31dc30da5bf37b6436a9e318ad370d.tar.bz2
gentoo-2-dd58bc57ef31dc30da5bf37b6436a9e318ad370d.zip
Fix for CVE-2013-1364, and upstream bug #ZBX-6097. Bumps 1.8.16 and 2.0.4-r1.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 786037A7)
Diffstat (limited to 'net-analyzer/zabbix')
-rw-r--r--net-analyzer/zabbix/ChangeLog13
-rw-r--r--net-analyzer/zabbix/files/2.0/patches/zbx6097.patch66
-rw-r--r--net-analyzer/zabbix/zabbix-1.8.16.ebuild (renamed from net-analyzer/zabbix/zabbix-2.0.2-r1.ebuild)106
-rw-r--r--net-analyzer/zabbix/zabbix-2.0.2-r2.ebuild395
-rw-r--r--net-analyzer/zabbix/zabbix-2.0.4-r1.ebuild (renamed from net-analyzer/zabbix/zabbix-2.0.4.ebuild)5
5 files changed, 103 insertions, 482 deletions
diff --git a/net-analyzer/zabbix/ChangeLog b/net-analyzer/zabbix/ChangeLog
index cca339ba0528..115dcb0efd40 100644
--- a/net-analyzer/zabbix/ChangeLog
+++ b/net-analyzer/zabbix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/zabbix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.111 2012/12/27 02:55:43 mattm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.112 2013/01/18 18:51:53 mattm Exp $
+
+*zabbix-2.0.4-r1 (18 Jan 2013)
+*zabbix-1.8.16 (18 Jan 2013)
+
+ 18 Jan 2013; Matthew Marlowe <mattm@gentoo.org>
+ +files/2.0/patches/zbx6097.patch, +zabbix-1.8.16.ebuild,
+ +zabbix-2.0.4-r1.ebuild, -zabbix-2.0.2-r1.ebuild, -zabbix-2.0.2-r2.ebuild,
+ -zabbix-2.0.4.ebuild:
+ Fix for CVE-2013-1364, and upstream bug #ZBX-6097. Bumps 1.8.16 and 2.0.4-r1.
*zabbix-2.0.4 (27 Dec 2012)
diff --git a/net-analyzer/zabbix/files/2.0/patches/zbx6097.patch b/net-analyzer/zabbix/files/2.0/patches/zbx6097.patch
new file mode 100644
index 000000000000..65d92a873f8e
--- /dev/null
+++ b/net-analyzer/zabbix/files/2.0/patches/zbx6097.patch
@@ -0,0 +1,66 @@
+Index: frontends/php/authentication.php
+===================================================================
+--- frontends/php/authentication.php (revision 32376)
++++ frontends/php/authentication.php (revision 32393)
+@@ -101,12 +101,11 @@
+ $config['authentication_type'] = $_REQUEST['config'];
+
+ // check login/password
+- $login = API::User()->ldapLogin(array(
+- 'user' => get_request('user', $USER_DETAILS['alias']),
+- 'password' => get_request('user_password', ''),
+- 'cnf' => $ldap_cnf
+- ));
++ $ldap = new CLdap($ldap_cnf);
++ $ldap->connect();
++ $login = $ldap->checkPass(get_request('user', $USER_DETAILS['alias']), get_request('user_password', ''));
+ if (!$login) {
++ error(_('Login name or password is incorrect'));
+ throw new Exception();
+ }
+
+@@ -129,12 +128,13 @@
+ }
+ elseif (isset($_REQUEST['test'])) {
+ // check login/password
+- $result = API::User()->ldapLogin(array(
+- 'user' => get_request('user', $USER_DETAILS['alias']),
+- 'password' => get_request('user_password', ''),
+- 'cnf' => $ldap_cnf
+- ));
++ $ldap = new CLdap($ldap_cnf);
++ $ldap->connect();
++ $result = $ldap->checkPass(get_request('user', $USER_DETAILS['alias']), get_request('user_password', ''));
+
++ if (!$result)
++ error(_('Login name or password is incorrect'));{
++ }
+ show_messages($result, _('LDAP login successful'), _('LDAP login was not successful'));
+ }
+ }
+Index: frontends/php/api/classes/CUser.php
+===================================================================
+--- frontends/php/api/classes/CUser.php (revision 32376)
++++ frontends/php/api/classes/CUser.php (revision 32393)
+@@ -822,15 +822,12 @@
+ // ******************************************************************************
+ // LOGIN Methods
+ // ******************************************************************************
+- public function ldapLogin($user) {
+- $cnf = isset($user['cnf']) ? $user['cnf'] : null;
+-
+- if (is_null($cnf)) {
+- $config = select_config();
+- foreach ($config as $id => $value) {
+- if (zbx_strpos($id, 'ldap_') !== false) {
+- $cnf[str_replace('ldap_', '', $id)] = $config[$id];
+- }
++ protected function ldapLogin($user) {
++ $config = select_config();
++ $cnf = array();
++ foreach ($config as $id => $value) {
++ if (zbx_strpos($id, 'ldap_') !== false) {
++ $cnf[str_replace('ldap_', '', $id)] = $config[$id];
+ }
+ }
+
diff --git a/net-analyzer/zabbix/zabbix-2.0.2-r1.ebuild b/net-analyzer/zabbix/zabbix-1.8.16.ebuild
index 814a3c0f3b80..24293d3630f9 100644
--- a/net-analyzer/zabbix/zabbix-2.0.2-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-1.8.16.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-2.0.2-r1.ebuild,v 1.1 2012/08/01 22:27:49 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.8.16.ebuild,v 1.1 2013/01/18 18:51:53 mattm Exp $
EAPI="2"
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit flag-o-matic webapp depend.php autotools java-pkg-opt-2 user
+inherit flag-o-matic webapp depend.php autotools user
DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers."
HOMEPAGE="http://www.zabbix.com/"
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="~amd64 ~x86"
-IUSE="agent java curl frontend ipv6 jabber ldap mysql openipmi oracle postgres proxy server ssh snmp sqlite iodbc odbc static"
+IUSE="agent curl frontend ipv6 jabber ldap mysql openipmi oracle postgres proxy server ssh snmp +sqlite iodbc odbc static"
COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
ldap? (
@@ -24,15 +24,14 @@ COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
=dev-libs/cyrus-sasl-2*
net-libs/gnutls
)
- mysql? ( >=virtual/mysql-5.0 )
- sqlite? ( >=dev-db/sqlite-3.3.5 )
- postgres? ( >=dev-db/postgresql-base-8.3.0 )
- oracle? ( >=dev-db/oracle-instantclient-basic-10.0.0.0 )
+ mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-3* )
+ postgres? ( dev-db/postgresql-base )
+ oracle? ( dev-db/oracle-instantclient-basic )
jabber? ( dev-libs/iksemel )
curl? ( net-misc/curl )
openipmi? ( sys-libs/openipmi )
ssh? ( net-libs/libssh2 )
- java? ( >=virtual/jdk-1.4 )
odbc? (
iodbc? ( dev-db/libiodbc )
!iodbc? ( dev-db/unixODBC )
@@ -42,13 +41,7 @@ RDEPEND="${COMMON_DEPEND}
proxy? ( <=net-analyzer/fping-2.9 )
server? ( <=net-analyzer/fping-2.9
app-admin/webapp-config )
- java? (
- >=virtual/jre-1.4
- dev-java/slf4j-api
- dev-java/json-simple
- )
- frontend? (
- dev-lang/php[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc]
+ frontend? ( dev-lang/php[bcmath,ctype,sockets,gd,truetype,xml,session]
media-libs/gd[png]
app-admin/webapp-config )"
DEPEND="${COMMON_DEPEND}
@@ -56,18 +49,6 @@ DEPEND="${COMMON_DEPEND}
use frontend && need_php_httpd
-S=${WORKDIR}/${MY_P}
-
-ZABBIXJAVA_BASE="opt/zabbix_java"
-
-java_prepare() {
- cd "${S}/src/zabbix_java/lib"
- rm -v *.jar || die
-
- java-pkg_jar-from slf4j-api
- java-pkg_jar-from json-simple
-}
-
src_prepare() {
eautoreconf
}
@@ -120,21 +101,14 @@ pkg_setup() {
pkg_postinst() {
if use server || use proxy ; then
elog
- elog "You may need to configure your database for Zabbix,"
- elog "if you have not already done so. Most minor version"
- elog "zabbix updates do not require db changes. However, "
- elog "you should read the release notes to be sure."
+ elog "You need to configure your database for Zabbix."
elog
- elog "Have a look at /usr/share/zabbix for"
+ elog "Have a look at /usr/share/zabbix/database for"
elog "database creation and upgrades."
elog
- elog "Execute schema, images, and data sql files in that order."
- elog
elog "For more info read the Zabbix manual at"
elog "http://www.zabbix.com/documentation.php"
elog
- elog "New use flags: java, odbc, iodbc"
- elog
zabbix_homedir=$(egethome zabbix)
if [ -n "${zabbix_homedir}" ] && \
@@ -167,7 +141,7 @@ pkg_postinst() {
elog "--"
elog
- elog "You may need to add these lines to /etc/services:"
+ elog "Add these lines in the /etc/services :"
elog
elog "zabbix-agent 10050/tcp Zabbix Agent"
elog "zabbix-agent 10050/udp Zabbix Agent"
@@ -177,9 +151,6 @@ pkg_postinst() {
elog "Zabbix is incompatible with fping 3.0 - (Zabbix bug #ZBX-4894)."
elog
- elog "Feel free to download or contribute gentoo specific zabbix templates"
- elog "via https://github.com/deploylinux/gentooZabbixTemplates (WIP). We may"
- elog "eventually create a seperate package in portage for them."
# repeat fowners/fperms functionality from src_install()
# here to catch wrong permissions on existing files in
@@ -245,11 +216,10 @@ src_configure() {
$(use_enable agent) \
$(use_enable ipv6) \
$(use_enable static) \
- $(use_enable java) \
$(use_with ldap) \
$(use_with snmp net-snmp) \
$(use_with mysql) \
- $(use_with postgres postgresql) \
+ $(use_with postgres pgsql) \
$(use_with oracle) \
$(use_with sqlite sqlite3) \
$(use_with jabber) \
@@ -282,15 +252,15 @@ src_install() {
"${FILESDIR}/1.6.6"/zabbix_server.conf \
"${FILESDIR}/1.6.6"/zabbix_trapper.conf
doinitd \
- "${FILESDIR}/2.0"/init.d/zabbix-server
+ "${FILESDIR}/1.6.6"/init.d/zabbix-server
dosbin \
src/zabbix_server/zabbix_server
dodir \
- /usr/share/zabbix
- insinto /usr/share/zabbix
+ /usr/share/zabbix/database
+ insinto /usr/share/zabbix/database
doins -r \
- database \
- upgrades
+ upgrades \
+ create
fowners zabbix:zabbix \
/etc/zabbix/zabbix_server.conf \
/etc/zabbix/zabbix_trapper.conf
@@ -308,10 +278,10 @@ src_install() {
doins \
"${FILESDIR}/1.6.6"/zabbix_proxy.conf
dodir \
- /usr/share/zabbix
- insinto /usr/share/zabbix
+ /usr/share/zabbix/database
+ insinto /usr/share/zabbix/database
doins -r \
- database \
+ upgrades \
create
fi
@@ -321,7 +291,7 @@ src_install() {
"${FILESDIR}/1.6.6"/zabbix_agent.conf \
"${FILESDIR}/1.6.6"/zabbix_agentd.conf
doinitd \
- "${FILESDIR}/2.0"/init.d/zabbix-agentd
+ "${FILESDIR}/1.6.6"/init.d/zabbix-agentd
dosbin \
src/zabbix_agent/zabbix_agent \
src/zabbix_agent/zabbix_agentd
@@ -351,13 +321,7 @@ src_install() {
/var/log/zabbix \
/var/run/zabbix
- dodoc README INSTALL NEWS ChangeLog \
- conf/zabbix_agent.conf \
- conf/zabbix_agentd.conf \
- conf/zabbix_proxy.conf \
- conf/zabbix_agentd/userparameter_examples.conf \
- conf/zabbix_agentd/userparameter_mysql.conf \
- conf/zabbix_server.conf
+ dodoc README INSTALL NEWS ChangeLog
if use frontend; then
webapp_src_preinst
@@ -368,28 +332,4 @@ src_install() {
"${MY_HTDOCSDIR}"/include/config.inc.php
webapp_src_install
fi
-
- if use java; then
- dodir \
- /${ZABBIXJAVA_BASE} \
- /${ZABBIXJAVA_BASE}/bin \
- /${ZABBIXJAVA_BASE}/lib
- keepdir /${ZABBIXJAVA_BASE}
- exeinto /${ZABBIXJAVA_BASE}/bin
- doexe src/zabbix_java/bin/zabbix-java-gateway-2.0.0rc3.jar
- exeinto /${ZABBIXJAVA_BASE}/lib
- doexe \
- src/zabbix_java/lib/logback-classic-0.9.27.jar \
- src/zabbix_java/lib/logback-console.xml \
- src/zabbix_java/lib/logback-core-0.9.27.jar \
- src/zabbix_java/lib/logback.xml \
- src/zabbix_java/lib/org-json-2010-12-28.jar \
- src/zabbix_java/lib/slf4j-api-1.6.1.jar
- exeinto /${ZABBIXJAVA_BASE}/
- src/zabbix_java/settings.sh \
- src/zabbix_java/startup.sh \
- src/zabbix_java/shutdown.sh
- fowners -R zabbix:zabbix /${ZABBIXJAVA_BASE}
- fi
-
}
diff --git a/net-analyzer/zabbix/zabbix-2.0.2-r2.ebuild b/net-analyzer/zabbix/zabbix-2.0.2-r2.ebuild
deleted file mode 100644
index d6267ba89c70..000000000000
--- a/net-analyzer/zabbix/zabbix-2.0.2-r2.ebuild
+++ /dev/null
@@ -1,395 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-2.0.2-r2.ebuild,v 1.1 2012/10/02 05:34:04 mattm Exp $
-
-EAPI="2"
-
-# needed to make webapp-config dep optional
-WEBAPP_OPTIONAL="yes"
-inherit flag-o-matic webapp depend.php autotools java-pkg-opt-2 user
-
-DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers."
-HOMEPAGE="http://www.zabbix.com/"
-MY_P=${P/_/}
-SRC_URI="http://prdownloads.sourceforge.net/zabbix/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-WEBAPP_MANUAL_SLOT="yes"
-KEYWORDS="~amd64 ~x86"
-IUSE="agent java curl frontend ipv6 jabber ldap mysql openipmi oracle postgres proxy server ssh snmp sqlite iodbc odbc static"
-
-COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
- ldap? (
- net-nds/openldap
- =dev-libs/cyrus-sasl-2*
- net-libs/gnutls
- )
- mysql? ( >=virtual/mysql-5.0 )
- sqlite? ( >=dev-db/sqlite-3.3.5 )
- postgres? ( >=dev-db/postgresql-base-8.3.0 )
- oracle? ( >=dev-db/oracle-instantclient-basic-10.0.0.0 )
- jabber? ( dev-libs/iksemel )
- curl? ( net-misc/curl )
- openipmi? ( sys-libs/openipmi )
- ssh? ( net-libs/libssh2 )
- java? ( >=virtual/jdk-1.4 )
- odbc? (
- iodbc? ( dev-db/libiodbc )
- !iodbc? ( dev-db/unixODBC )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- proxy? ( <=net-analyzer/fping-2.9 )
- server? ( <=net-analyzer/fping-2.9
- app-admin/webapp-config )
- java? (
- >=virtual/jre-1.4
- dev-java/slf4j-api
- dev-java/json-simple
- )
- frontend? (
- dev-lang/php[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
- || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )
- media-libs/gd[png]
- app-admin/webapp-config )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-ZABBIXJAVA_BASE="opt/zabbix_java"
-
-java_prepare() {
- cd "${S}/src/zabbix_java/lib"
- rm -v *.jar || die
-
- java-pkg_jar-from slf4j-api
- java-pkg_jar-from json-simple
-}
-
-src_prepare() {
- eautoreconf
-}
-
-pkg_setup() {
- if use server || use proxy ; then
- local dbnum dbtypes="mysql oracle postgres sqlite" dbtype
- declare -i dbnum=0
- for dbtype in ${dbtypes}; do
- use ${dbtype} && let dbnum++
- done
- if [ ${dbnum} -gt 1 ]; then
- eerror
- eerror "You can't use more than one database type in Zabbix."
- eerror "Select exactly one database type out of these: ${dbtypes}"
- eerror
- die "Multiple database types selected."
- elif [ ${dbnum} -lt 1 ]; then
- eerror
- eerror "Select exactly one database type out of these: ${dbtypes}"
- eerror
- die "No database type selected."
- fi
- if use oracle; then
- if [ -z "${ORACLE_HOME}" ]; then
- eerror
- eerror "The environment variable ORACLE_HOME must be set"
- eerror "and point to the correct location."
- eerror "It looks like you don't have Oracle installed."
- eerror
- die "Environment variable ORACLE_HOME is not set"
- fi
- if has_version 'dev-db/oracle-instantclient-basic'; then
- ewarn
- ewarn "Please ensure you have a full install of the Oracle client."
- ewarn "dev-db/oracle-instantclient* is NOT sufficient."
- ewarn
- fi
- fi
- fi
-
- if use frontend; then
- webapp_pkg_setup
- fi
-
- enewgroup zabbix
- enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
-}
-
-pkg_postinst() {
- if use server || use proxy ; then
- elog
- elog "You may need to configure your database for Zabbix,"
- elog "if you have not already done so. Most minor version"
- elog "zabbix updates do not require db changes. However, "
- elog "you should read the release notes to be sure."
- elog
- elog "Have a look at /usr/share/zabbix for"
- elog "database creation and upgrades."
- elog
- elog "Execute schema, images, and data sql files in that order."
- elog
- elog "For more info read the Zabbix manual at"
- elog "http://www.zabbix.com/documentation.php"
- elog
- elog "New use flags: java, odbc, iodbc"
- elog
-
- zabbix_homedir=$(egethome zabbix)
- if [ -n "${zabbix_homedir}" ] && \
- [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
- ewarn
- ewarn "The user 'zabbix' should have his homedir changed"
- ewarn "to /var/lib/zabbix/home if you want to use"
- ewarn "custom alert scripts."
- ewarn
- ewarn "A real homedir might be needed for configfiles"
- ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
- ewarn "using sendxmpp for Jabber alerts)."
- ewarn
- ewarn "To change the homedir use:"
- ewarn " usermod -d /var/lib/zabbix/home zabbix"
- ewarn
- fi
- fi
-
- if use server; then
- elog
- elog "For distributed monitoring you have to run:"
- elog
- elog "zabbix_server -n <nodeid>"
- elog
- elog "This will convert database data for use with Node ID"
- elog "and also adds a local node."
- elog
- fi
-
- elog "--"
- elog
- elog "You may need to add these lines to /etc/services:"
- elog
- elog "zabbix-agent 10050/tcp Zabbix Agent"
- elog "zabbix-agent 10050/udp Zabbix Agent"
- elog "zabbix-trapper 10051/tcp Zabbix Trapper"
- elog "zabbix-trapper 10051/udp Zabbix Trapper"
- elog
-
- elog "Zabbix is incompatible with fping 3.0 - (Zabbix bug #ZBX-4894)."
- elog
- elog "Feel free to download or contribute gentoo specific zabbix templates"
- elog "via https://github.com/deploylinux/gentooZabbixTemplates (WIP). We may"
- elog "eventually create a seperate package in portage for them."
-
- # repeat fowners/fperms functionality from src_install()
- # here to catch wrong permissions on existing files in
- # the live filesystem (yeah, that sucks).
- chown -R zabbix:zabbix \
- "${ROOT}"/etc/zabbix \
- "${ROOT}"/var/lib/zabbix \
- "${ROOT}"/var/lib/zabbix/home \
- "${ROOT}"/var/lib/zabbix/scripts \
- "${ROOT}"/var/log/zabbix \
- "${ROOT}"/var/run/zabbix
- chmod 0750 \
- "${ROOT}"/etc/zabbix \
- "${ROOT}"/var/lib/zabbix \
- "${ROOT}"/var/lib/zabbix/home \
- "${ROOT}"/var/lib/zabbix/scripts \
- "${ROOT}"/var/log/zabbix \
- "${ROOT}"/var/run/zabbix
-
- chmod 0640 \
- "${ROOT}"/etc/zabbix/zabbix_*
-
- if use server || use proxy ; then
- # check for fping
- fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
- case "${fping_perms}" in
- 4[157][157][157])
- ;;
- *)
- ewarn
- ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
- ewarn "you have to make /usr/sbin/fping setuid root and executable"
- ewarn "by everyone. Run the following command to fix it:"
- ewarn
- ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
- ewarn
- ewarn "Please be aware that this might impose a security risk,"
- ewarn "depending on the code quality of fping."
- ewarn
- ebeep 3
- epause 5
- ;;
- esac
- fi
-}
-
-src_configure() {
-
- local myconf
-
- if use odbc && use iodbc ; then
- myconf="${myconf} --with-iodbc --without-unixodbc"
- elif use odbc && ! use iodbc; then
- myconf="${myconf} --with-unixodbc --without-iodbc"
- else
- myconf="${myconf} --without-unixodbc --without-iodbc"
- fi
-
- econf \
- $myconf \
- $(use_enable server) \
- $(use_enable proxy) \
- $(use_enable agent) \
- $(use_enable ipv6) \
- $(use_enable static) \
- $(use_enable java) \
- $(use_with ldap) \
- $(use_with snmp net-snmp) \
- $(use_with mysql) \
- $(use_with postgres postgresql) \
- $(use_with oracle) \
- $(use_with sqlite sqlite3) \
- $(use_with jabber) \
- $(use_with curl libcurl) \
- $(use_with openipmi openipmi) \
- $(use_with ssh ssh2) \
- || die "econf failed"
-}
-
-src_install() {
- dodir \
- /etc/zabbix \
- /var/lib/zabbix \
- /var/lib/zabbix/home \
- /var/lib/zabbix/scripts \
- /var/log/zabbix \
- /var/run/zabbix
-
- keepdir \
- /etc/zabbix \
- /var/lib/zabbix \
- /var/lib/zabbix/home \
- /var/lib/zabbix/scripts \
- /var/log/zabbix \
- /var/run/zabbix
-
- if use server; then
- insinto /etc/zabbix
- doins \
- "${FILESDIR}/1.6.6"/zabbix_server.conf \
- "${FILESDIR}/1.6.6"/zabbix_trapper.conf
- doinitd \
- "${FILESDIR}/2.0"/init.d/zabbix-server
- dosbin \
- src/zabbix_server/zabbix_server
- dodir \
- /usr/share/zabbix
- insinto /usr/share/zabbix
- doins -r \
- database \
- upgrades
- fowners zabbix:zabbix \
- /etc/zabbix/zabbix_server.conf \
- /etc/zabbix/zabbix_trapper.conf
- fperms 0640 \
- /etc/zabbix/zabbix_server.conf \
- /etc/zabbix/zabbix_trapper.conf
- fi
-
- if use proxy; then
- doinitd \
- "${FILESDIR}/1.6.6"/init.d/zabbix-proxy
- dosbin \
- src/zabbix_proxy/zabbix_proxy
- insinto /etc/zabbix
- doins \
- "${FILESDIR}/1.6.6"/zabbix_proxy.conf
- dodir \
- /usr/share/zabbix
- insinto /usr/share/zabbix
- doins -r \
- database \
- create
- fi
-
- if use agent; then
- insinto /etc/zabbix
- doins \
- "${FILESDIR}/1.6.6"/zabbix_agent.conf \
- "${FILESDIR}/1.6.6"/zabbix_agentd.conf
- doinitd \
- "${FILESDIR}/2.0"/init.d/zabbix-agentd
- dosbin \
- src/zabbix_agent/zabbix_agent \
- src/zabbix_agent/zabbix_agentd
- dobin \
- src/zabbix_sender/zabbix_sender \
- src/zabbix_get/zabbix_get
- fowners zabbix:zabbix \
- /etc/zabbix/zabbix_agent.conf \
- /etc/zabbix/zabbix_agentd.conf
- fperms 0640 \
- /etc/zabbix/zabbix_agent.conf \
- /etc/zabbix/zabbix_agentd.conf
- fi
-
- fowners zabbix:zabbix \
- /etc/zabbix \
- /var/lib/zabbix \
- /var/lib/zabbix/home \
- /var/lib/zabbix/scripts \
- /var/log/zabbix \
- /var/run/zabbix
- fperms 0750 \
- /etc/zabbix \
- /var/lib/zabbix \
- /var/lib/zabbix/home \
- /var/lib/zabbix/scripts \
- /var/log/zabbix \
- /var/run/zabbix
-
- dodoc README INSTALL NEWS ChangeLog \
- conf/zabbix_agent.conf \
- conf/zabbix_agentd.conf \
- conf/zabbix_proxy.conf \
- conf/zabbix_agentd/userparameter_examples.conf \
- conf/zabbix_agentd/userparameter_mysql.conf \
- conf/zabbix_server.conf
-
- if use frontend; then
- webapp_src_preinst
- cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
- webapp_postinst_txt en "${FILESDIR}/"1.6.6/postinstall-en.txt
- webapp_configfile \
- "${MY_HTDOCSDIR}"/include/db.inc.php \
- "${MY_HTDOCSDIR}"/include/config.inc.php
- webapp_src_install
- fi
-
- if use java; then
- dodir \
- /${ZABBIXJAVA_BASE} \
- /${ZABBIXJAVA_BASE}/bin \
- /${ZABBIXJAVA_BASE}/lib
- keepdir /${ZABBIXJAVA_BASE}
- exeinto /${ZABBIXJAVA_BASE}/bin
- doexe src/zabbix_java/bin/zabbix-java-gateway-${PV}.jar
- exeinto /${ZABBIXJAVA_BASE}/lib
- doexe \
- src/zabbix_java/lib/logback-classic-0.9.27.jar \
- src/zabbix_java/lib/logback-console.xml \
- src/zabbix_java/lib/logback-core-0.9.27.jar \
- src/zabbix_java/lib/logback.xml \
- src/zabbix_java/lib/org-json-2010-12-28.jar \
- src/zabbix_java/lib/slf4j-api-1.6.1.jar
- exeinto /${ZABBIXJAVA_BASE}/
- doexe \
- src/zabbix_java/settings.sh \
- src/zabbix_java/startup.sh \
- src/zabbix_java/shutdown.sh
- fowners -R zabbix:zabbix /${ZABBIXJAVA_BASE}
- fi
-
-}
diff --git a/net-analyzer/zabbix/zabbix-2.0.4.ebuild b/net-analyzer/zabbix/zabbix-2.0.4-r1.ebuild
index da2ebaacafcf..eba2839a9c38 100644
--- a/net-analyzer/zabbix/zabbix-2.0.4.ebuild
+++ b/net-analyzer/zabbix/zabbix-2.0.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-2.0.4.ebuild,v 1.1 2012/12/27 02:55:43 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-2.0.4-r1.ebuild,v 1.1 2013/01/18 18:51:53 mattm Exp $
EAPI="2"
@@ -68,6 +68,7 @@ java_prepare() {
}
src_prepare() {
+ epatch "${FILESDIR}/2.0/patches/zbx6097.patch"
eautoreconf
}