summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-27 23:13:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-27 23:13:28 +0000
commit016be1842c01a8daa4119493781ae92ac849b1f5 (patch)
treec802c17ff2b8043ff02a3ead3f836fc51c347e02 /net-analyzer
parenttidy (Manifest recommit) (diff)
downloadgentoo-2-016be1842c01a8daa4119493781ae92ac849b1f5.tar.gz
gentoo-2-016be1842c01a8daa4119493781ae92ac849b1f5.tar.bz2
gentoo-2-016be1842c01a8daa4119493781ae92ac849b1f5.zip
Add a patch from debian to handle /etc/services better.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netcat/ChangeLog7
-rw-r--r--net-analyzer/netcat/files/digest-netcat-110-r73
-rw-r--r--net-analyzer/netcat/netcat-110-r7.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/net-analyzer/netcat/ChangeLog b/net-analyzer/netcat/ChangeLog
index 33f676498dfe..35024b9d520e 100644
--- a/net-analyzer/netcat/ChangeLog
+++ b/net-analyzer/netcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/netcat
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.25 2004/07/01 20:02:16 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.26 2004/12/27 23:13:28 vapier Exp $
+
+*netcat-110-r7 (27 Dec 2004)
+
+ 27 Dec 2004; Mike Frysinger <vapier@gentoo.org> +netcat-110-r7.ebuild:
+ Add a patch from debian to handle /etc/services better.
01 Jul 2004; Jon Hood <squinky86@gentoo.org> netcat-110-r5.ebuild,
netcat-110-r6.ebuild:
diff --git a/net-analyzer/netcat/files/digest-netcat-110-r7 b/net-analyzer/netcat/files/digest-netcat-110-r7
new file mode 100644
index 000000000000..9a79f05455f4
--- /dev/null
+++ b/net-analyzer/netcat/files/digest-netcat-110-r7
@@ -0,0 +1,3 @@
+MD5 402632f2fe01c169ff19a0ad6e9d608c nc110.tgz 75267
+MD5 84d850745dd860aedce64b518e0e3330 nc-v6-20000918.patch.gz 8740
+MD5 4ef287f5e3198780597f5726f16e9b3d netcat-110-r7-gentoo-deb-patches.tbz2 13809
diff --git a/net-analyzer/netcat/netcat-110-r7.ebuild b/net-analyzer/netcat/netcat-110-r7.ebuild
new file mode 100644
index 000000000000..f663a2b4c81e
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r7.ebuild,v 1.1 2004/12/27 23:13:28 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P=nc${PV}
+DESCRIPTION="the network swiss army knife"
+HOMEPAGE="http://www.securityfocus.com/tools/137"
+SRC_URI="http://www.atstake.com/research/tools/network_utilities/${MY_P}.tgz
+ ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz
+ mirror://gentoo/${PF}-gentoo-deb-patches.tbz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ipv6 static crypt GAPING_SECURITY_HOLE"
+
+DEPEND="virtual/libc
+ crypt? ( dev-libs/libmix )"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${MY_P}.tgz
+ unpack ${PF}-gentoo-deb-patches.tbz2
+ epatch ${DISTDIR}/nc-v6-20000918.patch.gz
+ EPATCH_SUFFIX="patch" epatch ${S}/patches
+ sed -i 's:#define HAVE_BIND:#undef HAVE_BIND:' netcat.c
+ sed -i 's:#define FD_SETSIZE 16:#define FD_SETSIZE 1024:' netcat.c #34250
+}
+
+src_compile() {
+ export XLIBS=""
+ export XFLAGS="-DLINUX -DTELNET"
+ use ipv6 && XFLAGS="${XFLAGS} -DINET6"
+ use static && export STATIC="-static"
+ use crypt && XFLAGS="${XFLAGS} -DAESCRYPT" && XLIBS="${XLIBS} -lmix"
+ use GAPING_SECURITY_HOLE && XFLAGS="${XFLAGS} -DGAPING_SECURITY_HOLE"
+ CC="$(tc-getCC) ${CFLAGS}" make -e nc || die
+}
+
+src_install() {
+ dobin nc || die "dobin failed"
+ dodoc README* netcat.blurb
+ doman nc.1
+ docinto scripts
+ dodoc scripts/*
+}